Why did you change the path? Shortcuts etc. break!

2»

Comments

  • OK. Hope you can find a way to let your Apps work together!

  • MikeTMikeT Agile Samurai

    Team Member

    Yep, plus we have some other ideas we want to try in future updates to avoid Hitman's interaction with us but it's not a sure thing.

  • MikeTMikeT Agile Samurai

    Team Member
    edited December 2018

    Hi @XIII,

    I can't reproduce the HitmanPro.Alert interfering with 1Password's Secure Desktop. Can you update Hitman and let me know if it works for you too?

    [Update: never mind, I see the thread at Wilders Security]

    I'm not seeing any more issues with Secure Desktop at the moment. Will try to investigate the CallerCheck issue.

  • I actually don't get an alert for Secure Desktop, I think:

    • I get an alert as soon as I start 1Password
    • Clicking on the Secure Desktop button does nothing (so also not generating a HitmanPro.Alert alert)
  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    @XIII,

    There are no alerts, it just prevents 1Password from doing it. As soon as I install HMP.A, it stops working completely. Uninstall, it works again. There are no alert, no event viewer logs, nothing. I'll keep investigating but it may have to wait a bit as we're still heavy in development for 7.3.

    @wkleem, we didn't change any paths for the 7.2.617 update, it was only to update our approved certificates list for Chrome and to use a new certificate for 1Password as well.

  • kop48kop48 Junior Member

    @XIII - I'd recommend not using any antivirus on Windows other than Windows Defender. Most AVs are far too invasive, and don't add any value (often, they add negative value).

    @MikeT - I have the shortcut in my Start Menu, but it's also pointing to a location that doesn't exist.

    This is the path that the shortcut points to:
    C:\Users\jonat\AppData\Local\1Password\app\7.3.612\1Password.exe

    This is the path of 1Password:
    C:\Users\jonat\AppData\Local\1Password\app\7.3.619\1Password.exe

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @kop48,

    We're trying to figure out a way to avoid changing paths from now on, we'll have a new method for the next update.

  • Since 7.3.619 the Link is completely broken:


    For me it's no problem, I could change it myself but I think this shouldn't happen :+1:

  • MikeTMikeT Agile Samurai

    Team Member
    edited December 2018

    Yep, we're going to kill the dynamic location and try to force Windows to rename the versioned folder to the 7 folder that we had before. It should give us the best of both worlds and if it does work, it'll fix the shortcut issue.

    We're working on it right now as we speak but there are some oddities with the renaming process. Hopefully, not too long before we have the next beta update out.

  • lumarellumarel
    edited December 2018

    I hope this works well then for everybody :+1:
    It would be so great if this stops to make any problems for you.

    Ok that sounds awesome :chuffed:
    But I hope you're not killing your vacations due to these issues :unamused:

    So.. happy christmas time!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @lumarel,

    Happy Holidays to you as well.

    Most of our team are out on vacation but a few of us are still around to keep improving the betas and we'll get our time off after they're back.

  • Not sure what happened, but the 1Password shortcut in the Start Menu now shows a default Windows icon instead of the 1Password icon.

    (the icon is the tray is still OK)

  • MikeTMikeT Agile Samurai

    Team Member

    Hi folks,

    We've just shipped 7.3.639 Beta 4 with installer-related changes, it should now only install to the same location as before.

    Check for the update by opening the 1Password menu in the main 1Password window and let us know how it turns out.

    Shortcuts should be updated properly as well but you may have to re-pin 1Password in other areas.

  • XIIIXIII
    edited December 2018

    The icon was actually gone... (hence the default Windows icon)

    So I installed Beta 4. Again: possible to add it to task bar (only), not to the start menu...

    (1Password in menu only has option "Open")

    Manually added it myself for C:\Users\XIII\AppData\Local\1Password\app\7. Is this the path you will be using from now on?

  • @XII yes, %LOCALAPPDATA%\1Password\app\7 is the home of 1Password 7. We tried to get away from "file in use" updater issues by using versioned folders, but it started to break too many things for people. So we reverted to use same location, but improved our updater to combat "file in use" issue by asking user to click "Retry" button. Hopefully you won't even see it, but it's there.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @XIII,

    Are you saying that when you installed 7.3.639 beta 4 update, it did not install the new shortcut to your app menu at all, you didn't see it in Recent list or in # section of the app list?

  • As far as I can see everything updated just fine, so the shortcut as well :+1::chuffed:
    Thanks!

  • MikeTMikeT Agile Samurai

    Team Member

    Awesome, thanks for letting us know!

  • @MikeT @SergeyTheAgile
    Thank you for reverting the build folder shortcut change. It was very annoying to keep getting Internet access requests for every new build from Win10 Firewall Control and having to re-do my 1PW shortcut i keep in special folder.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @mia,

    You're welcome.

    We didn't actually revert it but improved the approach to rename it to the previous locations, so we ended up with the best of both worlds; installing new updates to versioned folder and then do a complex process of rename multiple folders. Hopefully, this works.

  • XIIIXIII
    edited December 2018

    Are you saying that when you installed 7.3.639 beta 4 update, it did not install the new shortcut to your app menu at all, you didn't see it in Recent list or in # section of the app list?

    Yes; I even performed a search on the C: drive for “1Password*.*”, but did not find a shortcut.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @XIII,

    That is really really weird. I trashed all instances and i ran the installer, it installed it for me.

    Could it have been blocked by HMP.A?

  • Could it have been blocked by HMP.A?

    Unlikely, as I did not get any alerts.

  • brentybrenty

    Team Member

    Thanks for checking. Strange.

  • MikeTMikeT Agile Samurai

    Team Member
    edited December 2018

    Well, HMP.A did block Secure Desktop and a few other things that didn't generate any alerts, so I can't be sure that's not the case.

    We'll keep investigating but we can't reproduce anything like that on a normal setup.

This discussion has been closed.