1P 7.2.4 un-minimizes itself automatically

Can't say how much I admire the work of the Agilebits team and rely on 1P for Mac. Thank you!

Not a complaint - just something I've noticed since updating to 7.2.4 (on 10.14.2): when I close other applications' and Finder windows, 1Password nearly always 'maximizes' itself and comes to the fore… I typically launch and run it all day, minimizing it into the Dock when not in use.

Intentional? Feature? Bug? Convenience? New?

Thanks!


1Password Version: 7.2.4
Extension Version: (7.2.4)
OS Version: 10.14.2
Sync Type: Agile

Comments

  • LarsLars Junior Member

    Team Member

    @Mark Sealey - thanks for the kind words! :) I'd have to see more closely under what specific conditions 1Password does (or does not) exhibit this behavior. I took your use of "maximize" to be that it grew to the entire screen size, not just that it reappeared when previously hidden in the Dock. If you meant the latter -- that it's just popping back up, in regular size, as you're closing other things, the explanation for that may be as simple as whatever the most-recent application switching may have been. If you previously had 1Password selected, then moved on to other apps, but you wind up closing those apps, focus will shift to the last-used app. If that was 1Password, it may well reappear. Are you able to re-hide it when that happens?

    If you meant "maximize" in the sense of expanding to the entire screen, that's definitely not expected behavior. Can you clarify for me?

  • Lars,

    I am sorry: I did not describe what happens very well :-(

    I should not have said 'maximize'. But that 1P does indeed 'pop back up' from being 'hidden' in the Dock, Yes.

    Fo instance, when (and I don't think there's a 100% reproducible pattern) I quit, say, Safari (though the phenomenon may indeed be tied to one specific app that I haven't noticed (and/)or one type of app) so that there is nothing else open - except the hidden 1P, the latter 'jumps up' from the Dock to become visible again. (Nothing to do with (1P's) size.)

    This is indeed the sequence that you describe…

    …if you previously had 1Password selected…

    but it's surely new. Have been using 1P since almost the first version. This certainly appears like new behavior :) I'm almost 100% sure that - prior to 7.2.4 (MAS) - 1P stayed 'Docked'; and that focus did not switch to 1P as the last app used - at least not by bringing it back to its former size on the desktop.

    If you know I'm wrong, and must just not have noticed it, I'm also quite happy! Thanks, Lars :)

  • LarsLars Junior Member

    Team Member

    @Mark Sealey - hmmm, I'm not quite sure what might cause that off the top of my head. I can't get it to happen here. I assume you've restarted your Mac since you've noticed this happening? If not, it might be worth a try. If the behavior continues and it bothers you, let us know and include specific steps to reproduce: apps running when it occurs, exact steps taken to produce the behavior, specific versions of macOS, of 1Password, etc.

  • Thanks again, Lars.

    Yes, I restart daily.

    This has been happening only since 7.2.4 - so I'd have thought some new code therein?

    I'll pay attention and advise here which apps were running when it next happens.

    If I had tout money on it (though please don't take it :) ), I'd say that 1P 'reappears' after having been banished to the Dock if and when it is the only remaining single app.

    I'll test and post back. Thanks for your help!

  • LarsLars Junior Member

    Team Member

    @Mark Sealey - even in such a case, the Finder is still running, which means that Finder should be capable of being the front-most app (which would allow you to keep 1Password in a hidden state). If you can nail down specific conditions under which this happens, let me know.

  • Lars,

    Thanks so much for following this!

    These are the steps that work invariably for me (and both before and after installing this morning's 10.14.3 update):

    1. (Re)boot
    2. launch Mail; use it
    3. launch Safari; use it
    4. launch 1P; enter password; do not necessarily use it
    5. put 1P away into Dock
    6. quit Mail
    7. quit Safari
    8. 1P genie's itself out of dock… own window (resizable) on desktop.

    Hope that helps!

  • LarsLars Junior Member

    Team Member

    @Mark Sealey - thanks! Can you elaborate a bit on #5 above? What does "put 1p away into Dock" mean? -- how are you doing this/what are you doing to "put it away into dock?"

  • Of course, Lars; I'm sorry: single-click on orange icon second from left top left:

  • All,

    I am experiencing exactly the same thing and I'm positive it started with the latest upgrade to Version 7.2.4 on my MacBook running macOS Mojave Version 10.14.3 although it happened in the previous Mojave build as well. I am a longtime 1P user as well and after I power on my MacBook the first thing I do is to launch 1P and minimize it. I like having it available in the dock versus launching with hot-keys, etc.

    If there's a way to correct this I'd be thrilled!

  • LarsLars Junior Member

    Team Member

    @Mark Sealey - thanks for clarifying. Can you try something for me? Repeat the steps you gave me above, but without opening Safari. Use Mail and maybe another browser if you have one, or just Mail. See if you get the same results.

  • edited January 25

    Lars,

    I follow your thinking :-)

    Have just rebooted after a shopping trip. Launched 1P, Mail and Safari (as I would normally do).

    Nothing else launched - except those services which are active on login.

    Read your message, so I immediately minimized 1P.

    To be clear: 1P launched, password successfully entered, active but stowed in the Dock.

    Then quit Safari.

    Worked in Mail for about a minute.

    Quit Mail.

    Up pops 1P :-)

    Thanks for continuing to track this down!

    It really isn't the end of the world. But if it's unexpected behavior as you see it, and given that it is then an extra step to dock 1P again, it would be useful to have such behaviour optional.

  • ag_kevinag_kevin Junior Member

    Team Member
    edited February 10

    Hi @Mark Sealey

    Thanks for taking the time to provide steps to reproduce this, and the details. I'll raise an issue with the development team to see if we can do something about that.

    Cheers,
    Kevin

    ref: apple-3051

  • Thanks, Kevin! I'm pretty sure that the phenomenon applies whether or not 1P is the last otherwise open and running app. I still get it when perhaps, say, I close Mail but Safari is still running. Good luck!

  • LarsLars Junior Member

    Team Member

    @Mark Sealey - for what it's worth, I was unable to reproduce this issue in my virtual machine setup of OS X 10.11 (“El Capitan") and 1Password 6 for Mac, but I was able to do so on my "production" setup of macOS 10.14 (“Mojave”) and 1Password 7 for Mac, which leads me to suspect there may well be some unintended interaction that's new to 1Password 7 for Mac. Thanks for reporting it, and we'll see what we can do. In the meantime, you may wish to - instead of minimizing it using the middle (yellow) window button on the main 1Password window, instead use command + H to hide the application window, and then command - tab (or the dock) to get it back when you want it. Hope that helps! :)

  • Thanks, Lars! Usual excellent Agile help. Good luck :-)

  • LarsLars Junior Member

    Team Member

    Thanks for the kind words, Mark! :) Hopefully, we'll have it figured out soon.

  • This is happening on my installation as well. Looking forward to a resolution. Thank You

  • LarsLars Junior Member

    Team Member

    @iceout - thanks for weighing in.

  • Mark has described exactly what I experienced. I started paying attention to the menu bar and found that the 1password window wood spring from the dock if I close an application window when the menu bar read 1password. As long as the program is minimized in the dark and not showing on my menu bar, the window does not pop up. I don’t remember ever having to pay attention to this before version 7.2.4.

  • LarsLars Junior Member

    Team Member

    @easplastic - thanks for weighing in on this. We've got an issue open for it, and hopefully we'll be able to nail it down soon.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file