Cannot up date 1Password on windows

I am getting an error like on this post:
when I try to install 7.3.654 on my Windows 10 machine.

My %LOCALAPPDATA%\1Password\app looks like this:

I have tried closing all my browsers and that did not work.

Please help! ;)

1Password Version: 7.2.617
Extension Version: Chrome:
OS Version: Windows 10
Sync Type: Not Provided
Referrer: forum-search:failed to rename



  • Never mind. I just uninstalled everything related to 1password and reinstalled it all.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @tnwheeler,

    Thanks for reporting this and for sharing your screenshot. We think we know what is causing it and we'll fix it in the next update.

  • Glad I could be helpfull

  • MikeTMikeT Agile Samurai

    Team Member


  • MikeTMikeT Agile Samurai

    Team Member

    Hi @tnwheeler,

    Can you check for an update and let us know if it goes through well.

  • Sascha148Sascha148
    edited January 11

    just wanted to say, that I have the same problem.

    Current Version: 7.2.617
    Trying to update to: 7.3.657

    Any way to solve this without reinstalling 1password?

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 11

    Hi @Sascha148,

    Thanks for writing in. What anti-malware solutions are you using?

    So far, all of the initial issues that were reported are fixed in 657, we have confirmations already. It tells me that your issue is likely to be different one that we need to investigate.

  • tnwheelertnwheeler
    edited January 14

    Good Morning @MikeT!
    I got into the office today and I have the following error up:

    I am running 7.3.654.
    My folder looks like:

    If you want logs I can send the privately if you give me a place to send them.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @tnwheeler,

    Sorry about the delay. Did you have Edge running at the time? We've found out lately that some users get that same access is denied error from the system because Edge is locking the folder for the 1Password extension. We're looking into it.

    If you reboot, it would resolve that issue. However, since it's been a few days since we replied, have you been able to resolve it on your own?

    You can always email us anytime at [email protected]. It would help if you include the link to the forum thread in your email, so we can connect the email to the thread as reference.

  • @MikeT,

    A reboot did not fix the problem and I made sure no apps where running during the attempted update.

    It looks like I am going to have to do a clean install -- again. :(

    Sending some logs for you via mail.

  • bundtkatebundtkate

    Team Member

    If you're okay waiting on that clean install, @tnwheeler, we may have better ideas once we look at the logs. We've been gradually sussing out a few things that lock these folders and cause these sorts of issues and the quicker we can identify the one biting you, the quicker we can fix it. And, actually, on the Edge front – do you use 1Password in Edge and is it your default browser? Mike had tested this last night and I haven't had a chance to talk to him about his findings in detail, but Edge launches suspended on boot if it's your default, so it's possible it could be locking the folder all the same, even though it isn't active. If it is your default, you might try disabling the 1Password extension and (sorry) another reboot to see if that helps.

  • tnwheelertnwheeler
    edited January 23

    Sorry for the late response. I am fine with waiting.

    Edge is not my default browser but I do have the 1Password extension installed.

    A reboot with the extension disabled did not work.

  • bundtkatebundtkate

    Team Member

    No worries at all, @tnwheeler, thanks for letting me know. I've found you're email and we'll take a peek ASAP. :chuffed:

    ref: RHJ-94883-477

  • @bundtkate
    I am still having this issue and its getting very annoying to have to relaunch 1password every morning.

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 28

    Hi @tnwheeler,

    We're still looking into it, there's no one else with the same issue anymore in the latest 1Password 7.3.657 update, which makes it very difficult to pinpoint it down quickly for your case specifically.

    We also noticed something odd in your report, where 1Password downloads the update but when it tries to run it, the file no longer exists. Usually, this is a sign of a security program deleting the file as part of a quarantine measure.

    It looks like Greg has replied to your email but I'll follow up soon.

  • Hey guys, I have the same issue with 7.3.657 => 7.3.661

  • wigsterwigster
    edited February 3


    I would just like to say that I have the same issue with 657 upgrading to 661. I had it before when trying to upgrade to 654. I can be solved by uninstalling 1password, deleting what you can form %LOCALAPPDATA%/1pd, rebooting, deleing the rest of the 1pd folder and then installing from scratch. I also have 1password X installed in Firefox, but I don't think that is affecting anything.

    Like you mention above, I have the Edge extension 7.2.583 installed and in use. But killing all the edge processes does not release the locked files in %LOCALAPPDATA%, until an uninstallation, deletion and a reboot. I.e. something launches a process that locks the 1pwd files during boot, before any applications are launched. I can send you logs by PM of the upgrade etc if that's helpful. But the only thing there is:

    02-02 21:33:11.055309 +01:00] INFO [starter] starter\src\ renaming C:\Users\ignac\AppData\Local\1Password\app\7 to C:\Users\ignac\AppData\Local\1Password\app\7.old
    [2019-02-02 21:33:11.057276 +01:00] ERROR [starter] starter\src\ Failed to rename existing app folder: Access is denied. (os error 5)
    [2019-02-02 21:33:12.663138 +01:00] ERROR [starter] starter\src\ Installation failed.

    The file that is locked, even when all 1pd and Edge process are killed is 1password.exe.

  • Same here. Experienced it updating to 7.1.657, now to 7.1.661. Have Chrome addon installed in two browsers, Chrome and Vivaldi.

  • bundtkatebundtkate

    Team Member

    @dospolov and @Mancubus, could both of you send us a diagnostics report as described here:

    We're aware of a few instances where this can happen and are working on sorting them out, but the best way to determine which is giving you trouble we'll have to take a closer look at your install logs.

    @wigster: Do you see the same issue when you disable the Edge extension, reboot, and retry the update? Killing the processes won't necessarily release the lock as Edge can relaunch them, but disabling the extension and rebooting should keep the lock from reapply, unless it's something else that's locking things down.

  • I am still waiting on some feedback. this is getting very frustrating.

  • bundtkatebundtkate

    Team Member

    @tnwheeler: I see Greg was in touch to let you know the team was investigating your specific case, but I must admit I'm not aware of where that specific investigation stands. As such, I passed your e-mail with your diagnostics from various versions along to one of our dev team specifically working on the installer in hopes of both some feedback myself on where we're at with investigating your specific issue as well as hopefully some additional steps for you to try. I'll have something for you as soon as I hear back from them (or they may follow up directly if that works best). My apologies for the delay. I think the understanding was that you were okay for the moment, given the lack of imminent updates, so we've been doing our digging and planning to follow up when we've got something actionable to share. We've also got a few folks taking a well-deserved breaks on the Windows team and I've made matters worse by getting sick last week, so I'm working as quick as I can to get caught up and make sure y'all are kept in the loop. I'll make sure someone is in touch as soon as we have something more to share. :+1:

  • @bundtkate I have disabled the Edge plugin, rebooted and tried to update .657 to .661: the problem is the sameL

    I have just sent diagnostics logs to support.

  • @tnwheeler I've switched back to stable version. Waiting for a fix

  • bundtkatebundtkate

    Team Member

    @dospolov: This is an issue that has existed since the last stable in various forms. We've fixed some and are still investigating others. Not to say you absolutely must swap to beta by any means, but just fair warning that future stable updates may give you the same trouble and it may be worth sorting them now vs. later.

    @wigster: Were you able to peek at task manager and see if any of the 1password.edge processes were running when you retried the update? They shouldn't be, of course, but we've seen some strange behavior we've tenuously connected to Edge with 7.3 we're still working to track down and one theory that has emerged is that these processes are launching at inappropriate times, so I'd like to check they're not as a first step. If they are, try uninstalling the Edge extension, reboot, and give it another go. If they aren't please choose 1Password > Exit and try deleting the %LOCALAPPDATA%\1Password\app folder and installing the latest from here. Let me know if any of that works for ya. :+1:

  • wigsterwigster
    edited February 9

    @bundtkate Hi, I've had some time to play around:

    1) When attempting to upgrade, the 1pd.Edge processes are killed properly
    2) Disabling the Edge extension and rebooting doesn't do anything. Haven't tried uninstalling it this time, but I did previously and I didn't help.
    3) Exiting the 1pd app doesn't unlock the files. I can kill all the 1pd, Edge and 1pd.Edge processe and app/1password.exe remains locked

    This means that I cannot delete that one file. It's relocked immediately after reboot
    The only thing that works is deleting the 1pd.dll. This then prevent 1password from launching on reboot and then 1pd.exe can be deleted.

    Somehow this smells like it's the 1pd.exe process that locks its own file and then doesn't unlock it after reboot.

    In Process Exlorer it says that the 1pd.exe file is locked by SYSTEM.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @wigster,

    Thanks for investigating that and giving us more details. I don't think your issue is caused by Edge, it sounds like there's something causing the file to be locked but we do not need to lock our files during the update, we do release them by force.

    Can you tell me if you see a process called cftmon.exe running in your Task Manager/Process Explorer?

  • Hi

    No, there is no cftmon in the Task Manager, at least right now. This is a language-selection related process isn't it? I do have the language bar with three input languages open at all times -- maybe that is related?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @wigster,

    Did you only check the Details tab? I believe it is called CTF Loader in the default Processes tab.

    This is a language-selection related process isn't it? I do have the language bar with three input languages open at all times -- maybe that is related?

    Yes, it handles the input (inking, speech, etc) for other languages. During our investigation, we found that it can lock our file but we're not sure why yet.

    Would it be possible to tell me all three of your languages, so I can try to reproduce it. I have a few other languages already but they're not causing any issues for me.

  • Yes, indeed in Details I see ctfmon.exe but it is disabled. And CTF Loader in there in processes.

    I have the following languages: English(UK) with US-International keyboard, English (UK) with UK keyboard, Polish with Polish programmers keyboard and Czech with Czech programmers keyboard.

    Note that the English (UK) with UK keyboard is a bit of a weird self-installing thing. I am not sure what causes it, but every so often something adds it to the language bar, even though I do not have that keyboard installed in Language settings. It might be one of the Office applications. Then I have to manually add the UK English keyboard to UK English and actually remove it.

    So my default is an unusual combination of UK English with US Intl keyboard, if that could make any difference.

  • MikeTMikeT Agile Samurai

    Team Member

    Thanks, I'll test that.

    Note that the English (UK) with UK keyboard is a bit of a weird self-installing thing

    Some of our developers see the same thing with English (CA); it drives them nuts.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file