Offer to search the database when no match is found

Hi there! New member here, and let me start of by saying that I really like the app and that I'm sorry if this was already asked. I searched, but I couldn't really find anything.

This was my flow for today:
1. I have installed the Fandom app from the Play Store
2. I have entered the app, and it asked me to sign up (usually I wouldn't, but hey, now I have 1Pass)
3. I went through the registration form inside of the app until I reached the password prompt
4. At the password prompt, 1Pass offered me to autofill the field, but it would only do so with an existing account, which I didn't have (not sure if the Fandom app supports autofill properly, and if it was possible to generate a password from 1Pass here and then subsequently save it; that would be a wonderful flow)
5. I then went to the 1Pass app to search for a password generator button, but found none, so I just created a new Login item and generated the password there (later I read why it doesn't make all that much sense to just have a generator all on its own*)
6. I created a new entry, named it Fandom, and there I have entered the username and generated the password that I would use, and I copied that password and entered it in the app. All good, I'm registered!
7. I received an email from Fandom letting me know that I need to verify my email address.
8. I clicked on the "Verify email" button inside of the mail.
9. This has taken me to the Fandom login form (note: this was opened inside of a Chrome Custom Tab by Gmail)
10. I then tried to login, and I was prompted to do an autofill by 1Pass.
11. I clicked on the autofill button, and unlocked 1Pass, but I was only prompted by a dialog that said that there were no matches for this website. And that's fine, since I haven't provided an URL in the aforementioned Login entry that I have created.

But my question is - why did 1Pass not allow me to search my records so that I could have selected Fandom from there?

I have went into the new Fandom entry that I have created, and I added the URL, and everything worked nicely after that, but I was wondering if that could have been avoided. I do understand that there are a lot of limitations on Android (Android dev here), but I'm asking just in case, if it's something that maybe could be changed.

Sorry for the long text!


1Password Version: 7.0.9
Extension Version: Not Provided
OS Version: Android Pie 9.0
Sync Type: 1Pass Account


This discussion has been closed.