1passwordX doesn't unlock correctly on new firefox 65



  • BenBen AWS Team

    Team Member

    Hi @dontrepeat

    Do you have a 1Password membership account? 1Password X requires a membership. If you're using 1Password standalone (no membership) you'll want this extension instead:


    That said, 1Password 6 for Mac has been retired, and is no longer being developed. We'd always recommend keeping up to date with the latest versions of all of your software, but especially 1Password, your operating system, and your web browser.

    I hope that helps. Should you have any other questions or concerns, please feel free to ask.


  • Yeah, eventually subscription is the only feasible path. We knew that would eventually happen.

  • BenBen AWS Team

    Team Member

    Yeah, eventually subscription is the only feasible path. We knew that would eventually happen.

    Well, this thread in the 1Password X category, and 1Password X is a membership-only offering (and always has been). :) That said let's please try to stay on topic:

    1passwordX doesn't unlock correctly on new firefox 65

    There are lots of other threads about membership vs standalone. :+1:


  • OMG I'm not going crazy.. This is happening to me as well!

    • 1Password X v 1.14
    • Firefox Quantum 65.0 (65.0+build2-0ubuntu0.18.10.1)
      ... and other extensions like DuckDuckGo, Greasemonkey, uBlock Origin and NoScript.

    1Password X refuses to accept password if you press Enter
    Thanks, @eventz for the "click the padlock" workaround! :)

  • ag_sebastianag_sebastian 1Password Alumni

    Definitely not going crazy, @adfhogan! I'm sorry for the hassle, and I hope this will get addressed again soon.

  • Hello,

    After Firefox upgrade (from 64.0 to 65.0) I can no longer unlock vault with 1PasswordX extension. After filling in the password field and pressing enter extension reload (I can see that popup is white for a second) and it goes back to empty password field. It does not matter if I provide valid or invalid password. However when I go to https://my.1password.com/ and unlock it here extension works fine (no need to unlock, I can see all the account data).

    I have tried to reinstall extension and use a new profile in Firefox but it didn't help - issue is still there.

    I've looked into extension debugger but I am not really sure what to look for, I see a bunch of warning/errors but without any details or context:

    Error: Invalid tab ID: 84 ExtensionUtils.jsm
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist.
        Rx moz-extension://e2f22a7e-321f-4fee-b7ac-4f54160b5e80/background/background.js:31 
    Error: Invalid tab ID: 84
    error occurred while processing 'sources: TypeError: can't access dead object
    Stack: [email protected]://devtools/server/actors/utils/TabSources.js:311:5
    Line: 311, column: 5

    1Password Version: Not Provided
    Extension Version: 1.14
    OS Version: Ubuntu 18.10
    Sync Type: Not Provided

  • BenBen AWS Team

    Team Member

    Hi @sebcioz

    I've merged your thread with the other you found on this subject. Thanks! :)


  • I just tried logging into 1password on Ubuntu 18.4 in Firefox and hitting Enter worked as expected (despite having had the issue up until now)! Has this issue been resolved for everyone else as well? I know that there were new versions of 1password X and Firefox released recently, so I don't know which release fixed the issue.

  • Same issue here!

    I installed 1Password X into Firefox Quantum (65.0.1 – 64-bit) 2 days agao and now when I click on the icon in the browser bar, a blank page loads with the following URL:


    Now the only way to enter passwords in Firefox is to use the mini version in the MACs main bar. BUT this means having to copy the username and password separately. Also clicking on a link in the mini bar opens up the page, but doesn't autopopulate.

    Can we get a quick resolve on this please?

    Many thanks

    PS I have a subscription.

  • Also, when I'm logged in online and visit "Get the Apps", next to "1Password X" is this text "Requires Google Chrome 60 or later."

    So it actually compatible with Firefox?


  • ag_sebastianag_sebastian 1Password Alumni

    @sebcioz Does the Tab+Space workaround from @btaroli help in your case? If not, I'd like to ask you to send us an email to [email protected] and we'll look at this issue individually. Please include this forum topic in the email.

    @randomPoison We haven't made any changes on our end, so I'm curious how this will pan out. Let us know if the issue returns.

    @GJW1P This sounds like a different issue. I'd like to ask you to remove and then reinstall the add-on from https://addons.mozilla.org/en-US/firefox/addon/1password-x-password-manager/ and try again. If that doesn't help, please send us an email to [email protected] as well. Please include this forum topic in the email.


  • Hi Sebastian

    Thanks for the feedback.

    I have uninstalled and reinstalled the X plugin numerous times and eash time I click on it I get a white screen with the strange URL linking to the plugin (moz-extension:/...)

    I've tried installing it from my online account using Firefox and also searching for the plugin in Firfox addons. Same issue, no matter where I install it from.

    To get some form of Browser connection I tried to download the non-x version from here https://1password.com/downloads/mac/#browsers. I get theses two messages each time:

    I had to open Safari and download the standard plugin and upload the addon. At least I can use 1Password in my browser again, but really wanted to use the X version.

    Do you want me to email support ([email protected])?


  • Hi @GJW1P,

    I wonder if you might consider refreshing your Firefox profile and then trying 1Password X again. I've seen that help in the past. If you don't use the likes of Firefox sync though it will mean installing all of your extensions again. Mozilla's support page Refresh Firefox - reset add-ons and settings details everything from how to do so and what is and isn't reset.

    The connection failure message relating to the companion extension has most commonly been found when anti-virus is interfering with Firefox. The resolution is as you've already done, to download the extension in another browser and then locally add the XPI to Firefox.

  • Hi @littlebobbytables

    I'll give that a try later and let you know how I get on. I have a personal sync account, but will create a work one before I do this.

    Thanks again

  • Cheers @GJW1P, hopefully you find it helps.

  • I'm experiencing the same exact issue the OP reported. Though running 1Password X v1.14.1 and Ubuntu v18.04.2.

  • brentybrenty

    Team Member

    @chris13524: I'm sorry to hear that you're having trouble with Ubuntu and Firefox. Have you tried the workaround? Either Enter or Tab+Space seem to be working for others. Please let me know.

This discussion has been closed.