Multiple exceptions lately

Hi,

lately 1PasswordX stopped syncing for me. I tried to reinstall the extension but then the login got stuck. Altough i did receive the login notification via e-mail. After reinstalling / resetting the browser and extension numerous times at some point i was able to sign in again.
But as before the sync stopped working shortly after. Also signing in into my.1password.com and clicking the notification on the top right to also sign in into 1PasswordX did not work.

I have discovered multiple different exceptions, maybe this can help.
When trying to signin:

background.js:31 Uncaught (in promise) TypeError: Cannot read property 'encryptedBy' of undefined
    at t.n.getMasterPasswordDerivationInfo (background.js:31)
    at background.js:31
    at Promise (background.js:31)
    at new Promise (<anonymous>)
    at bY.decryptKeysets (background.js:31)
    at bY.unlockWithMasterPassword (background.js:31)
    at <anonymous>

Also sometimes when trying to signin:

background.js:31 Uncaught (in promise) TypeError: Cannot read property 'accountVersion' of undefined
    at db.findAccountByUUID.then.then.e (background.js:31)
    at <anonymous>

When trying to store/update a password after the sync has stopped working:

background.js:31 [_request] Request "/api/v2/vault/******/**/items" failed: Error: Incorrect Version value has been sent.
    at new t (background.js:31)
    at _handleQwestError (background.js:31)
    at Array.f (background.js:24)
    at background.js:24
    at background.js:24
    at p (background.js:24)
    at s (background.js:24)

My friend noticed yesterday that his sync stopped working, so i guess he got the same problem. On my other devices (OSX, another Ubuntu) it works fine.

Apart from that i have to say i love your products for their usability, keep up the good work!

regards,
Philipp


1Password Version: Not Provided
Extension Version: 1.14, 1.15.0 Beta
OS Version: Ubuntu 17.04
Sync Type: Not Provided

Comments

  • ag_sebastianag_sebastian 1Password Alumni

    Hi there @rettier!

    Thanks for your report and the logs. I'd like to ask you a few questions before we dig further into this:

    • Which browser are you using?
    • What happens if you try to sign out and then sign back into your account via 1Password.com?
    • What happens if you try using the extension in a new Chrome/Firefox profile?
  • rettierrettier
    edited February 18
    • My Browser : Chromium 63.0.3239.84 (Offizieller Build) Built on Ubuntu , running on Ubuntu 17.04 (64-Bit)
    • Signing in on my.1password.com works fine.
    • On a new profile the login also does not finish, it is stuck with the login button displaying a loading icon. The top most exception i posted above is raised.
  • brentybrenty

    Team Member
    edited February 18

    @rettier: Ah, thanks for clarifying. Chrome 63 was released in 2017, so it's quite a bit different than what we're using today. Can you install the current version? That should work as expected.

  • oops i wasn't aware my browser on this machine is so old. I just upgraded to Google's Chrome 72.0.3626.109. Still the same issue on a fresh Chrome Profile.

  • beyerbeyer

    Team Member

    Hey @rettier!

    Sorry for the delay. Could you please email the complete console logs you have from the 1Password X background page to [email protected]? I'll take a look and help get to the bottom of what might be causing this issue.

    Also, could you please check and see how much disk space you have on the volume where your Chrome profile is stored? Chrome stops letting us save to the IndexDB we create on disk when there's less than 1 GB or so of storage remaining. In the past, this has caused some weird errors like the ones you see, and they are hard to troubleshoot since as a browser extension we can't get an accurate idea of how much storage space remains.

    Thanks,

    Beyer

  • Hey @beyer, now that you mention it must have been the disk space. I cleaned my disk yesterday due to a warning that is full, and it is working as of today. If it helps you i can easily fill it back up to produce some error logs for you. Also i‘ll head to my colleague to check on his disk usage, since he has similar issues.

  • beyerbeyer

    Team Member

    @rettier: I have an issue open already to work on handling these errors better and at the very least taking users to a support article. I believe I have all the information to get that done, I just need to carve out the time. I added some logging and a notification in the past. Unfortunately, that didn't catch all code paths that could cause 1Password X to stop working. One of the challenges is browsers aren't very specific about how much storage space is remaining on a device which I believe is mostly to prevent device fingerprinting. I'll dig into that issue and see if I can get this resolved for good tonight.

    Let me know if there's anything else I can do to help!

    Cheers,

    Beyer

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file