Chrome Extension doesn't work after updating to 7.2.5

My 1Password updated today to 7.2.5 and it has been a complete disaster. Every time I open the popup (with cmd+\), it prompts me to install the chrome extension, which was already installed. I've had this bug happen before, by the way, and it is extremely annoying.

I didn't want to fuss around with this for the 3rd time, so I deleted the chrome extension and re-downloaded it, and signed in. I even killed Chrome and relaunched it, and killed 1Password as well.

No dice. It still always asks me to install the chrome extension, rendering the mini menu utterly unusable

The mini menu is far and away the biggest selling point, without it functioning properly, the app is substantially less useful.

FWIW, I am not a fan of new design or whatever changes happened to the chrome extension. It is so different I wonder if there are two chrome extensions and I just downloaded the wrong one (which is really bad, the product shouldn't be fragmented like that in a way that people can't distinguish between the versions/products). I think the updates to the chrome extension are heavy-handed and uncalled for. I never needed more popups, which the new extension is in love with. All I ever needed was the mini menu and the auto-fill features. I really dislike that your developers keep iterating on what was already, honestly, a perfect product. I wish the dev team would focusing on fixing bugs rather than tweaking the UI every month. It is incredibly jarring and frustrating to have to deal with new bugs you introduce along with new features and having to navigate around the new UI.

Sincerely,
A frustrated software developer.


1Password Version: 7.2.5
Extension Version: 1.14.1
OS Version: 10.14.3
Sync Type: Not Provided
Referrer: forum-search:chrome extension doesnt work

Comments

  • Greetings @willashley23,

    The forum swallowed up the \ in your initial post so the edit mention was just me gently tweaking your post so it was visible when viewing the message. I hope you don't mind.

    The version you've reported for the extension is that of our 1Password X extension. While at some point in the near future it will integrate with 1Password for Mac we're not there just yet and it's still very much only in the betas. As it was designed as a standalone extension it doesn't try to connect to 1Password for Mac and so 1Password for Mac doesn't know it's installed and it can't work with the keyboard shortcut to fill. You need the companion extension which relies completely on the native application. If you remove 1Password X and install the companion extension I believe all the normal behaviour you're after should return. A direct link for the Chrome companion extension is 1Password extension - Chrome Web Store. If you're still having trouble after that please let us know.

  • Hi,

    Thanks for responding! So here's the problem:

    When you click that "add 1password to chrome" button, it takes you to this page: https://1password.com/downloads/mac/#browsers

    When you scroll down, you'll se a link to download for chrome. Here's the problem: Than link takes you to 1Password X

    I cannot begin to explain how bad this is. You have your app telling users to download an extension yet you link your users to the wrong extension. I didn't even look at the name of the extension because, you know, I kinda trusted you guys to direct me to the correct one, which is another problem - there is no visual brand difference between the two extensions. The icon is the exact same. This means the only difference visually is the "x" in the title. That is a really terrible user experience.

    Also,

    I did as you said, I removed that extension, downloaded the normal one for Chrome, and it still doesn't work. It still prompts me to install the extension even though it definitely is there in Chrome.

  • Further update: I realized the extension was shut off in chrome for some reason (maybe downloading "X" automatically disables the other one) but I re-enabled it. Now, when trying to access the mini menu, it simply doesnt open at all. The keyboard command just does nothing.

  • Ok, I've tried deleting and reinstalling the extension, and made sure it is enabled (clicking on the extension icon opens the app).

    Still no dice. We're back to where we started: opening the mini just tells me I need to download the extension.

    Guys this is really really really annoying. It's like every second I save from 1Password is chronically blown away each time I encounter a bug like this.

  • Hi @willashley23,

    When I follow the link I see two sets of links, the second set for 1Password X and the first for our companion extension.

    That first link is the same as the direct link I supplied in my earlier reply.

    If you have removed 1Password X, only have the companion extension installed and enabled and ⌘\ still isn't working then I'd like to review a diagnostic report. Can you complete the following for me please just so we have a clean starting point and hopefully something useful in the logs to explain why things aren't working.

    1. Ensure Chrome is reporting that it is up-to-date. Google's support page Update Google Chrome can be useful if you're not sure.
    2. Restart the Mac.
    3. Launch 1Password and unlock.
    4. Launch Chrome and test filling.
    5. Assuming the issue is still present create a diagnostic report and send it in.

    For the diagnostic report, this link will guide you through the steps and has sections for the various supported versions of 1Password.

    How to send a 1Password diagnostics report

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected].

    Once you've sent the report you should received an automated response from us with a ticket ID. If you can post that ticket ID here it will help us locate your diagnostic report and we'll see what it reveals.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file