Filling errors on two websites

edited March 2019 in 1Password X (beta)

Hi guys, I noticed filling errors on two websites:

1) March Madness is here so ESPN filling should work well ;). Go here: and click "Log in" on the top right. Fill in ESPN login with 1P X. Effect: nothing happens and the input boxes remain blank as if nothing happened.

Hypothesis: is 1PX refusing to fill because ESPN is HTTP (not secure)? They refuse to use HTTPS which makes me really sad, but I am guessing that 1PX is not filling because of this. If so, you guys should include a warning or prompt that tells the user why 1PX refused to fill the inputs.

2) Go to this website: and click the "Log on" button to manage subscriptions:

Then try filling in your Vanguard login. You will end up with this, even despite having my username and password properly set in 1Password:

1Password Version: 1Password 7 Version 7.3.BETA-2 (70300002) AgileBit
Extension Version: 1.15.1
OS Version: 10.14.3
Sync Type: 1Password


  • brentybrenty

    Team Member

    @jadchaar: Thanks for letting us know! With regard to Vanguard, it's actually working for me, so I wonder what is different between us. Do you happen to know where you saved the login originally? Does it work if you create a new on? I also created a brand new login item for the ESPN site, and that filled okay. Are you selecting Fill from the toolbar menu, or from the inline menu? Hopefully we can narrow down what's going wrong there. :)

  • Hi @brenty!

    For ESPN, both methods (inline and from toolbar) are not working for me. It is worth noting that I have the following as my "URL" in the entry: and the entry comes up fine because it shares the ESPN domain. Weird because I tried switching the URL to "" and "" and both failed to fill as well.

    For Vanguard, it is worth noting that I do not even get an inline-menu option but have to manually access the toolbar. I have taken a video of the bug in action using a test vault and test entry I created that is very similar to my own:

    Note: both sites were tested on the latest 1P X beta version 1.15.2.

  • brentybrenty

    Team Member

    @jadchaar: Hmm. I thought I'd done something stupid here. I got my wires crossed and didn't realize that my browser on the machine I was using had the stable extension. It works there...but I just installed the beta too, and I'm seeing the same thing: inline menu works, 1Password X fills. Which browser version are you using? There has to be something that accounts for the difference. Do you have other extensions which might be interfering? We'll get to the bottom of this. :)

  • jadchaarjadchaar
    edited March 2019

    Hey @brenty! I tested it with both "Google Chrome Version 73.0.3683.75 (Official Build) (64-bit)" and my primary browser "Brave Version 0.61.51 Chromium: 73.0.3683.75 (Official Build) (64-bit)". Both had the same issue.

    I have the following extensions installed on both browsers:

    1Password X Beta
    uBlock Origin
    uBlock Origin Extra
    HTTPS Everywhere
    JSON Viewer
    The Great Suspender
    Smile Always

  • brentybrenty

    Team Member

    @jadchaar: Thanks! Yikes. I'm not going to be able to install all of those extensions in the same browser/profile with 1Password, as many (if not all) seem to be requiring access to everything I do on webpages -- which includes the sensitive information I save and fill using 1Password.

    So here's my setup:

    • Brave 0.61.52 (stable)
    • 1Password X 1.15.2 (beta)
    • 1Password desktop extension 4.7.3 (stable)

    And here's what I did:

    1. Navigated to and *
    2. Clicked "Log In" in the upper right
    3. Filled in fake login credentials
    4. Clicked the inline 1Password icon
    5. Selected "Save in 1Password", saved
    6. Reloaded the page
    7. Opened login form
    8. Clicked inline 1Password icon and selected the saved login to fill

    *I notice this is not a secure website. Do you have your login item in 1Password saved as http://?

    In both cases, I was able to save and fill a new Login item. While I do not have an actual ESPN account of my own, I do have one for Vanguard and get the same result with that. So I don't quite think it's something specific about the Login item...but can't rule it out entirely at this point. If you follow those same steps in a browser/profile without the other extensions, does it work? It might be possible to narrow it down to a specific one, if that's the case. Let me know.

  • jadchaarjadchaar
    edited March 2019

    Hi @brenty,

    Yeah I agree some of the permissions that my extensions require are quite dangerous, but I make sure to change the permissions to only allow on certain sites or on click. I do keep things like uBlock and HTTPS Everywhere on the default permissions since they are open source and widely trusted. That said, still good to be cautious.

    As for testing...

    Even with a fresh Brave profile with only the 1P X Beta extensions installed, the bug I reported above still occurs. I noticed that you actually have a flaw in your reproduction steps. You must go to this URL exactly,, and click this "Log on" button on the page:

    That should produce the issue I am speaking of above.

    Even with a fresh Brave profile, the filling still fails on ESPN. The URL saved in my vault is "", so yeah it is unsecured "http" just like the website is (insert sad face). The inline menu comes up but when I click it to fill, nothing fills and the inputs remain blank.

  • brentybrenty

    Team Member

    @jadchaar: Ah, sorry for not being clearer. Clicking "Log On" on that page takes me to the URL I listed. Is it taking you to a different URL?

    Were you able to save a new Login item on those pages? Again, I'm not sure why that would make a difference, but at this point it's still one thing that is different, so it might help narrow down why it's working for me and not you.

    I also tested this in Chrome 73 again just to be sure, and filling works in both cases. I did notice though that has a different menu to bring up the login form, but that one is still working as well.

    When filling fails, what do you see in the logs?

    Save a console log for the 1Password extension

    I wonder if there is something there that might offer a clue. I'm sorry that we haven't figured this one out yet, but I'm sure we'll get there. Thanks for your patience and willingness to work with me on this. :)

  • Yeah no problem @brenty willing to help! Clicking the "log on" button I pointed out brings me to this popup and not a separate page:

    For the logs, should I post them here or email them your way? They seem to contains some potentially sensitive ID's. Let me know :).

  • brentybrenty

    Team Member

    @jadchaar: Thank you! I think we're onto something now, because I don't get that at all. This is what I see when I go here:

    and click Log On like we both describe:

    That's the login form that works just fine for me. So that would explain why you're getting a different result, even if I don't understand why the page is different.

    I don't think there would be anything sensitive in the logs, but maybe better to email them, especially if you could also include a webarchive of the page you're getting. That could help us figure out what's going on and hopefully find a way to improve it. Just send it to [email protected] and let me know the Support ID you receive.

    Still not sure about ESPN though. But we can look into that more too. :)

  • Hi @brenty! I just sent an email containing the logs and the extracted page info. When I get a support ID I will post it here.

    Once we figure out Vanguard, we can work on ESPN :).

  • @brenty I am still yet to receive a support ID. When should I expect one?

  • Here it is: #UHJ-91914-119

  • brentybrenty

    Team Member

    Perfect! Thank you! I'll take a look and get back to you via email. :)

    ref: UHJ-91914-119

This discussion has been closed.