changing how down arrow in userID field is used

When typing a login id, Firefox (at least) shows a list of ID's you've typed in the past in a dropdown menu. Sometimes I just want to use one, which I would normally get to with down-arrow. But, 1Password X uses down arrow to activate (if it's locked) or choose entries.

Is there any way an option could be added to control how the keyboard is used in fields on the webpage? I'd be happier if I could set alt-downarrow or something to activate the 1Password behavior, and leave downarrow for the Firefox behavior.


  • ag_yaronag_yaron

    Team Member

    Hey @blairmacintyre !

    I'm not sure I quite understand what you are trying to do. Mind sharing some screenshots or a video capture of the behavior you're talking about? :chuffed:

  • Sure. Let's say I go to amazon (I'll start with 1Password locked). If I type "b", I see a dropdown with the possible email suggestions from Firefox.

    Now, I hit "down arrow" on my keyboard, and instead of going to the email, it pops up the "unclock 1Password" box.

    I would prefer that if 1Password is locked, it DIDN'T show me the unlock and just let me cursor down. I can hit cmd-. to unclock it if I want to use it. For a number of sites, I know the password and can type it faster than unlocking 1Password. Or, I have access to accounts that I am not saving the password in my 1Password (for various reasons).

    If 1Password is unlocked I get the 1Password dropdown when I select the field (or if I unlock it right then with cmd-.).

    But, if I start typing more, I get the Firefox suggestions over top of the 1Password suggestions.

    Hitting down with both up hides the Firefox suggestions and goes into 1Password. This case is somewhat confused because both are showing.

    Ideally, if 1Password is locked, it would let Firefox behavior stand (cursor down through it's suggestions). If it's unlocked, it would either show the Firefox suggestions and let me cursor through it, or not show them.

  • ag_yaronag_yaron

    Team Member

    Thank you for the detailed examples @blairmacintyre ! This definitely explains your problem well.
    The main thing that comes to mind when I understood what is the issue you're experiencing is: Why do you have both 1Password and Firefox suggestions enabled? This is not ideal, and both will always fight over who's boss. :chuffed:

    I'd suggest either disabling Firefox's autofill/suggestions, or disable 1Password X's autofill/suggestions, which would bring you to the ultimate workflow (no double prompts to save passwords, no autofill wars like the one you're describing here).

    Furthermore, I do believe this UI/UX is the right way to go (just not alongside an active autofill from your browser). If we do remove this behavior from 1Password X, the average user might think the extension is not working or would just come to the forum here and suggest we show some visual aid or message that explains the extension is locked :angry:

    To sum it up, I'd suggest you just try working with your browsers suggestions disabled for one day, and then work with 1Password X's suggestions disabled another day, see which one works better for you and find the correct workflow. If you end up choosing working with both, perhaps pressing ESC will close just the 1Password X message and will keep Firefox's suggestions on? Worth a shot. If not, then working with the mouse might be your only option there.

  • ok, I'll try ... was hoping to keep both, but I think you're right, it's kind of wishful thinking. We'll see how it goes.

  • ag_yaronag_yaron

    Team Member

    @blairmacintyre I was also working with both for a while, and was hesitant about leaving just 1Password in charge, but since I did that I do not feel like anything's missing. Give it a shot :)

  • ok, I'll try. It'll encourage me to put more in 1Password. :)

  • ag_yaronag_yaron

    Team Member

    That is exactly what happened when I did this move. Lots of new logins incoming, so make sure you organize it from the start to avoid a big mess :chuffed:

  • swrobelswrobel
    edited May 21

    A big +1 for this suggestion. I want to use Firefox's form suggestions over 1Password's and I should be able to. Let me just reassign 1Password X so it stops stealing the down key.

  • ag_yaronag_yaron

    Team Member

    Hey @swrobel ,
    You can keep both 1Password X and your browser's built in autofilling feature enabled, then disable 1Password X's inline menu suggestions so it won't show up inside fields by right clicking the 1Password icon on the top right corner of your browser and selecting "Settings", then scroll down to the autofill section and disable the inline menu suggestions.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file