1Password for Chrome is filling in gibberish instead of the password on certain sites

When I try to log in to Fidelity investments using a url like this one: https://digital.fidelity.com/prgw/digital/login/full-page?AuthRedUrl=https://oltx.fidelity.com/ftgw/fbc/ofsummary/defaultPage&AuthOrigUrl=https://statements.fidelity.com/ftgw/fbc/ofstatements/getConfirmsList, and I try to use the 1Password chrome extension to fill in the password, it fills in a password that is MUCH longer than my saved password. (It actually exceeds the max password length, causing the page to complain). If I try to log in, it rejects me because it's not filling in my actual password.

Note that if I manually copy-paste the password from 1Password, it works correctly and provides the actual password.


1Password Version: Not Provided
Extension Version: 1.14.3
OS Version: OS X 10.13.6
Sync Type: Chrome extension only

Comments

  • kaitlynkaitlyn

    Team Member

    Hey @ContentCaribou – welcome to the forum!

    I believe I found what appears to be the culprit after taking a look at the HTML on Fidelity's login page. What I noticed is that the password field has a max-length of 20. What I think is happening is when you copy and paste your password, the password is truncated to 20 characters (due to the max-length attribute). When 1Password X fills the password, it doesn't take into account the max-length attribute, so the password in its entirety is filled. I tested this theory and confirmed that's what's happening for me.

    My question to you is – how long is your password? Now I don't really want you to tell me that (especially since this is a public forum), but I think it's something to consider. If your password stored in 1Password is longer than 20 characters, that means that Fidelity only took into account the first 20 characters – so that's what your actual password is, regardless of the total length.

    To test this further, I'm hoping you can try something out for me. Would you mind shortening the current password you have stored in your Fidelity Login item to the first 20 characters? Please copy and paste the password elsewhere before testing this so you don't forget it (the password will also be stored in your Previous Password in 1Password, but I recommend this just in case). Now that you only have the first 20 characters stored in your 1Password item, please try filling on the same Fidelity site and let me know what you discover.

  • You're a genius! I tried your steps and it fixed everything, thank you so much! The length issue was the culprit.

  • kaitlynkaitlyn

    Team Member

    Aww shucks! :chuffed: Thanks a ton. I'm glad to hear it worked for you.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file