Strange Login failure on 1Password on iPad (iOS)

diittodiitto Junior Member

Hi, I have 1Password for iOS, version 4.5 on my 2017 iPad. iOS version 12.2. One of several Logins I have on this iPad that has worked OK since I first put it on two years ago failed this morning. Tried a few of the other Logins and they all are still working OK. This failed Login has a URL, username and password. All have been verified to be correct.

When I click on the URL within the 1Password Login, it fills the correct page (a local NextDoor blog on which I have an account) with what clearly shows as my username (visible) and a password identified only by ***. But when I click “Sign In” if offers a “wrong password” message.

And here is what is strange. If I click “Done” go back to the 1Password Login, click the URL again and have it come to the page on which I want to login but this time I just place my cursor anywhere on the username or on the password (think I have to double click to make these fields active) but if while sitting on say the username field and make the cursor active and then say click a single backspace, not only does the character I backspaced disappear but, here is the good part, the ENTIRE password disappears as if I deleted it (recall that I am on the username field at the moment). If I do exactly the same from within the password field and attempt to delete a character of that password, the ENTIRE username disappears. These two fields are somehow connected, where one impacts the other in some unexpected (at least by me) way.

It would appear that some sort of linefeed or something is traveling along with the entry of my username and password. If I let the Login take me to the URL but prior to click “Sign In” I then remove and manually re-enter what I know to be the username and password, it works fine.

So something has happened (and I never touched it) to the two year old Login that appears to no long be simply moving the username and password correctly forward to enter in the URL login space but is instead moving along something extra that is causing the Login to fail.

I’ve also tried making a new Login with the same URL, username and password. Unfortunately it fails exactly as does my old, original Login….

One last point is I also own 1Password on my Mac (current version of MacOS and 1Password) but I do NOT share Logins via any shared vault or such (my choice). I have the same URL, username and password saved as a Login on my Mac and it still works fine.

Any ideas what might have happened to this iOS 1Password Login??? thanks


1Password Version: 4.5
Extension Version: ??
OS Version: macOS 10.14.4
Sync Type: not used

Comments

  • diittodiitto Junior Member

    By the way, I did not previously have a similar NextDoor local blog Login on my iPhoneXS, instead only on my 2017 iPad. But just now, I constructed a login by hand using the URL, username and password I know to be correct and just like on the iPad, it too, failed. Same story, the Username and Password fields that get brought over from the Login to the NextDoor URL somehow get corrupted on the way. But, it must have just happened recently as I use this Login on my iPad often, every few days or so. Just to add more info. Appears to be a 1Password/iOS/NextDoor compatibility issue that just occurred say within the last week or so??? When did 1Password for iOS last update??? I don't think I know that...

  • ag_anaag_ana

    Team Member

    Hi @diitto!

    So something has happened (and I never touched it) to the two year old Login that appears to no long be simply moving the username and password correctly forward to enter in the URL login space but is instead moving along something extra that is causing the Login to fail.

    Is it possible that something actually happened to the website instead? If you didn't touch the login in these two years, and if you see the same behavior on a new phone with a brand new Login item, perhaps something changed on the website that is causing this.

    When did 1Password for iOS last update??? I don't think I know that...

    The last version (7.3) was released last month. However, in your message you wrote that you are running 1Password version 4.5. Is this correct? Because this version would be about 5 years old now. Is this really the one you are using?

  • diittodiitto Junior Member

    Wow, 2nd part 1st. I am very wrong in having said version 4.5... Don't recall now what I saw that made me think that was it, something in the iOS App Store I think but when I actually check the version by scrolling to the bottom of SETTINGS in the running 1Password app, yes, you are correct. I am running version 7.3...

    Regarding your other point, it's curious. First, a couple of points.
    1. I also access this website using 1Passsword on my Mac. Note I said I don't share the logins between say my Mac and my iPad. They are independent and setup independently by me but basically they are the same. Both have worked fine for a long time. As of today, the Mac 1Password login still works fine. The iOS version on my iPad does not.
    But yes, truly something has changed and I supposed it could be on the nextdoor site.
    2. When I click on the URL in the 1Password saved version of the login for this next-door site, it opens the URL in the 1Password browser and enters the username and password but then they just sit there. It does not auto-submit. I don't even know how to do that or if it is even possible. Most of my 1Password logins auto-submit when entered from my Mac but none do when entered from the iPad under iOS. I did my best experiment to date a bit ago. I went to those two sets of characters, username (readable) and password (***), clicked on the very last character of the username, clicked delete and that character and the entire PASSWORD field below cleared as well. That's what I said in my original post. But now, while looking at that, I simply readded that one character to the end of the username, retyped in the full password and NOW I have succeeded in getting rid of whatever is happening that is causing these two fields to be coupled by some strange line feed or something. Once I do this manual adjustment, if I now say try to remove the last character of either the username or the password, it just deletes that one character as one might expect. So that first delete gets rid of the problem if you will.

    So... Don't know if that added much. I've never seen a mystery like that... Could they, nextdoor, have changed something in the past day or two tops as I log on to this site fairly often though often through my Mac and that, as I said, still works as normal. ??? The answer is that SOMETHING sure changed and since there was no 1Password update, it would sure seem to point to the website end. Note I also said above I made a Login in 1Password on my iPhoneXS and it fails too. So it's some interplay between the iOS version of 1Password and this Nextdoor website.

    I will play with it some more and I can certainly still get in, on my Mac or even on my iPad if I just don't go straight in with 1Password. Just a pretty curious error, the likes of which I've not encountered before. Just wanted to see if you folks had ever seen something like this. Say like some coupling between the username field and the password field when sending both over to two fields on the login page of a website using 1Password for iOS.

    Been using 1Password for quite a few years. Love it... thanks... bob

  • ag_anaag_ana

    Team Member

    Hi @diitto,

    Wow, 2nd part 1st. I am very wrong in having said version 4.5... Don't recall now what I saw that made me think that was it, something in the iOS App Store I think but when I actually check the version by scrolling to the bottom of SETTINGS in the running 1Password app, yes, you are correct. I am running version 7.3...

    Thank you for the confirmation :)

    1. I also access this website using 1Passsword on my Mac. Note I said I don't share the logins between say my Mac and my iPad. They are independent and setup independently by me but basically they are the same. Both have worked fine for a long time. As of today, the Mac 1Password login still works fine. The iOS version on my iPad does not.

    There might be some minor differences between the two, if you created both items manually on each device. For example: is the URL field exactly the same on your Mac and on your iPad for this item?

    1. When I click on the URL in the 1Password saved version of the login for this next-door site, it opens the URL in the 1Password browser and enters the username and password but then they just sit there. It does not auto-submit. I don't even know how to do that or if it is even possible.

    If you are using macOS Mojave, this is normal: because of an update in the operating system, 1Password is not able to automatically submit any form anymore (this used to be the case). Now it can only fill your data on a page, but you will have to press the Enter key to actually submit the form.

    So... Don't know if that added much. I've never seen a mystery like that... Could they, nextdoor, have changed something in the past day or two tops as I log on to this site fairly often though often through my Mac and that, as I said, still works as normal. ??? The answer is that SOMETHING sure changed and since there was no 1Password update, it would sure seem to point to the website end. Note I also said above I made a Login in 1Password on my iPhoneXS and it fails too. So it's some interplay between the iOS version of 1Password and this Nextdoor website.

    It is possible that something changed on that website, yes. I would like to test this and see if I can make this work however. Can you please let me know the full URL where you are trying to login, so I can test it on my Mac?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file