Autofill opens browser history

Hey, 1Password team --

I've been experiencing an issue for over a month now where my 1Password Chrome Extension will intermittently open the browser history tab when I click "Autofill". This doesn't happen on every login/account and has been difficult to recreate. I'd estimate 20% of my login attempts result in this behavior. I've tried uninstalling and reinstalling the extension and wiping my chrome settings to no avail. Would love your help resolving this!


1Password Version: 1Password 7 Version 7.3.BETA-14
Extension Version: 4.7.3.90
OS Version: OSX 10.13.6 / Chrome 74.0.3729.157
Sync Type: Dropbox/1Password Teams

Comments

  • Hello @theycallmeswift,

    The Chrome history is directly reachable via the URI chrome://history/ and I can only assume certain Login items have that stored in the primary website field. That's the only way I can imagine this happening and removing the extension or resetting Chrome's settings wouldn't stop it from happening.

    The next time you experience this note the Login item and the site the item is for. Manually navigate to the site's sign-in page and copy the URL for what is hopefully a dedicated page for the sign-in form. Overwrite the existing URL stored in the primary website field with this and see if the issue no longer happens for that item.

    Hopefully that helps because I can't think of what else could even begin to cause that kind of behaviour.

  • @littlebobbytables that was my initial thought as well, but the extension is actually opening two tabs (the correct tab and the history tab). It's also not guaranteed to happen each time I use a login. I'd estimate the behavior appears 20% of the time.

    The only other thing I can think of is that the Chrome menu is not closing properly and the click is being registered through the 1password extension into the menu. If you look at the screenshot below, the History button on the chrome menu is approximately at the same height as the login button in the 1 password extension. What do you think?

  • littlebobbytableslittlebobbytables

    Team Member
    edited May 24

    Greetings @theycallmeswift,

    So if I hide the 1Password icon to the Chrome menu, something I've never done before, then I can reproduce the behaviour. What I'm unsure of though is whether this is a bug with 1Password, Chrome or macOS. I will file an issue just to see what the devs reply with but all I recommend is to move the 1Password button to the toolbar menu so that the Chrome menu isn't active and reacting to the mouse. You can do this by right clicking on the 1Password button and selecting the menu option Show in Toolbar.

    So it isn't that 1Password is opening a second tab, it's that a single click is being acknowledged by both 1Password and Chrome and as a result each is performing an action.

    As you're on a Mac it's also worth noting that you can access 1Password mini also by the 1Password icon in the macOS menu bar at the top of the screen or via the keyboard shortcut ⌥⌘\. That keyboard shortcut will always open 1Password mini while the keyboard shortcut ⌘\ is to fill the current page. The latter differs in that if you have a single best match Login item 1Password mini won't show, it will simply fill using that Login item.

    ref: apple-3714

  • Good to know, thanks for your help @littlebobbytables!

  • brentybrenty

    Team Member

    :) :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file