Browser freezes upon password generation

AndiHAndiH
edited February 14 in 1Password X

When I try to change my password on any site, the plugin freezes the whole page. (Chrome, Version 72.0.3626.109 Official Build, 64-bit)

It looks like this:

Step 1:

Step 2:

Step 3:

After I click Step 3 the browser window freezes and only a reload is possible.

The background page of the plugin reports the following errors:

44Unchecked runtime.lastError: The message port closed before a response was received.
15Unchecked runtime.lastError: Could not establish connection. Receiving end does not exist.
3background.js:31 Uncaught (in promise) TypeError: Cannot read property 'overview' of undefined
    at Object.configure-show-login-prompt (background.js:31)
    at r (background.js:31)
configure-show-login-prompt @ background.js:31
r @ background.js:31
my.1password.eu/api/v2/vault/gpioktxrldwfyk3koyczncsnra/34/items:1 Failed to load resource: the server responded with a status of 409 ()
background.js:31 [_request] Request "/api/v2/vault/gpioktxrldwfyk3koyczncsnra/34/items" failed: ServerError: Incorrect Version value has been sent.
    at new t (chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:31:155638)
    at _handleQwestError (chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:31:356001)
    at Array.f (chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:24:626593)
    at chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:24:626282
    at chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:24:487066
    at p (chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:24:487176)
    at s (chrome-extension://khgocmkkpikpnmmkgmdnfckapcdkgfaf/background/background.js:24:486539)
(anonymous) @ background.js:31
2background.js:31 Uncaught (in promise) TypeError: Cannot read property 'overview' of undefined
    at Object.configure-show-login-prompt (background.js:31)
    at r (background.js:31)

One final note: It works in Firefox.


1Password Version: 7.2.4
Extension Version: 1.15.0
OS Version: macOS Sierra (10.12.6)
Sync Type: 1password account

Comments

  • I also tried it with my second mac which runs mojave. Same issue :(

  • Hello @AndiH,

    I've been able to reproduce and we have a bug report filed. The "freezing" is normally 1Password X overlays a dialog on top of the page and at least part of this is occurring even though the dialog is not present. If you were to reproduce the effect you would find that tapping the escape key should find the page becomes responsive again as escape dismisses the invisible overlay. I don't know that it will always be the case but what I found when testing was after dismissing the overlay that I could use the inline menu to save and that it would correctly appear. Of course we still need to correct the issue but I'm hoping that might help while we work on it.

    ref: x/b5x#788

  • AndiHAndiH
    edited February 15

    Okay, indeed it works sometimes if you fiddle around. Escape didn't do it for me, but right-clicking to open the context menu did something. Anyway I hope you will find a fix soon.

    Thanks for notifying me :-)

  • dtearedteare Agile Founder

    Team Member

    I think I might know what's causing this. Investigation is needed but I have a clue to follow thanks to your logs. Thank you for posting them! ❤️

    ++dave;

  • Nevermind. I hope you'll find a fix soon :)

  • BenBen AWS Team

    Team Member

    :+1:

    Ben

  • I to have this same issue, I'm VERY impressed with how 1password works, however I'm very disappointed that the Generator isn't working correctly and I'm having the issue listed above, ESC does however unlock the screen, BUT on Some sites, when changing your password, you are given 2 blanks to fill in, selecting the first blank and telling it to use the suggested password makes it jump to the second blank, putting in the password, but leaving the first blank, blank, and you cannot copy it from the second blank to put it in the first blank either. Please include this in your bug fix. As we may end up going with LastPass because of this issue. Thank you. In addition while trying to sign up for THIS site, I found that the Password manager for Chrome is probably what is causing the issue. When I tried to once again generate a password with 1password, CHROME popped up trying to generate a password, and it overlayed the 1password menu and put it in the background where you cannot click on it, then when moving to the second field, THEN you can see 1password, however, again, it just fills in the second password and not the first one. This is something that is very annoying. I am about to try disabling Google Chromes password app, however, once I do that, I can't get my passwords that I wanted to move to 1password. So it's defeating the purpose of having it. You should create some sort of migration tool, to pull passwords already in Chrome and Firefox into 1password.

  • I'm seeing the same issue with 1Password X - just started subscribing after being on 1password 4 forever. Hitting Esc several times will fix it but it's super annoying!

  • Hi.
    I have created multiple accounts on different websites recently, and I use 1Password X (1PX) to generate a memorable password and then I press on the fill button. But after I do that it's like the webpage freezes! I can't press anything! Either buttons or links. So I can't proceed with the registration process! Thankfully I could just refresh the page and start over the process and instead using the fill button I use traditional copy pase with the mouse.
    I inspected the page and I found that 1PX creates an iframe dom element (will id op-save-login) witch is placed over the whole page (like a modal window). If I remove that element the page works fine again.

    Can u guys fix this? (It's a little annoying :P )

    Stay awesome

    // Simon (^-^)


    1Password Version: Not Provided
    Extension Version: 1.4
    OS Version: Not Provided
    Sync Type: Not Provided

  • Hi @cshelton, @ThaVerge & @mrKnorring,

    The developers are aware and working on getting this fixed. Hopefully it won't be too long and I'm sure somebody will post when a beta is worth trying for those willing to give it a whirl.

  • beyerbeyer

    Team Member

    Hey @cshelton, @ThaVerge & @mrKnorring,

    We've just pushed both a new beta (1.15.1.beta) and stable (1.14.1) which should fix any issues with displaying the save item dialog and tab freezing. I sincerely apologize for any inconvenience this caused. Please let me know if you are still having problems after getting the update!

    Cheers,

    Beyer

  • Hey @beyer
    It works better, thx <3

  • dtearedteare Agile Founder

    Team Member

    Woot! I'm glad to hear things are working for you now. 🎉

    Thanks for letting us know. 🤗

    ++dave;

  • Just installed the update. Everything works fine now. Great work gals and guys!

  • I'm glad to see that bug fixed as well :smile:

  • dkvkdkvk

    Hey, just found this thread about this issue of freezing page after filling in generated passwords.

    I am using 1PasswordX 1.15.2 on my Mac using Chrome.

    I still have this issue, not sure what I can do to fix it.

    Any suggestions?

  • kaitlynkaitlyn

    Team Member

    Hey there @dkvk – I can't say that I've seen this happen myself in 1.15.2. Are you noticing the freeze on certain web pages or every time you try to generate a password in 1Password X. Additionally, are you using the new, redesigned version of the popup or the old popup?

  • dkvkdkvk

    Hey @kaitlyn,

    The freeze occurs on every webpage I try. It happens both when I try to generate a password as well as save login I have typed in my self.

    See screenshot of what the popup looks like.

  • kaitlynkaitlyn

    Team Member

    @dkvk – Sorry for the trouble here! 1Password X should be presenting you with an overlay and a popup asking you which vault you'd like to save your new Login in. It sounds like you're receiving the overlay without the popup, which resembles a freeze since you can't access anything on the page. I'm curious what happens if you press the esc key during the "freeze." Would you mind trying that out and letting me know what the results are? Along with that, what version of Chrome are you using?

  • dkvkdkvk

    @kaitlyn

    When I press the esc key the blocking iframe disappears and I can interact with the page as usual again.

    I have had this issue for at least a couple of months. Over the time I have upgraded the versions of 1Password and Chrome and have always used the latest version of them all. At the moment I use version 74.0.3729.169 of Chrome.

  • kaitlynkaitlyn

    Team Member

    @dkvk – That sounds like exactly what I described then. I'm glad you're at least able to press escape rather than refreshing the entire page. That does seem strange that the issue has come along with you through all these updates. Can you please remove and reinstall 1Password X? Once you sign back in, go ahead and attempt to generate a password again and let me know how it goes.

  • dkvkdkvk

    Hi @kaitlyn

    A reinstall solved the issue!

    I should have tried it on the first hand. Although strange that the old implementation/bug was hanging on.

  • ceceliacecelia

    Team Member

    Hooray! I'm happy to hear reinstalling did the trick @dkvk. That is very odd that the bug hung around post-update, though. If something like that occurs again, please let us know — We'll be happy to look into it with you. :)

    Cheers!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file