Keyboard entry requires mouse click first

When I launch 1Password for Windows 7.3.684 on my Windows 10 desktop, I have to click in the space to enter my password before it will accept keyboard input. If I have 1Password open on screen, the keyboard shortcut to "find" a password [Ctrl+F] doesn't work. I may be old school, but keyboard shortcuts can be quicker and more precise, and I used to have that functionality in 1Password for Windows V4 before I upgraded to a subscription, family plan. I see some related posts in the Windows forum and was not sure if this is related to those posts. Thanks for a great product.

1Password Version: 7.3.684
Extension Version: N/A
OS Version: Windows 10 Pro 1903
Sync Type: 1Password subscription
Referrer: forum-search:keyboard shortcut windows 10 desktop


  • bundtkatebundtkate

    Team Member

    I'm not seeing this on my end, @Prepared, but one thing or another causing some focus troubles is definitely well-documented and I'd wager both of your issues are related to that. When you open 1Password, we ask Windows to put focus in the Master Password field, but we cannot force that to happen. If something else is competing for focus, it can win out, and even on my system where focus tends to be fairly reliable, I have seen it misbehave once or twice. Similarly, with Ctrl + F, all that's doing is putting focus in the search field. So, anything that causes trouble with the Master Password could cause trouble there as well.

    This is an issue we've never been able to reliably reproduce. As I mentioned, it's happened to me on fairly rare occasion, but ask me to repeat it and I'm at a loss. This can be a third-party app competing for focus, so the best I can generally recommend at present is that we can take a look at some diagnostics and look for apps that might be likely to do so. If this is something you see each and every time you use 1Password without fail, this is probably worthwhile. If it's intermittent at all, this is a less likely cause. In those cases, if you know of anything that seems to trigger the issue, let me know. I would absolutely love to find steps to reproduce this problem as I know it is quite frustrating to those it impacts and reproducing it would go a long way towards fixing it.

    As it stands, we have and will continue to make changes aimed at fixing this problem, but since we aren't able to reproduce it ourselves, y'all are our eyes and ears. We'll only know what worked when our customers stop seeing it, so regardless of how this issue behaves for you, it would be awesome if you could keep an eye out after each update and let us know if you see things getting better. :+1: And, of course, if this is consistent enough you feel looking at third-party interference is worthwhile, let me know and I'd be happy to take a peek.

  • I understand the issue with Windows "focus." I run a high-end Windows 10 desktop with many applications and processes running. Even when I start 1Password, thereby 1Password being front and center at the time, I still have to click on 1Password before it will take password entry. I appreciate all of your efforts to resolve this. Using a mouse if fine, but keyboard shortcuts are so much quicker.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Prepared,

    Please try this in the upcoming 1Password 7.4 update as we do need your help to test it. We don't have a timeframe yet but we're getting close.

    Due to internal major changes we're making in 1Password 7.4, we have to rework our window handling a lot and that meant our focusing code has been given an update as well. We don't know if it is better but we know it is not worse as we still cannot reproduce the issue.

This discussion has been closed.