Extra Page Opened with 1Password X authentication


Team Member
This discussion was created from comments split from: authentication error on each login.


  • edited May 2019

    Hello, I'm having a similar issue. I'm using the latest versions of Chrome (74.0.3729.169), 1Password Version (7.2.6), Chrome 1Password X extension (1.15.2), and OSX (10.14.5) Here's how it happens:

    1) 1Password is in a locked state (e.g., due to inactivity or my computer being asleep)
    2) I open a website that requires a login (e.g., Chase.com -- this is just an example, this issue occurs on every website I've tried so far)
    3) I click on the 1Password browser control located within in the username/password box form, and the "Shift-Cmd-X to unlock 1Password" box pops up
    4) I enter my Master password to authenticate, which works and the various 1Password autocomplete login options for Chase.com appear
    5) Then immediately after that, a new tab in Chrome opens to "https://my.1password.com/signin/?a=xxxxxxx" asking for the Master password to login again. In other words, it's asking for the same exact authentication a second time (once in the browser extension box, and now once in the new tab)
    6) It doesn't matter if I just close this new tab without entering anything, or if I re-enter my Master password on tab and login a second time --- the initial login from the 1Password extension box worked and it is already authenticated. So it appears the second tab login isn't doing anything.

    This issue just started happening with the most recent 1Password update, and is happening on my home iMac as well as my laptop Macbook pro. It seems like a bug because the second login doesn't seem necessary at all -- the first extension login woks to authenticate and I'm able to successfully autofill passwords regardless of the action I'm taking on the tab with the second login prompt. It's not a major issue, but is pretty annoying to have tabs popping up every time I have to re-authenticate via the Chrome extension. This only seems to be an issue with the Chrome 1Password X Extension (I don't experience this with Safari).

  • kaitlynkaitlyn

    Team Member

    Hi there @adamcadamc, and welcome to the forum! Thanks for the detailed report and steps to reproduce the issue. It's quite helpful. :)

    I've got a couple questions to start off:

    • Have you changed anything on your account recently? (e.g. enabled 2FA, changed your Master Password, updated your email)
    • When you close the second tab and choose not to authenticate, do you notice that your data is still synced between devices? For example, if you create an item in 1Password X, does it immediately populate in 1Password for Mac? And if you create an item in 1Password for Mac, does it then show up in 1Password X?

    Next, I'd like you to post (or email) a copy of your logs so we can take a closer look. We've got a handy guide on how to gather your logs here. You're welcome to post them in your response back to me or let me know if you'd prefer to move the conversation over to email where things are a bit more private. It's totally up to you!

  • Hello, thanks for getting back to me so quickly!

    • To the first question, I haven't changed anything regarding my account, the only change within the past few weeks is the update to the 1Password mac and 1Password X apps (I think it was last week or the week before that I noticed the updates come through). Other than that, I haven't updated my account at all.

    • To the second question, I wasn't really looking for the exact scenario you described. I can try and see what happens tomorrow morning, but I did experience a fairly similar issue (when creating a new 1Password forum account to post this). The 1Password X extension recognized it as a new login, but then when I attempted to save it and add that login to my vault, the 1Password X box displayed a "server cannot be reached" (or similar) error -- I can't remember the specific message since it was earlier today -- but it was 100% in the nature of "can't reach/connect to server". I was for certain connected to the internet at this time, and experienced zero connection related issues with any of the other apps I had open. I specifically looked at my network connection when this happened and it appeared normal. So maybe this is related to a syncing issue like you mentioned? When the error message was received, the new 1Password forum account credentials did not save to my vault at all. Later in the morning I actually had to go reset my forum password because I used the password generator when creating my account (thinking it would save to my vault like normal) and it didn't -- and I didn't write it down or anything. So, it definitely did not store in my vault at first. After I realized it didn't save, I opened Safari with the forum password-reset link emailed to me, and when I reset the password, the Safari 1Password extension stored my new forum credentials just fine -- which synced between apps/devices.

    My log file is linked below (thought it would be cleaner than dumping the whole log in here). Just looking through it briefly, there appear to be various authentication failures/401 server errors in it. Anyways, I look forward to hearing what you think is going on, thanks!

    Log link:

  • kaitlynkaitlyn

    Team Member

    @adamcadamc – Thanks so much! It looks like there's a 2FA issue going on, so that's the reason for the request for re-authentication. Without re-authenticating, 1Password X won't be able to sync, which is the exact reason for the "server cannot be reached" issue you experienced. Now what I'm curious about is if 1Password X syncs if you do sign in on that second tab. You can give it a try by repeating the steps in your original post, but signing in on the second tab instead of closing it. After that, go ahead and try to save a Login again (a test login is just fine). Do you still see the same error or were you able to save the Login successfully?

  • @kaitlyn just tried it:

    1) Entered my Master Password in the second tab, upon hitting the "Sign In" button that tab closes and I'm back on the original tab
    2) I click the 1Password X icon (next to the Chrome search bar) to create a new log in, hit the "+" button to actually create the login, and immediately upon hitting that another tab opens - to https://my.1password.com/signin/ again -- asking for my master password once again.
    3) Enter my Master Password in the third tab and I'm logged into https://my.1password.com/vaults/... this time (unlike the first time this tab doesn't automatically close upon hitting "Sign In" but remains open. But on loading https://my.1password.com/vaults/... there is an error message saying "the requested vault cannot be found" -- I attached the screenshot to this reply.
    4) While on https://my.1password.com/vaults/ I tried step 2 again (clicking the 1Password X icon, hitting "+" to create a new login to see if it will sync), and the same thing happens (a 4th new tab opens to the https://my.1password.com/signin/ page, etc.) It appears to just keep doing this upon repeating step 2 (regardless of what tab is active when I click the 1Password X icon to try to create the new login). So it's stuck in a cycle of opening new tabs essentially, doesn't seem like any of the Sign In attempts are actually persisting.

    I should mention as well that I do use 1Password for both business and home use. I have used both my home and business vaults/accounts side-by-side for awhile now. So I don't know if something is getting screwy with 1Password X and the multiple account management/authentication? But, this behavior didn't start occurring (the second tab popping up, etc) until the most recent 1Password X update (versions provided in my original post). I have also tried completely uninstalling and reinstalling 1Password and 1Password X and the issue still occurs.

    New log link: https://www.dropbox.com/s/um86i21p9eh6q86/1PasswordX_log2.log?dl=1

  • @kaitlyn just to add some more fuel to the fire, I just was creating a new account on a website, 1Password X detected it and asked to add it to my personal vault. I tried to add it, but received the "Server cannot be reached" error I described above. But, then I switched the vault selection box to instead add it to my work vault, and it saved/synced just fine...which is weird because my personal vault was unlocked in the same Chrome window (I had just used it to log in to another website).

  • kaitlynkaitlyn

    Team Member

    Thanks, @adamcadamc! I think we can narrow the issue down to your personal account since it seems as though your items are syncing on your work account. As a troubleshooting step, could you please remove and reinstall 1Password X? It should ask you to sign into your accounts to get set up, but go ahead and try saving a new item to your personal vault after that and let me know how it goes.

  • @kaitlyn I'm happy to try re-installing again (I already did that previously). Also, I just acquired a brand new laptop on Tuesday (MacBook Pro) and newly installed 1Password 7.3 (and 1Password X 1.15.2) and the same behavior is happening on the brand new laptop.

  • @kaitlyn just uninstalled, restarted, and re-installed and the same thing is happening still. I did notice that upon the new install there was a message to "update 1Password" on the top of the 1Password X box, which is a little bizarre since it's the most recent version available. Upon clicking the "update" link it just directs https://support.1password.com/explore/whats-new-1password-x/ page. I'm thinking about trying the 1Password X beta to see if anything changes.

  • @kaitlyn so just to quickly follow up, I just installed 1Password 7.3.1.BETA-0 and 1Password X beta 1.16.2, and the extra tab/login issue is not occurring. It seems to be resolved with the "integrate with 1Password for Mac" option turned on. I will post back if anything comes up. The issue still remains on my desktop (with the non-beta versions).

  • kaitlynkaitlyn

    Team Member

    I appreciate the detailed response, @adamcadamc. I'm wondering if updating to the 1Password X beta on your other computer helps out the situation. Don't worry about updating 1Password for Mac to the beta just yet because I'd like to check if the 1Password X beta is what's solving the issue or if connecting to 1Password for Mac is solving the issue. Would you mind installing the 1Password X beta on your computer where the issue still exists? Without connecting to 1Password for Mac, are you still seeing the same additional page open up?

  • @kaitlyn just tried on my desktop, with 1Password X beta (1.16.2) and 1Password 7.3 and the issue still occurring (regardless of whether the "Integrate with 1Password desktop application" option is off or on. Looks like there is a communication issue between 1Password X beta and the non-beta desktop when the "Integrate with 1Password desktop application" option is on.

    After trying this, I just updated the desktop app to 1Password 7.3.1.BETA-0 and the problem is fixed ONLY when the "Integrate with 1Password desktop application" option of 1Password X beta is on (I hadn't tried turning that option off earlier this morning when I replied). When I flip that option off, the issue resumes.

    So seems like its a 1Password X authentication issue, and that connecting/integrating with 1Password desktop application fixes it (I'm assuming that it uses authentication via the desktop app then which circumvents the issue).

  • kaitlynkaitlyn

    Team Member
    edited May 2019

    @adamcadamc – I'm glad we've narrowed it down this much! I'd like to get the 1Password X team involved, so I'm wondering if you could send us a diagnostics report via email. Here are the steps to do so:

    1. Right-click on the 1Password X icon in Chrome
    2. Click Get Help
    3. Include a link to this forum thread and your forum username in the email

    One more question – do you use Duo for 2FA on your 1Password account or another authentication app?

    Let me know once you've sent us the report so I can keep an eye out for it!

  • @kaitlyn Just sent it in per your instructions. I do not use Duo at all, just the standard 2FA option.

  • kaitlynkaitlyn

    Team Member

    Perfect! I'm going to have our developers take a look, and we'll be in touch. :)

    ref: PZV-93854-642

  • kaitlynkaitlyn

    Team Member

    Hi again @adamcadamc! I'm curious if you'd be willing to try out the 1Password X beta and let me know if you're still experiencing the same issue. If you'd prefer to remain on the stable build, a fix should be making its way there very soon. Let me know!

  • edited June 2019

    Hey @kaitlyn, the problem went away when I tried 1Password 7.3.1.BETA-0, but only when the "Integrate with 1Password desktop application" option of 1Password X beta was turned on -- this was with 1Password X beta (1.16.2). I just updated to 1Password X beta (1.16.3) now, and the problem seems to have been fixed regardless of the "Integrate with 1Password desktop application" option is turned on or off. So it looks likes the issue has been fixed with 1Password X beta (1.16.3). Thanks!

  • @kaitlyn Update: my desktop (with 1Password 7.3.1.BETA-0) automatically updated to 1Password X beta (1.16.4) this morning, and the issue returned. Similar to 1Password X beta (1.16.2), the problem goes away only when the "Integrate with 1Password desktop application" option is turned on.

  • brentybrenty

    Team Member

    @adamcadamc: If you restart the browser, does that help?

  • @brenty completely shut down Chrome and restarted my computer, and the issue hasn't occurred again, so maybe that was the trick. Side note, I just got home from work and noticed that 1Password for Mac updated to 7.3.1.BETA-2, and 1Password X beta (1.16.4) is no longer able to connect to to 1Password for Mac. I tried reinstalling both, and restarting everything with no luck. I realize these are both beta builds, but figured I'd pass it along. The extra authentication tab opening issue doesn't happen regardless of whether the "Integrate with 1Password desktop application" option is turned on or off, so that's cool.

  • ceceliacecelia

    Team Member
    edited June 2019

    Hey @adamcadamc :) I'm happy to hear the re-authentication issue seems to be resolved, but that's really unfortunate about Desktop App Integration breaking in its place. Let's dig in!

    First, I'd like to take a few shots in the dark

    1. 1Password X does need to be manually unlocked once after Desktop App Integration is turned on, and since you reinstalled the 1Password X beta and 1Password for Mac, this does need to happen once more before the two can unlock each other. Can you try manually locking and unlocking 1Password X by "right clicking" the 1Password X icon in your browser's toolbar and choosing "Lock," then unlock it once with your Master Password. The next time 🤞🏻it unlocks, Desktop App Integration should work.
    2. Can you make sure beta builds are turned on in 1Password for Mac (just in case - since you reinstalled). - 1Password Support article: Use 1Password beta releases -
    3. Since Desktop App Integration won't work if Chrome is in the middle of an update, can you check in Chrome's toolbar ⋮ » Help » About Google Chrome? If there's a relaunch button, clicking that should do the trick.

    Sorry for the silly suggestions - Just wanted to get the easy stuff out of the way. If none of the above sorts things out, would you be willing to send over some console logs from 1Password X? If you'd like, you can shoot them over here or in a private message. I've gone ahead and started a private thread, so if you'd prefer to send the logs there, please compose an email to [email protected] and include [#YLK-96846-879] in the subject line of your email to ensure the logs are sent to me. Here's a guide for sending console logs: 1Password Support - Collecting and sending logs

    Thanks! <3

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file