Login Item with multiple websites only fills first entry

I am a systems engineer and connect to many, many websites and servers each day. As such, many of those websites are only internally facing on our network and most utilize Active Directory to perform authentication. When I need to change my AD password, I'm also forced to manually update the many different login items with my new password. Today, I used a single Login item to store my AD username and password and instead of updating the additional entries for other websites that use the same creds, I copied the website URL from the other Login entries and pasted into my new, single login item. I then manually browsed to that website in Chrome, clicked my 1P extension, and was presented with only my new login item in 1P Mini. However, when I clicked that item to auto-fill my creds, the tab browsed to the website in my first website entry and auto-filled the creds on that site... I tried using Google Chrome Version 74.0.3729.169 (Official Build) (64-bit) and just updated it to Version 75.0.3770.100 (Official Build) (64-bit) with the same results. Additionally, I tried to use the Edge browser with the same results. Is this an expected behavior? Should I stop trying to consolidate all my websites into a single login item?

1Password Version: 7.3.684
Extension Version:
OS Version: Win 10 Ent 1803
Sync Type: 1P for Families


  • Sorry, this isn't a Windows Beta edition! I'm a noob at using your board... :)

  • bundtkatebundtkate

    Team Member

    This isn't expected behavior, @KenJHen, and probably means there's some difference between the URL you're signing in on and the intended-to-be-matching URL you saved. This will be a bit of a laundry list, but checking each of these is worthwhile:

    1. Make sure each of these URLs are in separate website fields. Serializing with commas, spaces, semicolons or other punctuation won't work.
    2. Make sure those URLs actually match those you're signing in on. I'm gonna pick on Microsoft a smidge here because they have this habit of having sign-up/change password forms for given services with domains that don't match the service itself. I thus run into non-matching troubles with them a bit more often than others.
    3. Trim those URLs as much as possible. If there are referral parameters, language selectors and the like that aren't necessary to navigate to the page, getting rid of them in your website field can sometimes help.
    4. Finally, make sure these are secondary website fields up at the top of your item details and not custom fields down in another section. They should all be in a list right below the password for that Login item.

    Hopefully one of these helps, but if you're still having trouble or everything in the list looks okay, let me know. :+1:

  • Thanks for the reply. The issue is definitely not around any of those items. Let me add some screenshots for clarification.

    1. Browse to "http://xac2", which is a Citrix XenApp login page
    2. Clicked 1P Chrome extension
    3. Clicked the only result, which is my domain creds login with multiple websites; the xac2 website is the last in the list
    4. Browser is redirected to the first website in my list and attempts to login
    5. If I click Back button in browser, the xac2 page loads and 1P auto-fills the form...
    6. I re-ordered the websites in my Login item; same behavior where top of list website is opened...
  • Fixed the issue by installing the "1Password X – Password Manager" Chrome Extension. Nothing to see here... sorry to waste your time. :blush:

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @KenJHen,

    I'm glad you were able to use 1Password X instead.

    Just to clarify, you have the actual hostnames saved without TLD as in http://xac2 and not xac2.com? If yes, then it's a known limitation within the Windows app, it doesn't recognize hostnames yet; so it tries to find the valid domain that's available next in the Logins list and opens that instead. You could get around this by using the IP address instead but that's a bigger hassle for the moment.

    We will fix this in a future update.

    ref: opw/opw#2072

  • lumarellumarel
    edited June 2019

    Hey @MikeT and @KenJHen,

    Sorry for interrupting this conversation,
    Did you already try to use the full internal website-dns-name? Usually these internal websites listen to the internally configured ConnectionSpecificSuffix.
    I have several of these combined items with internal and external addresses in the same item (e.g. AD / AzureAD / ADFS / Citrix Director /...) and these work flawless, but they are all configured with the full dns-name including the internal TLD :)

    Nevertheless this is a cool feature to come Mike :+1:

  • Thanks for the info, @MikeT and @lumarel. Yes, in this environment, folks are accustomed to using only the hostname in URLs, omitting the domain name. Even though I already upgraded my Chrome extension to X, I updated a login entry to include FQDN, not just hostname. When browsing to a site lower in the list, I'm properly presented with the login. I accept the limitation and will use these work-arounds to continue moving forward. Thanks!

  • lumarellumarel
    edited June 2019

    You're welcome @KenJHen, That's great if these two options are already there! But we will see if 7.4 already brings this hostname only feature as well :):+1:

    (By the way 1Password X is just another solution for the 1Password Subscriptions, not a progression of 1Password 7 + the "legacy" browser extension, maybe you didn't know that)

  • MikeTMikeT Agile Samurai

    Team Member


    You're welcome, KenJHen.

    But we will see if 7.4 already brings this hostname only feature as well

    At this moment, it's not planned to be in 7.4. There are some work we started to do and need to finish first before we can fix the hostname limitation but that work is not going to complete in time for 7.4.

This discussion has been closed.