Desktop integration stopped working

Hi, friends.

Running the latest betas of 1Password 7 and 1Password X, on the latest version of Chrome. 1Password X and the desktop app seemed to have stopped communicating, and I see this error in the 1Password X Settings page.

I've tried all the troubleshooting steps I could find in the forum:

  1. Full OS restart.
  2. Disable desktop app integration. Re-enable. Lock > Unlock desktop app.
  3. Remove 1Password X from Chrome and reinstall.
  4. Reset 1Password X Device Keys from desktop app Help menu.

Any thoughts?


1Password Version: 7.3
Extension Version: 1.16.2
OS Version: 10.14.5
Sync Type: Not Provided

Comments

  • I'd been using the 1Password 7.3 beta with 1Password X beta (for Chrome) to use the integration feature for MacOS, allowing use of TouchID for login on my MacBook Air. Today 1Password 7.3 auto installed and now the 1Password X integration no longer works. Unfortunately I can't reinstall the MacOS beta as every time I click to search for updates it says I have the latest version installed, despite the fact I've got the option to install betas checked. I also tried uninstalling the 1Password X beta and installing the main version, but integration still isn't available there.


    1Password Version: 7.3
    Extension Version: 1Password x Beta 1.16.2
    OS Version: OS X 10.14.5
    Sync Type: 1Password.com
    Referrer: forum-search:1password 7.3 no integration with 1password x

  • Same problem for me. Same versions of everything.

  • BenBen AWS Team

    Team Member

    Hi folks,

    Integration with 1Password for Mac is only available in beta builds of 1Password for Mac. Because 7.3 is not a beta build, it isn't available there. We'll be pushing a new beta shortly.

    Thanks.

    Ben

  • BenBen AWS Team

    Team Member

    Hi all. I've merged a couple of threads on this subject. Please see above.

    Ben

  • Just downloaded the new beta and 1 Password X integration is restored. Thanks!

  • BenBen AWS Team

    Team Member

    You're very welcome. Thanks for the update. :)

    Ben

  • Confirming that the latest beta fixed it for me as well.

  • BenBen AWS Team

    Team Member

    Thanks :+1: :)

    Ben

  • I'm still having issues getting 1passwordx beta to connect with the desktop app...I am running versions:

    MacOS 1Password 7
    Version 7.3.1.BETA-0 (70301000)
    1Password Beta

    1Password X Beta 1.16.2

    Did you guys need to do anything special to get the connection to work again? I have restarted browser, toggled the connect/disconnect setting, all the basic stuff, still seeing the "Unable to establish a connection" message. Really missing touch ID support

  • Nevermind...I found the "Quit 1Password Completely" option from the mac toolbar settings. after doing that and re-opening 1Password desktop, the connection is restored.

  • kaitlynkaitlyn

    Team Member

    It's great hear that you were able to get things working again, @srwells! The 'Quit 1Password Completely' option quits both the 1Password app and 1Password mini. It's a fantastic trick resolves things more often than not, so I'm glad you found it. :)

  • Hello Team. Is Desktop Integration currently only available in Chrome with the beta 1Password X and beta 1Password 7? I was trying to get it to work in Edge (Chromium) for Mac but I get the same error as @gkeenan does above.

    Thanks

  • Hello,

    For the following combination:
    Mac App : Version 7.3.1.BETA-0 (70301000)
    Chrome Extension: 1.16.2.beta (build #20071) – released 2019-05-17

    Besides doing a 'Quit 1Password Completely' for the Mac App, I also had to restart Chrome for the integration to start working.

  • brentybrenty

    Team Member

    @orlando79: Do you mean after updating something? The context isn't clear form your comments.

  • @brenty, sorry, I can't tell you when it stopped working since I did not even know that 1PasswordX could work with the desktop app. It was only when I noticed it working on another machine that I realized this.

    Have opted to receive beta updates for both the browser extension as well as the desktop app. The former seems to receive frequent updates, so am not sure when the functionality broke since I relied solely on the extension until today.

  • brentybrenty

    Team Member

    @orlando79: Hmm. Do you have desktop app integration enabled in 1Password X settings?

  • I'm getting the same message as the original post; Unable to establish connection with a 1Password desktop app.

    Chrome 1PasswordX beta extension v1.16.4
    MacOS 1Password 7 Version 7.3.1.BETA-2 (70301002)
    Chrome Version 75.0.3770.90 (Official Build) (64-bit)

    The console log is showing (with IDs removed):
    14:12:04.493 background.js:31 Initializing Desktop App Integration. Attempting to connect to native app. 💌
    14:12:04.498 background.js:31 Connecting to native app
    14:12:04.591 background.js:31 Preparing hello payload for device
    14:12:04.591 background.js:31 (accountUUID, userUUID, server) =>
    14:12:04.591 background.js:31 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.
    14:12:04.594 background.js:31 Signing payload for account with kid
    14:12:04.595 background.js:31 🌈 Sending message to native app
    14:12:04.595 background.js:31 💥 Failed to send because our port was disconnected. Browser code signature became invalid?
    14:12:07.092 background.js:31 Attempt #1 to reconnect to the native app
    14:12:07.092 background.js:31 Connecting to native app
    14:12:07.185 background.js:31 Preparing hello payload for device:
    14:12:07.185 background.js:31 (accountUUID, userUUID, server) =>

    This repeats several more times each time I try to activate integration in the extension settings.

    Thoughts?

  • brentybrenty

    Team Member

    @jaotto: Code signature invalidation happens most frequently due to a pending update. Complete any updates and restart to resolve that. But if you have other software interfering, either by blocking the connection, trying to snoop on it, or modifying the browser, you'll end up in the same situation: 1Password will refuse to connect to a browser whose identity it cannot verify. Have you tried restarting the computer? Do you have any "security" software that might be interfering?

  • markmc999markmc999
    edited June 18

    Hi all

    Same here.

    Using desktop:
    1Password 7
    Version 7.3.1.BETA-3 (70301003)
    1Password Beta

    And Chrome client:
    1.16.4

    Tried reinstalling both, rebooted. disabling and reenabling extension and nothing seems to work.

    I'm getting no errors etc. however :(

    Chrome = Version 75.0.3770.100

  • kaitlynkaitlyn

    Team Member

    Hey @markmc999! Has Desktop App Integration worked for you in the past, or were you receiving this error right off the bat?

    First, let's try restarting both 1Password and Chrome. Go ahead and hold down the option key and click the 1Password icon in the right side of your macOS menu bar. Then, click on Quit 1Password Completely. Additionally, right click on the Chrome icon in your dock and select Quit. Reopen both 1Password and Chrome once that's done.

    If the issue still exists, it'd be helpful to see a diagnostics report from your computer so we can diagnose what's going wrong. Would you mind sending one to [email protected]? You can find the instructions here. Please include your forum username and a link to this thread in the email, and I'll be on the lookout for it.

  • Hi @kaitlyn

    Interestingly it is working today - my machine did a reboot and some updates from app store and it seems to have fixed it. I'd already tried what you had suggested but it is now working today.

    Thank you !

  • kaitlynkaitlyn

    Team Member

    @markmc999 – That's good to hear! Please keep an eye on it and let us know if it comes up again. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file