Chrome not connecting

This discussion was created from comments split from: Chrome extension broken after update to 7.3.


  • Couldn't connect to 1Password error after 1Password extension installation

    Google Chrome 75.0.3770.100
    1Password extension 3.48.0
    1Password 6
    OS X El Capitan 10.11.6

    Each time the connection is attempted, the following log entries are made:

    2019.06.28 13:20:42.866[1726]: 633001 [EXT:(Secondary Thread 0x7ff625b5f230):] M webSocketForURI: | [ES4] Extension connected Chrome-Extension 'chrome-extension://aomjjhallfgjeglblehebfpbcfeobpgk / (null)'

    2019.06.28 13:20:42.930[1726]: 633001 [EXT:(Secondary Thread 0x7ff625b5f230):] E findExtensionProcessForPort: | Failed to find extension process for 'chrome-extension://aomjjhallfgjeglblehebfpbcfeobpgk:52524', my PID: 1726, invalid output: '1395
    ', apps found: (
    2019.06.28 13:20:42.930[1726]: 633001 [EXT:(Secondary Thread 0x7ff625b5f230):] E findExtensionProcessForPort: | Stopping connection since no PID was found to validate the other side of the connection.

    ● Screenshot of 1Password mini after the Google Chrome 1Password extension has been installed:

  • In my preceding post, the correct 1Password extension version number is

  • brentybrenty

    Team Member

    @macindigo: Quit Chrome, and Quit 1Password Completely -- Command Option Control Q. When you restart them, are they able to connect? The WebSockets messages you're getting indicate that there is no Native Messaging connection available, but restarting should get that back up for you. Let me know.

  • macindigomacindigo
    edited June 2019


    I had quit Chrome and 1Password completely before posting and that did not solve the issue. I quit 1Password mini via the gear icon on its screen as the Command Option Control Q combination does not always work.

    As you suggested, I completely quit 1Password with Command Option Control Q and that did not make any difference either. Same error and same log entries upon Chrome and 1Password restarts.

    Just to be clear, here is a screen shot of what I see when I click the 1Password extension icon in Chrome:

    I've gone to the support site and done all that the support site suggests, including reinstalling everything, but the error persists.

  • Brenty, all little more information:

    When clicking the 1Password Chrome extension icon, with 1Password and mini both running, the connection process causes 1Password to quit.

    If I click it without 1Password running, 1Password will start, briefly display the login screen (< 1 second) and then quit.

    In activity monitor, I can see PIDs for 1Password and 1Password mini. It seems that whatever is causing 1Password to quit may well be why there is no PID to validate, per the third log entry.

  • ag_anaag_ana

    Team Member

    @macindigo: Can you please send us a diagnostic report from your Mac to [email protected] so we can take a closer look at why this is happening to you?

    After you have sent the email, please feel free to post the ticket number you received so we can locate your message and get back to you as soon as possible.

    Looking forward to your message!

  • brentybrenty

    Team Member

    @macindigo: I've split you off into a new discussion because you'd posted in one about 1Password 7.3, and I missed that you're running an old version of 1Password in your earlier post.

  • Brenty and ag_ana, thanks for your help with this.

    Per the support site documentation, I uninstalled and reinstalled the 1Password Google Chrome extension and Google Chrome itself. After re-reading the "Looking for the 1Password app" screen text and 1Password's quitting during the extension connection process, it became clear that re-installing 1Password was an option.

    I downloaded a new copy of 1Password-6.8.9.pkg, re-installed 1Password and the Google Chrome extension connection process completed successfully.

    ! have two Macs, both running the same version of El Capitan and 1Password; both exhibited the same error with the Google Chrome extension. I compared the binaries after reinstalling 1Password on one machine with the other and the sizes are the same. However, command line diff finds that they are not identical.

    Both machines were originally updated to 1Password 6.8.9 via 1Password's built-in software update process and the current install was done with a stand-alone pkg file. That's the only difference that I'm aware of.

    I didn't compare the binaries with a hex editor to see where the difference is but reinstalling 1Password resolves the issue.

  • LarsLars Junior Member

    Team Member

    @macindigo - glad to hear a re-installation seems to have solved things for you. Let us know if you have any follow-up questions. :)

This discussion has been closed.