Sync Now button grayed out

d00byd00by Junior Member
edited December 1969 in 1Password 3 – 6 for Mac
Hi,

I use 1 Password v3.2.1 (build 30653) on my Mac Mini2,1 OSX 10.6.4

I also use 1passwordPro v3.1.1 on my iPhone 2G with latest version of iPhone OS 3.

I am having problems syncing. The "Sync Now" button is grayed out in my 1Password app in OSX.

I have to sync via IP address which is a pain.

My firewall is off both in OSX and in my router. I use Little Snitch but it allows connections in 1Password, Bonjour.

Can anyone give any suggestions as to why I am unable to sync normally? :?

Both my iPhone and Mac Mini use the same Home Wifi Internet connection.

Comments

  • macpugmacpug Agile Customer Care
    edited December 1969
    I'm sorry you're having trouble. Please try these steps to see if it takes care of things for you:

    1. In 1Password on your iPhone, disable Wi-Fi Sync.

    2. In 1Password on your Mac, if your iPhone's name is listed under SYNC in the left pane,
    Control-click it, and choose Delete; then confirm your selection to delete the iPhone.

    3. In 1Password on your iPhone, re-enable Wi-Fi Sync.

    4. Almost immediately, a window should appear on your Mac, ready to accept the secret
    codes. If it doesn't, please quit and relaunch 1Password on your Mac.

    5. In 1Password on your iPhone, tap Allow New Connections, and enter your master password.

    6. In that Wi-Fi Sync Authentication window on your Mac, enter the secret codes, and
    click the Authenticate button. Be sure to do that while the secret codes are displayed
    on your iPhone; otherwise, you'll have to tap Allow New Connections again.

    Good luck. Let us know how it goes.
  • d00byd00by Junior Member
    edited December 1969
    macpug wrote:

    4. Almost immediately, a window should appear on your Mac, ready to accept the secret
    codes. If it doesn't, please quit and relaunch 1Password on your Mac.


    I followed the steps. I could not go beyond Step 3 because in Step 4 the window for entering secret codes is not appearing in on 1Password for Mac.

    I tried this multiple times with no success.
  • MartySMartyS AgileBits Customer Care (retired)
    edited December 1969
    d00by wrote:
    I followed the steps. I could not go beyond Step 3 because in Step 4 the window for entering secret codes is not appearing in on 1Password for Mac.

    I tried this multiple times with no success.


    It sounds like you need to tell 1Password on the Mac to re-authorize your iPhone. Please select your mobile device's name in the SYNC section of the sidebar and control-click it and choose the Delete option. This will cause 1Password Mac to prompt for the secrets from your iPhone the next time it is detected. Normally this sync authorization is a one-time operation.
  • d00byd00by Junior Member
    edited December 1969
    It's NOT working. I tried multiple times.

    The only way I can sync right now is through IP address! :(
  • MartySMartyS AgileBits Customer Care (retired)
    edited December 1969
    d00by wrote:
    It's NOT working. I tried multiple times.

    The only way I can sync right now is through IP address! :(


    If you can sync via IP address but no other way then your device's Bonjour "announcement" isn't being received by 1Password on your Mac. Either you have a firewall -- hardware or software -- blocking the packets or your device isn't on the same network subnet as your Mac.

    Please see our Wi-Fi sync troubleshooting guide here:

    http://help.agile.ws/1Password_touch/sync_problems.html

    I'd suggest you start with deleting the existing SYNC sidebar item for the IP address method you've been using and then perform an Ad Hoc network test. Then move on to the Bonjour section to make sure the mDNSResponder process is running and if necessary to test using the Bonjour Browser tool, etc.

    Please let us know the results of each of your tests and we'll help you further if you still can't get it working.
  • d00byd00by Junior Member
    edited December 1969
    I d/l the Bonjour Browser. It was not showing the 1Password app running on my iPhone.

    I created an ad-hoc network. That did not make the sync work either.

    I switched back to my normal wifi-internet connection. That somehow made it work.

    I authorized my device and now I am able to sync my 1password apps normally. (party)

    I guess Bonjour Thingy was messed up and somehow when I switched between a normal wi-fi and the ad-hoc network, that seemed to make the Bonjour thingy recognize my iPhone app.

    Thanks everyone for their valuable time and info.:|
  • MartySMartyS AgileBits Customer Care (retired)
    edited December 1969
    d00by wrote:
    I d/l the Bonjour Browser. It was not showing the 1Password app running on my iPhone.

    I created an ad-hoc network. That did not make the sync work either.

    I switched back to my normal wifi-internet connection. That somehow made it work.

    I authorized my device and now I am able to sync my 1password apps normally. (party)

    I guess Bonjour Thingy was messed up and somehow when I switched between a normal wi-fi and the ad-hoc network, that seemed to make the Bonjour thingy recognize my iPhone app.

    Thanks everyone for their valuable time and info.:|


    I'm glad you got things working and we appreciate knowing about it. Networking remains a mysterious "art" at times. Once the networking is working then so can the 1Password syncing!
This discussion has been closed.