1Password 7.3.705 Beta 4 update is available

MikeTMikeT Agile Samurai

Team Member
edited August 22 in Windows Beta



  • [IMPROVED] More consistent handling of TOTP fields. {OPW-4061}
  • [IMPROVED] Updated our translations with the latest from our incredible translators on Crowdin.
  • [SECURITY] User consent has been reset for Have I Been Pwned service with an updated security warning.


We have one last update before this goes stable; this fixes the issue with domain administrators not being able to install 1Password with User Access Control disabled. We also included a small fix for a rare condition where 1Password could be in a sync loop with a file download issue.

  • [FIXED] Domain administrators couldn't install 1Password with User Access Control turned off. {OPW-4020}
  • [FIXED] In a rare condition, 1Password could go into a loop of downloading a file during a sync session. {OPW-3947}


We made a few more adjustments to our installer to work better for admins that have administrator approval turned off. This should now install automatically without any prompts for you guys. In addition, we fixed the incorrect order permission glitch on the 1Password > app > 7 folder reported by @lumarel here.

  • 1Password prevented its install if Windows had the administrator approval turned off but this is treated as granting permissions, not denying as originally coded. {OPW-4020}
  • Fixed the incorrect order of permissions on the 1Password\app\7 folder. {OPW-4017}


  • Hey @MikeT!

    Looks good on my side as well now after the update :)
    And I didn't catch any other issues up to now :+1:

  • MikeTMikeT Agile Samurai

    Team Member

    Great, thanks for testing it.

  • FunctionFunction
    edited July 16

    Hi @MikeT , I am writing here to voice my concern about a change made in Build 701 since that post was closed.

    I am not a big fan of the change to require admin rights. Many users install 1password in a corporate environment. Requiring admin privileges makes it so they can't use the password manager at work. I understand the rationale for implementing the change, but a lot of users will lose functionality. I am one of them.

    Secondly, the way it was implemented requires an admin password for each update (at least that's been the case so far). Updates are no longer silent and quick.

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 16

    Hi @Function,

    Believe us, we don't want to do this but we have to for security reasons. It became too easy to compromise 1Password if we don't start locking down access to 1Password files.

    If you need to use 1Password at work where admin rights aren't granted, 1Password X is the better option if you can use Firefox or Chrome and you have a 1Password membership.

    Secondly, the way it was implemented requires an admin password for each update (at least that's been the case so far). Updates are no longer silent and quick.

    That will be "expected" for 1Password 7.3 for now, we do anticipate this will be the last minor 7.3 update. We have already improved our updater in 1Password 7.4 that will integrate with Windows' task scheduler so that admin rights can be automatically granted for future updates without bringing up UAC on every update.

  • It is a delicate balance and a difficult choice to make. Thanks Mike.

  • MikeTMikeT Agile Samurai

    Team Member
    edited July 16

    Thanks for understanding!

  • edited July 17

    I tried updating to 702, but it stalls and never installs. Then I force restart Windows Explorer via Task Manager, and get this message:

    I'm not doing anything, but signing into 1Password, going to Settings > Update > Update to 7.3.702

    Any suggestions? I've restarted my machine multiple times to no avail? Should I uninstall and re-install 1Password? I should note, I missed 701, so I'm updating from 7.3.684

  • bundtkatebundtkate

    Team Member

    When you say it stalls, @jcsully217, how long are you waiting? One thing that tripped me up with the new updater at first is that 1Password doesn't download the update until you trigger the update. In other recent 7.3 updates, the update is downloaded as soon as its available and installs right away so updates do go a fair bit slower with the new-new installer. I'd suggest opening the 1Password menu so you can see download progress (we're working on making this a bit clearer in the UI generally by using a banner, but have found it doesn't always display for some reason). If it reaches the end and doesn't start installing, you know it has genuinely failed. My thinking is that it's possible it's just going slow enough that you're giving up before it has a chance to try an update, but watching the download will allow us to confirm or rule that out.

  • brentybrenty

    Team Member

    @jcsully217: The error you're getting suggests that you're running it as an admin user. I haven't seen any cases where that's been a false positive. If you're not actively making 1Password run as admin (right-clicking, setting that option in a shortcut, etc.), did you maybe just install it as admin originally? If so, uninstalling and reinstalling not as an admin should do the trick. Let me know.

  • @bundtkate I downloaded it yesterday (16 July 2019 ~4PM), clicked install, I went home, today ( 17 July 2019) around 12:30PM I went to invoke 1Password, and I realized it wasn't open. I checked the task manager and found the beta installer, it had one process, then a second would appear, but said Suspended, then after about 1 second that second suspended process disappears. I tried opening 1Password to no avail, so I force restarted Windows Explorer and that is when I got that error above.

    @brenty I don't have a non-administrator account on this machine, it is a work machine, Windows 10 Enterprise 1803. It is joined to a domain, where I have administrator privileges set via a Group Policy. I can create a local account without admin access then try installing it, but that seems completely backwards. Also this contradicts what @MikeT stated earlier in this thread, and in the 701 thread:

    The biggest change in this update is 1Password now requiring the administrator rights to be installed.

    So should I try creating a local account without admin privileges and install 1Password through that account?

  • bundtkatebundtkate

    Team Member

    It requires administrator permission but not necessarily that you install using an administrator account. You can install on a local user account, if you want, and 1Password will prompt for admin permission (and the admin password to grant such permission) where needed. Plus, running a program as an administrator isn't the same as running it on an administrator account. Not all apps on your admin account run as admin (in fact, most probably don't). I know, kind of confusing, but at the end of the day, you (thankfully) shouldn't really need to worry about all that – I'm just sharing to try to clarify why what type of user account you have doesn't necessarily matter.

    To expound on @brenty's suggestion, what you could try here is to uninstall 1Password, then run the beta installer normally on your admin account – just double-click it, don't right-click and run as administrator (which is what triggers that error). Since you weren't watching the install before, I'd join in brenty's suggestion as well. We need know if you see any errors during that installation to know exactly what went wrong. Even though your account is an admin account, you should still see the prompt for admin permissions when needed. Since you are an admin, you'll just need to click "Allow", rather than enter a password, but you will still see the prompt. I have an inkling what might have happened is that since you walked away after clicking install, you never got the opportunity to allow the install to proceed, but give it another try and let me know what you find out. :+1:

  • So I uninstalled it via Control Panel, went to 1password.com and downloaded the installer. I double clicked the installer, did not install as administrator (via the right click menu). It already had my account, so I signed it and clicked 1Password then download. It downloaded then closed 1Password, I waited 5 minutes, then went into Task Manager and saw the beta installer then a second beta install process which would be suspended, again that one popped up for about a second then disappear. I waited another 30 minutes, force restarted Windows Explorer and it gave that message again. There was no prompt for admin permissions, or a prompt to allow the install. Any other suggestions?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jcsully217,

    Can you email us your 1Password diagnostics report, there isn't any reason any of our process (excluding Edge extension) should be suspended.

    Please use this guide to generate the report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • Hi @MikeT ,

    I just sent in the email.


  • MikeTMikeT Agile Samurai

    Team Member

    Got it, thanks.

    ref: MQS-27188-718

  • CartmanCartman
    edited July 24

    Sad to see the move to needing an admin password to install/update but I understand why. We will have to turn off auto-updating for our corp users and add that to the desktop support teams maint tasks.

    We had to do this for the Mac version as execs freak out when presented with needing to enter an admin PW to update. Silly but true.

  • brentybrenty

    Team Member

    Thanks for understanding. And although I can't promise anything at this time, we do want to see if we'll be able to offer a means to ease deployment in the future. The initial install will probably always require admin rights, but hopefully we can make it so that updates do not require it in a future version. Thank you for your input!

  • MikeTMikeT Agile Samurai

    Team Member

    FYI: We just shipped 7.3.704 beta 3 update, this include a small few fixes related to domain admins not being able to install 1Password with User Access Control disabled and a sync issue with a file download.

  • Problem again with install of 7.3.704 for me. Enclosing pix of questions and results...any help would be appreciated. Running Windows 7 and I am the admin...in order here is the results:

    1) Ready to install pword.jpg
    2) pwordprompt 1.jpg
    3) pworderror1.jpg

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @dennisgreenlee,

    We'll follow up in the email conversation we had with you.

    ref: WCU-82153-823

  • I'm getting an error on 2 separate Windows 10 Enterprise (the one I am writing this on is build 18941.1001) machines when trying to update from 704 to 705. Specifically after accepting the UAC prompt for elevation a dialog box pops up indicating a PermissionDenied error (code 5) from the OS. Is there anything I can pull to help determine what is causing the Access Denied error?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Zaepho,

    Thanks for reporting it.

    Unfortunately, there isn't an easy way to find out what's causing that issue. Generally, it happens when you have any open access to the 1Password app directory; it's as simple as Windows Explorer being open in the 1Password app directory or you have a web browser running with 1Password extension.

    As the error message would mention, try to close any web browsers, 1Password and other windows that may be related to 1Password and then click Retry.

    The updater is supposed to close all instances of 1Password running but if you wait too long, the 1Password extension can restart the instance while you are installing the new copy.

    You can also try restarting the computer and run the update first.

  • @MikeT Closing out my browsers worked! It'd be great if the installer detected the open file handle and gave a relevant message rather than waiting for the OS to return the generic access denied. Obviously that's a lot more work for the installer to do though. Thank you for your help!

  • bundtkatebundtkate

    Team Member

    It actually does detect these at the outset, @Zaepho – if any 1Password processes are running when you first initiate the update, the installer will kill those processes. As Mike mentioned, though, if you wait long enough and leave browsers open, the extension can relaunch 1Password. It's designed to wait long enough before relaunching for an update to complete, but not so long as to make things look broken when the update is done. It's a fine line, though, and there are for sure things that can make it not quite work the way we'd like. Combined with the fact that we can't detect the difference between 1Password itself having that folder locked and something else entirely, there is a limit on how useful we can make these errors without also making them confusing under other circumstances. We're definitely still making tweaks and improvements to this process, though, so we appreciate y'all's feedback a ton and are definitely continuing to keep it in mind and adjust what we can moving forward. :+1:

  • MikeTMikeT Agile Samurai

    Team Member
    edited August 5

    A lot of the improvements we've been making toward our updater is not yet available in any public releases; they're implemented in the upcoming 7.4 major update, so you should expect to see less of these issues pop up in time.

  • I can't use 1Password now since I do not have admin access, thanks bunches. How do I get 1Password to stop asking me to update? Saying No I do not want to update just means I get a new notification about every 2 minutes.

  • bundtkatebundtkate

    Team Member
    edited August 6

    You can't disable this dialogue, @mpallas, but it shouldn't matter that you're not an admin user necessarily. The installer now requires admin permission to make changes to 1Password files, but it doesn't require that your user specifically have admin access. If you, for example, have a local user account on your home PC that use from day-to-day and have given a separate user admin permissions, you'll see a user account control prompt asking for admin permission. Enter your admin user's password to grant that permission and 1Password can complete its install.

    This is the happy path so to speak – what I'd expect to happen for most home users that are not part of the administrator group – but I know this isn't going to be the path everyone finds themselves on. 1Password will need these permissions moving forward, but the exact recommendation for folks who aren't able to give that permission will vary depending on exactly what's not working in your environment. So, if you can tell me more about your environment – do you have the ability to grant these permissions via admin credentials? Is UAC maybe disabled for your non-admin user? Are you using 1Password at work and unable to get those admin permissions? Let me know and I can give you a better answer about what's best moving forward. :+1:

  • MikeTMikeT Agile Samurai

    Team Member

    Note that you can disable automatic updates in 1Password's Update settings, that'll stop it from prompting to install the update on every lock. This isn't intentional though, we're looking to improve this.

  • Hi guys. The current beta for 1Password for Windows is 7.3.705.BETA released 2019-07-30.
    When will the next beta?
    Betas are meant to be constantly updated.

  • GregGreg

    Team Member

    @r1ma: We are working really hard on our updates and we don't rush them. We release the updates (even beta ones) when they are ready for a wider audience, because 1Password is an important app that deals with people's the most sensitive data. The security and the integrity of that data is our top priority.

    We also don't post any ETAs, so I do not have any timeframes for you at this point. I hope for your understanding.

    If you have any other questions, feel free to raise them in the forum. We are always ready to help you with 1Password.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file