3rd party integration with Alfred


  • Q: Does 1Password v6.8.9 (from AgileBits store) work with Alfred v4.0.3? Alfred is not finding the vault automatically, and I don't know where to point it. (Actually Alfred finds 1P v4 vault, which I have no interest in.). Should they work? TY

  • brentybrenty

    Team Member

    @joccam: I'm not sure at this point. 1Password 6 was discontinued before this discussion from last year started. Do you have 3rd party integrations enabled in Preferences > Advanced?

  • @brenty Yes, I do. So I get 1password settings from v4.

    However, I just noticed something odd... I moved that folder out of the way (so Alfred would "automatically" find a better v6 folder), and after a little time, the v4 folder reappeared. So it seems v6 is creating the v4 folder (or I have a rogue process creating the folder???). Oddly, the passwords are NOT up-to-date with v6 1Password. So very confusing.

    Seems like it's trying to work... but the results are totally inconsistent and confusing.

  • Yeah, 1Password v6 creates the v4 folder when I check the "3rd Party Integrations" checkbox.
    So, I'm surprised the contents are not up-to-date with 1Pv6. Close but... incomplete.

  • 1Password is simply not including all the passwords. Includes 710 items and then stops. New items (?) are ignored. Not sure what’s up with that. Other than that, the 1Password<->Alfred configuration seems to work. Frustrating because it works... but not fully.

  • brentybrenty

    Team Member

    @joccam: Do you maybe have multiple 1Password 6 installations? Some people have installed it from both our website and the App Store at some point, and then there will be separate support folders for each with separate data:

    Mac App Store

    1Password website
    ~/Library/Application Support/1Password 4/

    Note that the second one there is the same support folder used for 1Password versions 4 through 6. Let me know what you find.

  • @brenty: TY for your help. I do have a 1Password from 2013 App Store, but it's not installed. AFAICTell, I only have a single 1Password 6.app installed.

    I killed 1Password mini, no 1Password running.
    I did have the two folders. The App Store one seems pretty skeletal and seems to have ended use 2H2018. I have now deleted (moved) it.

    When I restarted, 1Password appeared to be starting first time, so it seems to have been affected by the moved folder!! I configured for iCloud. 1Password then (seemed to) reload all data.

    At this point, the 1Password app knows about over 1,000 items, but (according to Alfred) the 3rd Party Integration .json file only knows about 710. The same test login is MIA.

    So despite the good tips, I am back to square one.

  • brentybrenty

    Team Member

    @joccam: Indeed, while you may not have the app installed currently, what we're looking for is the support folder. If that exists, then you likely still have data there, and 3rd party apps may be drawing from the wrong one. If you clear out the stuff from the version you're not using, disable 3rd party integration, verify that Alfred has cleared its index of 1Password as well, restart your Mac, and enabled it again, does that help?

  • @brenty: TY for your help again.
    As suggested, I just did the whole shutdown, reboot, checked that Alfred saw nothing (could not find file), and then enabled 3rd party integration. No joy. Unfortunately, still only 710 of my passwords loaded which still excludes my most recent one(s).

    My impression is that 1P is simply not saving out the full metadata?

  • brentybrenty

    Team Member

    @joccam: I've split you off into a separate discussion in the Mac legacy category, since you're using an old version and this isn't related to the beta, so we can focus on your specific issue.

    First, to clarify, 1Password 6 works differently than 1Password 7. I'd recommend the latter, as it vends metadata to Spotlight, and works across all vaults, account and standalone. 1Password 6 legacy 3rd party support is limited to the Primary vault, and it will only include Logins item with URLs.

    With that in mind, what are you looking at exactly when you're comparing Alfred's data to 1Password's? Are you using a standalone vault or a 1Password account? Are you maybe just "missing" item types that are simply not supported by the old version?

  • @brenty: The info about the URL did the trick. The MIA password metadata had no URL associated with it. I added one, and bingo! Thank you!

    As for 1Password7, is it still subscription only? I am open to upgrading but not so interested in another subscription.

    Thank you for your help in any case. I am glad this mystery is solved. I've never used Alfred for 1Password before, so this will increase the value of Alfred and 1Password for me. TY

  • brentybrenty

    Team Member
    edited September 2019

    @joccam: Ah, great! You're welcome. Glad that helped. :):+1:

    While I recommend a 1Password membership since that offers the best experience, 1Password 7 has never been "subscription only":

    1Password 7 for Mac: The Best Ever

    It can be purchased from within the app. If you'd like to give a membership a try though, shoot me an email at [email protected] -- I'll be happy to help you make the transition. :)

  • @brenty: TY for the heads up. When I go to the MacOS App Store, the In-App pricing is all subscription. The link you gave me shows $50 intro pricing and (now?) $65 which don't show up in the Mac App Store. Mac App Store is sub-only? Intro pricing is gone for 1Password users? TY

  • ag_anaag_ana

    Team Member


    You are correct, 1Password on Mac App Store only supports 1Password Memberships. if you want to purchase a license for 1Password 7, you need to download the app from our website instead ;)

  • Why doesn’t the web page pricing page mention the non-subscription pricing? I am not really keen on installing an app just to see the pricing. What is the pricing for personal upgrade from 1Password6, or is there a URL you could point me to? TY

  • brentybrenty

    Team Member

    @joccam: Pricing is in the link I sent you earlier. We don't promote "standalone" because, frankly, we did, for too long, and it was awful: thousands of emails like "I bought a license! Why can't I use 1Password seamlessly across all my devices without paying more?" Unhappiness all around. Things are better now. 1Password will offer you a license if you set it up with a local vault, not an account, which is the only way you'd need a license anyway. :)

    P.S: "Getting 1Password 7 ready for the Mac App Store" goes into more detail about the difference there.

  • @brenty: TY for the link with the explanation of subscription.

    TY for the link article, but the article is old. That’s why I asked about the “launch special” and what the current pricing is? Is there still any upgrade discount for existing 1Password customers?

  • brentybrenty

    Team Member

    @joccam: We're currently running the same promotional price (as mentioned in the article) and it will be sold again at the regular price (also listed in the article) once that ends (I don't know when that might be). That's available to existing customers and anyone else who takes advantage of it while it lasts. :)

  • @brenty: I just downloaded the app. After clicking on the 'license available' button, the pricing shows as $65. Is there a 'trick' to getting the promotional pricing, or is it over? TY

  • brentybrenty

    Team Member

    @joccam: I just double checked to make sure, and as I write this the promotional price is still available. I think maybe you haven't actually gone to the store/purchase option yet. Can you try that?

  • @Brenty: Thank you. FYI, I had to dig a bit. The pop-up that opened at launch led me via “License?” button to a page where the license is $65. It did that the first time I tried and again this AM. However, after your message, I dug a bit further and through the Application menu->Purchase menu, the very same pop-up came up with $50. Done!

    FYI, also, I paid with PayPal and ran into another hiccup. When I clicked to pay withPayPal, the PayPal pop-up appeared which I filled out, but when I clicked to complete the transaction, I was bumped out of the pop-up and into a browser. OK... so I logged in again, and pressed button to complete the transaction. At that point, the browser errored out, the 1Password 7 was hung, and as far as I could tell, the transaction failed (but only apparently). FYI, the browser errored with the following errror message:

    Store Error
    An unexpected error was encountered. Please try again, or contact us at [email protected] for assistance.

    Nevertheless, when I checked email, PayPal had succeeded. So I used the license file in 1Password7 and am now running.

    All FYI.

    Thank you for your patience, perseverance, guidance and generous help. I am now running 1Password7.

    Thank you, = Joe =

  • brentybrenty

    Team Member

    @joccam: I'm sorry for the trouble, but I'm glad you were successful! I haven't been able to reproduce either of those issues, and we haven't had other reports like that, but we'll see what we can find. And likewise, thank you for letting us know, and for your support!

  • MacOS (current) + Safari, in case it helps.

  • brentybrenty

    Team Member

    I'm on macOS 10.14.6 and Safari 12.1.2 here, and I'll see if anyone else is able to reproduce it. Cheers! :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file