Face ID is enabled, but it asks me my master password several times

edited April 2019 in iOS


Let me explain the issue.
I think it asks my master password on some cases; restart etc. That's okay. Let's assume that I restarted the phone and try to fill in a form. It asks my master password, I type in it and it shows the login items. (Btw, on that case if I go to details of the login item, copy/reveal/show in large type options are not available when I click the username or password. I think it is another bug.)

If I click the login item, sometimes it fails. Therefore, I click the password button on top of the keyboard and 1Password asks my master password again. If I do that again, it will ask it again, even I open the main 1Password app.

I recorded a video to show the problem, but I can not share it because my password is shown when I am typing.

Can you please guide me if I am missing some settings or something else? If this is a bug I can try to provide more information.


Security settings:
Lock on exit: disabled
Auto-lock: 1 hour

Face ID: enabled

1Password Version: 7.3
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided


  • BenBen AWS Team

    Team Member

    Hi @koraykupe

    This is a known situation when using the Password AutoFill feature in iOS 12. Launching the 1Password app and unlocking with your Master Password first may help.



  • @Ben Is it because of iOS12? Because it is quite annoying.

  • amswitzeramswitzer
    edited July 2019

    What I find super annoying is that in iOS 12 (and also in iOS 13 which I'm a public beta tester for), after a restart of the iPhone, you have to go deselect and then reselect the option to use Face ID before Face ID starts working again. This should not be the case.

    While I agree that after a reboot or iOS update, users should have to re-authenticate with the master password, Face ID should begin to work immediately upon successful access using the Face ID. I should not have to "jiggle the handle" by going into security, de-selecting then re-selecting the Face ID option just to get Face ID, which was selected anyway, to work again.

    And by the way, I use Face ID on several apps (banking etc) and it seems that 1PW is the only app that requires this routine in order for Face ID to work after a reboot or OS upgrade.

    Like I said - super annoying.

  • BenBen AWS Team

    Team Member
    edited July 2019


    You shouldn't have to toggle Face ID off and on within 1Password. The way it is supposed to work is like this:

    1. Reboot
    2. Launch 1Password app
    3. Unlock with Master Password
    4. Launch Safari
    5. Activate autofill
    6. Unlock with Face ID

    If you're having different results than that please generate and send us a diagnostic report _while the problem is occurring. The report will be of little use if the problem isn't happening at the time it is generated.

    Sending Diagnostics Reports (iOS)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/103277/face-id-is-enabled-but-it-asks-me-my-master-password-several-times#latest
    • Your forum username: amswitzer

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    You should receive an automated reply from our BitBot assistant with a Support ID number.  Please post that number here so I can track down the diagnostics and ensure that this issue is dealt with quickly. :)

    Once I see the diagnostics I'll be able to better assist you. Thanks very much!


    ref: WWY-93113-927

  • bradchoatebradchoate Junior Member

    I came here hoping this was a reported issue already and was going to report it if it wasn't. I have had the same experience. Now that Ben has explained what is going on, I think that yes: the times I've experienced this may have been after a reboot. iOS restarts itself after applying updates overnight, so intermittently I run into this, without warning.

    I wish there was a security preference that would permit 1Password to use FaceID and/or TouchID to unlock the keychain after a reboot. Is there a technical impossibility about doing that?

  • brentybrenty

    Team Member

    @bradchoate: There is an option for that (Settings > Advanced > Security), but...

    1. We don't recommend it, as that helps people forget their Master Password and then they're completely out of luck when they inevitably need it again
    2. No matter what, an iOS update can at any time clear the Keychain data needed to enable biometrics for 1Password, and then the Master Password will be required (doesn't happen with every update, but for major ones it is the rule rather than the exception; I'd put money on this happening when updating to iOS 13)
    3. The Master Password is used to encrypt the data, so it is needed to decrypt it; I can't stress this enough: you should expect to have to enter it sometimes; it's unavoidable, and a fundamental part of securing your data

    After restarting and/or updating iOS, if you unlock the main 1Password app using your Master Password, that can allow you to use biometrics to unlock there and also in iOS Password Autofill afterward. Most people don't do an iOS update or even restart their device every day, as it really isn't necessary to with that kind of frequency. I don't think it's unreasonable to have to enter the Master Password once a day, but in the vast majority of cases even that that will not be necessary -- though it depends on what you're doing.

  • Regarding to my first message,
    Would it be possible to redirect me to the main app or show a warning about it on autofill screen?
    I am not sure if other password manager apps have the same issue.

  • brentybrenty

    Team Member

    That's not feasible. 1Password doesn't know your intent. You may be happy to enter your Master Password to use iOS Password Autofill. If, however, you decide that you'd rather use Touch ID/Face ID, you just need to open the main 1Password app and enter your Master Password there the first time to enable that.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file