Can't sync via dropbox

Hello,

Yesterday I purchased both 1Password for Mac as well as 1Password Pro (iPhone & iPad). So both of these are running the latest versions. I've added lots of passwords on the Mac program and it is working fine but, despite several attempts, I cannot get my iPhone app to sync via Dropbox.

I have made sure that Dropbox on my iPhone is fully synced. I've tried deleting and reinstalling the 1Password app.

The message is:

"Failed to find the data file on Dropbox. Please make sure..."

But the data folder is in Dropbox. Can someone help?

Thanks, D

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    edited September 2011
    Hi Deeja45, welcome to the forums!

    I'm sorry about the issues you're having with Dropbox.

    Can you read this post by Khad about how to resolve this:
    Stop Syncing with Dropbox and then start using it again

    After doing that, open 1Password Pro on your iOS devices and see if Dropbox sync works now. If not, then on the iOS devices, go to:
    Settings > Sync > Dropbox Sync > Account > Reset

    After resetting the Dropbox Sync, configure it for Dropbox sync again and see if that'll fix the problem.


    I hope that helps, please let me know!
  • I just wanted to say this helped with the problem I was dealing with this evening as well. Thanks for the clarity. It may be a nice thing to have as a possible sticky on this forum.


    Thanks,
    Geoff
  • khadkhad Social Choreographer

    Team Member
    Thanks for the update, Geoff! I'm glad things are working well for you now. We'll see how we can best make this information more prominent.

    Cheers,
  • Hi, I've deleted and reset and everything else your forums suggested and I can't get pass the point when the app see's the file in dropbox and just spins "Loading remote encrytion keys..." it's stuck there. Can someone please help me?
  • NikNik 1Password Alumni 1Password Alumni
    Sorry for the trouble. Could you please tell us:

    * Which iOS device you're using
    * Which version of iOS you're using
    * Whether you're running the latest version of 1Password (3.5.9)
    * Which version of 1Password you have configured to sync via Dropbox on your Mac or Windows PC
    * Whether you can see 1Password.agliekeychain when you log into your dropbox.com account

    Thanks very much for your help.
  • iPad 1 Version 4.3.5 (8L1)
    1Password 3.5.9
    Mac Lion 10.7.1
    I moved the Dropbox file on my mac so it's sandboxed for future compliance, 1Password file would not relocate to Dropbox unless I did that
    Yes I see the 1Password.agliekeychain on Dropbox.com inside the .ws.aglie.1password.settings file, 23 bytes
    I also tried it on my iPhone 4 version 4.2.10 (8E600) and had the same problem
    I have deleted and reset everything you can come up with, read all the forums
  • khadkhad Social Choreographer

    Team Member
    Yes I see the 1Password.agliekeychain on Dropbox.com inside the .ws.aglie.1password.settings file, 23 bytes

    Aside from seeing a text reference to 1Password.agilekeychain within that file, can you also confirm that your actual data file is showing up on Dropbox.com? It will look like a folder called "1Password.agilekeychain".
    20111002-t7umynwumqesfmuc3r5mejb91h.png
    Could you post a screenshot of your 1Password General preference pane? Here is mine for reference.
    20111002-q7rweej6q3ubimgttdw4thug2h.png
  • edited October 2011
    Is this what you wanted to see?[attachment=1413:screen1.jpg][attachment=1414:screen2.jpg]
  • khadkhad Social Choreographer

    Team Member
    edited October 2011
    That's great. Thanks!

    It looks like your data is not actually stored in your Dropbox folder according to the screenshot of the Dropbox web interface. Try clicking the "Stop Using Dropbox" button, wait for Dropbox to finish syncing, and then click the "Use Dropbox" button.

    Syncing will not work if you cannot see the 1Password.agilekeychain folder via the Dropbox website as shown in my screenshot above.

    Things to keep in mind: your Dropbox folder needs to be located at exactly /Users/yourusername/Dropbox without any symlinks or other redirects. Is there something unusual about your Dropbox installation or the location of your 1Password data?

    You obscured a crucial part of the second screenshot of 1Password's preferences. Is there a subfolder between your Home folder and the Dropbox folder, or is your username all that was obscured in the screenshot?

    Please let me know. I'm looking forward to resolving this for you.
  • I stopped storing in the Dropbox folder and then started it again, I also deleted the file on DropBox's website also. What is on Dropbox's website is the "pointer file".

    The part I obscured was my full name, it's stored at /Users/yourusername/Dropbox

    I made sure that Dropbox was sandboxed, 1Password would not use Dropbox until I changed the location.

    Should I be seeing two files on Dropbox's website?
  • khadkhad Social Choreographer

    Team Member
    Your 1Password data needs to be located in your Dropbox folder and visible from the Dropbox web interface (as shown in my screen shot above):
    20111002-t7umynwumqesfmuc3r5mejb91h.png
    The pointer is necessary but only a pointer. Your actual data needs to be there as well in the "1Password.agilekeychain" folder. (It is a bundle in OS X, so on your own machine it shows up as a single file rather than a folder. This is expected.)

    Please be sure Dropbox has finished syncing before checking for your data via its web interface.

    If your data is located in your Dropbox folder on your machine but not showing up via the web interface, there is some problem with Dropbox and its ability to sync. You may need to contact Dropbox for additional support on that, but I will certainly do my best to get you up and running again.

    What happens if you add a file via the web interface? Try uploading an image file or document via the web and see if it shows up on your machine in your Dropbox folder.
    20111007-bjwkcrf4w9a1skqi6ku3p1xh8h.png

    Are you sure you are logged in to the same Dropbox account on your computer and the web interface? It seems obvious, but that would obviously make all the difference. Just thought I would mention it.
  • I'm logged into the correct account.

    On the Dropbox website the second file is not there, I stopped using Dropbox, deleted the file on Dropbox's website. Relinked it to Dropbox and hit the upload like you suggested and only one file loaded and I got an error message from Dropbox's website. Of course they don't tell you what was wrong but the suggest using the "basic uploader" system. The problem is that it takes you deep in the 1Password folder and you're looking at each password file.

    I did look at the forums on Dropbox but not helpful other than what you posted there[attachment=1418:Screen Shot 2011-10-07 at 7.15.51 PM.png]
  • khadkhad Social Choreographer

    Team Member
    Terribly sorry for the confusion. Please try uploading an image or document of your own rather than anything to do with 1Password. I just want to make sure that if you add a file via the web interface it syncs properly to your machine and shows up in your Dropbox folder in Finder.

    For example:

    1. Open TextEdit
    2. Type some words.
    3. Save the file to your desktop
    4. Upload that file to Dropbox via the web interface
    5. Check to see if that file then shows up in your Dropbox folder on your computer
  • I did both with no problem, it was instant syncing of a text and photo file from the Dropbox website to my Finder Dropbox folder.
  • khadkhad Social Choreographer

    Team Member
    Okay. That is good! Now let's see if we can figure out why your 1Password data is not syncing to Dropbox.

    When you click the "Use Dropbox" button in 1Password's preferences, it sounds like the 1Password.agilekeychain file shows up properly in the root of your Dropbox folder. Is that the case?

    Once Dropbox indicates that it has completed syncing, is it showing up via the web interface? As I mentioned above, it will show up as a folder called 1Password.agilekeychain in the web interface.
  • Here is my Finder Dropbox snapshot
    [attachment=1420:Screen Shot 2011-10-08 at 10.01.52 AM.png]

    Here is my Dropbox web interface
    [attachment=1421:Screen Shot 2011-10-08 at 10.04.20 AM.png]
  • NikNik 1Password Alumni 1Password Alumni
    edited October 2011
    Thanks for the screenshots! The "minus" overlay on 1Password.agilekeychain is a huge red flag. This is what I found out about it on Dropbox's web site:

    Conflicted Folders
    Folders that are deselected in Selective Sync preferences will be removed from the Dropbox folder on your hard drive. However, if a folder is created with the same name in the same place as the unsynced folder, the new folder will appear with a gray circle and a minus sign overlay. This icon indicates the folder is not being synced to your Dropbox. If you resume syncing your old folder of the same name through Selective Sync preferences, the new folder and its contents will appear alongside the old folder as a conflicted copy.



    Can you please go to Dropbox Preferences on your Mac and check the Advanced > Selective Sync settings? It sounds like maybe 1Password.agilekeychain sync is disabled and that's why it's not getting synced back to Dropbox from your Mac.
  • Here is what I see in the selective sync preference in Dropbox.
    [attachment=1422:Screen Shot 2011-10-08 at 1.11.47 PM.png]

    The very first time I got the Dropbox file moved to be sandboxed and was able to move the 1Password file to Dropbox there was that negative sign on the 1Password file.
  • ok, here we go:

    I fooled around with the Finder Dropbox file, right clicking on the 1Password file I selected to share the file which took me to Dropbox's website.

    I declined to share it with anyone, the page had an option to restore 1Password and I now have all the right files but now I have a conflict, I would like to delete one of the conflicts but I don't know what's the good file?

    [attachment=1423:Screen Shot 2011-10-08 at 1.27.33 PM.png]
  • I can't send you anymore screenshots, I hit the quota
  • I deleted the file that was marked conflict.

    Then I opened the app for the iPad and it worked.

    The trick is to restore the file on DropBox's website

    Hope this helps someone
  • khadkhad Social Choreographer

    Team Member
    It sounds like you had previously indicated that you did not want to sync 1Password.agilekeychain in Dropbox's preferences, so Dropbox remembered that when you tried to set it up this time. It's simple to do — just uncheck the box for selective syncing — but I have never seen anyone do that before. I'm glad you got everything working well, though! :-)

    Best regards,
This discussion has been closed.