Keyboard does not work when creating new logins and crashes [resolved with 7.4.2 on iOS 13.1.2]

loscarwebloscarweb
edited October 2019 in iOS

View 1Password Approved Answer

it is September 20th i have iPhone X with ios 13 and 1password 7.4. when i open one-password and use the keyboard to ssearch for a login it works. if i try to create a new login when the window appears to start typing the name of the new login , I cannot use the keyboard and 1password crashes every single time, i reboot the phone same thing happened.


1Password Version: 7.4
Extension Version: Not Provided
OS Version: ios13
Sync Type: Not Provided
Referrer: forum-search:ios13

«134

Comments

  • Same here. I have iOS 13.0 and 1Password version 7.4. Exact same problem as above. Can't create any new logins due to it crashing once the keyboard shows up (oh the irony, I couldn't create a 1Password login for this support forum because of the app crashes). I've also tried rebooting as well as uninstalling/reinstalling fresh from the app store.

    Only difference is I have the iPhone 11 Pro. It worked fine on my previous iPhone with iOS 12.x.

  • Same. Freezes/crashes when try to add new item.

  • brentybrenty

    Team Member
    edited September 2019

    @loscarweb, @trh98, @rl7007: Thanks for getting in touch. I'm sorry for the trouble. Can you tell me the exact steps you're taking? I'm not seeing that here, but maybe I'm doing something different. Also, what keyboard are you using? There have been other reports of keyboard issues with iOS 13, so I wonder if that may be related. What vault type and sync method are you using?

  • Hi brenty!

    I’m using the default iPhone keyboard (English QWERTY) and I also have the emoji keyboard turned on. I don’t have any third party keyboards installed. I’m not sure the answer to the vault type question. I just have a personal vault that I am trying to add a new login to. Also, where would I find the sync method? I don’t see anything about a sync method in any of the iOS 1Password app settings.

    The exact steps for me are as follows:

    1) iPhone XS Max with iOS 12.x with a working 1Password app.
    2) Performed an iCloud backup of said iPhone.
    3) Activated new iPhone 11 Pro.
    4) Restored iCloud backup to new phone.
    5) 1Password app automatically installs along with all other apps.
    6) Log in to it with my master password successfully.
    7) Click on Logins, then click the ‘+’ on the top right.
    8) New login screen appears and keyboard automatically pops up from the bottom to begin typing.
    9) At this point, nothing else happens and nothing on the screen responds to any touches. No flashing cursor at the new login name, nothing. The only thing on the entire screen that works is dragging up from the bottom (which is the iPhone home button more or less).
    10) After about 15-20 seconds of this freeze, the 1Password app crashes/closes back to the iPhone home screen.

    I tried uninstalling/reinstalling the app as well as a couple of reboots of the iPhone. If I can help further, let me know.

  • Same here, with iPhone X, iOS 13, 1Password 7.4.1.

    Trying to create a login: +, personal vault, and the screen will appear as if you can add a new login, but it stops there and freezes, then crashes.

  • playskoolplayskool
    edited September 2019

    Trying to create a login in personal vault and app freezes, then crashes.

    Process: +, personal vault, and the screen will appear as if you can add a new login, but it stops there and freezes, then crashes.

    Most other functions work, besides login creation


    1Password Version: 7.4
    _Extension Version: 1
    _OS Version: iOS 13
    _Sync Type:
    Not Provided

  • ag_anaag_ana

    Team Member

    Hi @playskool!

    We will be happy to help you with this. I noticed that you also sent us an email about this issue. So we don't duplicate the answers, we will get back to you over there as soon as possible.

    Thank you for your patience!

    ref: NFD-45175-165

  • Same here. Updated to the latest version of 1Password, on iOS 13.1 public beta. Unable to create new logins / keyboard freezes

  • Having same issue. I’m on the latest version 7.4.1 running on iOS 13 on a new iPhone 11 Pro Max

  • Just came to report the same issue. 1Password 7.4 with iPhone Pro 11 and iOS 13.0.

    I am not seeing the same issue with my iPad and iOS 13.1 beta.

  • hi I tried again with 7.4.1 and iOS 13 and still the same problem

    1) lunch 1password
    2) Face ID and app opens
    3) click search and type for a login , no problem it works
    4)click + to add an item
    5) select login and try to add "login name" it DOES NOT WORK I cannot type anything an app shutdown after a few second
    6) note if instead of a new login a try to create a new note , it works

    please help

  • I just upgraded to an iPhone 11 pro max. Now I can’t get into my 1Password app.

  • I am seeing a freeze whenever I try to create a new login after the last update on iOS 13 Beta 4. I have an iPhone XS Max.

  • For 1Password for iOS 7.4.1, I have the exact same issues as everyone else!!
    I even tried 1Password via the share sheet in Safari for iOS (13), but I still cannot save or create a new password this way. Crashes!!

  • I am seeing the exact same behavior as @playskool on iOS13.0, 1P 7.4.1, on an iPhone 8 Plus.

  • 1password on IOS13 is unable to create a new login. It locks up and then crashes. I have uninstalled 1password and reinstalled it and I get the same thing. Any ideas?

  • mobilemindmobilemind Junior Member

    +1 same thing here. iOS 13.0, 1Password 7.4.1

  • mobilemindmobilemind Junior Member

    +1 same thing here. iOS 13.0, 1Password 7.4.1

  • brentybrenty

    Team Member
    edited December 2019

    Thanks everyone for chiming in, and a big thanks to @trh98 for the detail! I'm really sorry for the hassle. We're investigating some reports like this, and appreciate the info. There are a few things that might help us determine what's going on:

    1. Did you experience this (a) only after updating to iOS 13 on an existing device, (b) on a new device after restoring from a it from a backup, (c) a new device setup from scratch, or (d) [something I haven't thought of]?
    2. Can you create any other types of items (i.e. non-Login) successfully?
    3. If you select + New Login but do nothing else does 1Password still crash for you?
    4. If you create a new Login item on another device or computer in your Dropbox vault does it sync to your iOS device?
    5. Is anyone experiencing this on an iPad, not just an iPhone?
    6. Did you submit a crash report the next time you opened 1Password?
    7. Will you send us a diagnostics report and post the Support ID you receive here?

    https://support.1password.com/diagnostics/

    Please send it to [email protected] and include your forum username and a link to this discussion so we can connect the dots:

    https://discussions.agilebits.com/discussion/107201/ios-13-keyboard-does-not-work-when-creating-new-logins-and-crashes#p1

    We'll figure out what the problem is and find a solution for you folks! :+1:

    ref: dev/apple/issues#4226

  • It’s not happening on my iPads. Only the iPhone.

  • brentybrenty

    Team Member

    @RobTX: Thanks for confirming! I haven't yet seen any reports of this happening on iPadOS, but I figured I should ask. If anyone is, I suspect they will let us know here. If it's really just one and not the other, that difference may help ferret out the cause. :+1:

  • brenty, I'll try to answer all of your questions:
    1) I never had iOS 13 until I received my new iPhone 11 Pro 5.8". My previous phone was the iPhone XS Max with iOS 12.x and it had no problems whatsoever. I only discovered this problem when I activated and began to use my iPhone 11 Pro 5.8" that came with iOS 13.0 preinstalled.
    2) All other types seem to create just fine. I can create a credit card, a wifi password, etc. and 1Password does not crash. I've noticed that the keyboard doesn't automatically pop up when I choose one of the other types. The keyboard only automatically pops up when I choose "Login" as the type. Maybe that is significant.
    3) Even if I do nothing else but choose "Login" after pressing the "+", 1Password still crashes. I have pressed "Login" as the type and not touched the screen at all after that, still the app crashes.
    4) I don't use Dropbox for my syncing, I just use the built-in 1Password syncing. However, if I create a login using the Windows 10 app, it does sync successfully to the 1Password iOS app. I'm then able to copy the password from iOS and use it. That's actually what I've been doing the past couple of days. Creating my new logins using the Windows 10 app since the iOS app isn't functional.
    5) I have the iPad 2018 model (standard cheapo model, not a Pro) and it has iOS 13. It does not have the same problem. I am able to create a "Login" type with no problems whatsoever. And that does sync to my iPhone app successfully.
    6) I never received a message asking me to send a crash report. I'm not sure if that is supposed to show up automatically but it never has.
    7) I went to the diagnostics section of the iOS app and sent the diagnostics report. I changed the email address to what you specified along with all of the information and links you specified as well.

    I appreciate the help!

  • brentybrenty

    Team Member
    edited September 2019

    @trh98: Likewise, thanks for your answers, and the diagnostics! We'll take a look at all of this and compare to see what we can learn. When 1Password crashes, you should be asked to send a crash report the next time you open it. So I wonder if that along with some reports that this isn't happening on iOS 13.1 (though I have seen at least one to the contrary above too) and the association with the keyboard coming up might indicate something going on in iOS itself.

    In the interest of finding a workaround for you while we're looking into this, while I'm glad that at least you're able to create a Login on another device, I wonder if you're able to create on on the iPhone some other way -- for example, by bringing up 1Password from iOS Password Autofill or the 1Password extension on a website to save a Login there, rather than creating one by hand in the app. I suspect you'll encounter the same issue, but it's worth a try at least.

    ref: SUG-75185-759

  • Auto fill is what surfaced the issue for me. I needed to create a new login and the app seized. For me it is not “crashing.” It is freezing and I have to force close.

  • The same here. iOS 13. Can’t crate new logins but the funny thing is I can create other entries like secure notes and identities

    Phone iPhone X.
    iOS 13.0
    1Password family version 7.4.1

  • Here is my reports

    1) iPhone 11pro with iOS 13.0. Never experienced this issue with my previous phone. (FYI, the iP11Pro was setup from an existing iPhone X with 13.0 using the new transfer settings feature.)

    2) DOn't seem to have any issue with other categories.

    3) Yes, as soon as I try and create a new login, 1password hangs for about 10-20 seconds and then crashed. During that time I can't do anything.

    4) Yes, I get new items created on other devices just fine. (Note: you mention Dropbox, but I use 1Password vaults)

    5) Created a new login on iPad without issue.

    6) I do not get a prompt to file a crash report when opening

    7) Diagnostic sent with user name and link to thread.

  • Confirmed. Only the Login add freezes. Basically all input is ignored from the screen and you can’t bring up the keyboard.

  • Same issue as above. iPhone XSmax, iOS 13.0, 1Password 7.4.1 Keyboard freezes and then app crashes. No diagnostics report on restart.

  • scott_m29scott_m29 Junior Member
    edited September 2019

    Same problem. iPhone XS, iOS 13.1 (beta), 1Password 7.4.1

    When I create a new Login, 1Password freezes. No keyboard response, cannot Cancel. Have to force quit; I’m not seeing a crash.

    I can create a new Note, new Software License. Cannot create a new Login.
    Restarted 1Password. Restarted iPhone. Same problem.

  • scott_m29scott_m29 Junior Member

    Still the same problem. iPhone XS, iOS 13.1 (beta), 1Password 7.4.1

    Also - I can sync with the Mac OS version and create new accounts there. The sync transfers the new accounts okay.
    But the iOS version of 1Password is hosed up on the New Login page.

This discussion has been closed.