1Password7 not working on Catalina

I just installed Catalina and find that I cannot open 1Password 7 on my MacBook Pro. 1Password remains accessible on my iOS devices.Please help.

1Password Version: 7.3.2
Extension Version: Not Provided
OS Version: OS X 10.15
Sync Type: iCloud
Referrer: forum-search:1Password7 not working on Catalina


  • arisg1arisg1
    edited October 2019

    I have the same issue. The first time I opened 1P it crashed. The second time it opened but there are no entries in the vault although it synchronised with iCloud.

  • I have the same issue. Please fix it.

  • habhab
    edited October 2019

    NVM (can't delete a comment so leaving this edited comment instead)

  • I reinstalled 1Password yesterday and it worked. Today, on startup of my computer, 1Password doesn't open (it crashes after I try to enter my master password).

  • LarsLars Junior Member

    Team Member

    @bruceoconnor - I'm sorry for the trouble! I'm glad to hear you're still able to access your 1Password data in your iOS devices.

    I'm also curious to know what might be causing this, since our development team has been working with the betas of macOS 10.15 ("Catalina") for months now without noticing any such behavior -- and although there are a few people in this thread reporting what seem to them to be similar issues, we're not being deluged with reports of 1Password 7 being non-functional in Catalina, which would certainly be the case if we'd missed a blocker that didn't allow 1Password to run under Catalina.

    Did you happen to send us a copy of the crash report? I'd like to see it, along with a diagnostics report from your Mac:

    How to send a diagnostics report from your Mac

    Please add the following code (including the square brackets) to the Subject line of your diagnostics email before sending it:


    This will link your diagnostics to our current discussion. I'll take a look and let you know what I find out.

    For anyone else reading, please note: this ID is for @bruceoconnor only. If you’re experiencing the same issue and need help, please ask us for your own ID.

    ref: RRY-47528-383

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @arisg1! I'm sorry for the trouble. Can you tell us a little more about your setup? What version of 1Password are you running, specifically (you can check in 1Password > About), and what version of macOS? Do you have only the single iCloud-synced Primary vault, or are there other vaults, and if so, are you able to view them? Do you have 1Password installed on any other devices, and if so, are you able to open/view your data there?

  • What I have found out is that if I leave 1Password out of my startup items for myself as a user (in which MacOS automatically starts the program upon boot), and then manually start the program from applications after boot is complete, the program opens and works fine. I shut down my computer every night, so this is a little hassle but not that bad.

  • brentybrenty

    Team Member

    @bruceoconnor: 1Password should not be set manually as a startup item. macOS launch services should be running it on login. I'd check to make sure that you have 1Password Preferences > Browser > Always keep 1Password Helper running enabled, and try toggling it to see if that will force macOS to re-register it. Unless there's a serious permissions issue, that should do the trick.

  • Hi Lars and thank you for taking an interest in this problem. I am running 1P version 7.3.2 and macOS 10.15 release version. I have 1P installed on my iPhone as well with iOS 13.1.2 and it works fine. Upon re-installation of macOS and 1P on my iMac everything works well. I have also installed macOS 10.15 and 1P on my 2017 Macbook Pro and works fine. It must have been a momentary glitch which hasn't re-appeared.

  • ag_anaag_ana

    Team Member

    On behalf of Lars, you are welcome! If you have any other questions, please feel free to reach out anytime.

    Have a wonderful day :)

  • I checked 1Password preferences and found that the settings suggested by Brent had been correct. When I again added 1Password to my startup items, and rebooted my computer from power-off, 1Password correctly loaded and functioned. The same thing happened this morning. As arisg1 said, this was a momentary glitch (hopefully).

  • BenBen AWS Team

    Team Member

    Thanks for the update @bruceoconnor. If we can be of further assistance, please don't hesitate to contact us.


  • I was having a similar issue, where 1Password would bring up the browser or open a new tab when I selected an item, but not go to the URL. I followed Bruce's suggestion to : ' ... have 1Password Preferences > Browser > Always keep 1Password Helper running enabled, and try toggling it to see if that will force macOS to re-register it.' This worked and was very easy! Thanks, Bruce!

  • LarsLars Junior Member

    Team Member

    Welcome to the forum, @clm3k3k3k! Glad to hear that worked for you as well. Let us know if you need anything else.

  • I am also unable to use 1Password since I upgraded to Catalina. I currently have an open ticket with 1 Password but have not been hearing further from the person helping me. I was persuaded to set up an account, but so far it has made no difference. The program opens on my MacBook, but does not recognize my Master Password. It does seem to be working on my IOS devices. I also need to update the new program on my Mac Tower. I have followed this and other threads on this topic on this forum, but so far - it just isn't working.

  • BenBen AWS Team

    Team Member


    I'm sorry you're having trouble. So as to avoid duplicating efforts please try to avoid contacting us in multiple threads about the same issue. We'll be happy to help, and someone from our email team will be back with you as soon as is possible.



This discussion has been closed.