Blank page in Firefox on Ubuntu 18.04

I do have the problem that 1Password X always shows a blank page in Firefox, while I have configured Firefox to remember history. Firefox is currently on 69.0.

The web console shows the following error:

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Ubuntu 18.04.3
Sync Type: Not Provided


  • kaitlynkaitlyn

    Team Member

    @ddewit – You’re absolutely right! We’ve noticed the same thing. I’d be happy to clarify what exactly is happening here and how to avoid it. While in private browsing mode, Firefox prevents extensions from accessing the local database, which 1Password X relies on in order to function properly. Unfortunately, this currently results in a blank page when trying to open the extension. So far, we’ve seen this behavior when either of the following preferences are set in Firefox:

    • Never remember history
    • Always use private browsing mode

    Disabling either of those preferences should allow 1Password X to function as expected, but it seems that you’ve already figured that out. If you have any other questions, don't hesitate to ask!

  • Hi @kaitlyn, like I tried to say, I don't have those settings enabled. I'm also not in a private browsing session when this error occurs. And, since you're asking for cases where this does occur, despite not being in private mode, I created this topic.

  • kaitlynkaitlyn

    Team Member

    I'm so sorry, @ddewit! It seems my brain added an unnecessary word in when I read your original post. Please forgive me. :)

    What are your current privacy settings in Firefox? I'd like to try and replicate it the best I can to see if I'm able to reproduce the same error. I'd also like you to grab your 1Password X logs (rather than from the web console) just to see if there's a more specific error going on there. We've got a guide that explains how to gather those here. Please post them here, or if you'd prefer, I'd be happy to move over to email where things are more private than a public forum. Let me know!

  • No problem @kaitlyn. I'm currently out of the office for a couple of days, I'll try to gather the information soon, but it could be that I only get to it after the weekend. As for sharing logs, I'd rather do that via email, indeed.

  • kaitlynkaitlyn

    Team Member

    @ddewit – Sounds good. I'm in no rush, but I'll be here whenever you're ready to help get this resolved for you. If it has to wait until Monday, then that's absolutely fine. As for your logs, you can send them to [email protected] and include a link to this forum post in the body of the email so we know they're related. Thank you! ❤️

  • EricSEricS Junior Member
    edited September 2019

    I am having the same issue as @ddewit - blank tab when clicking the 1PasswordX button, no private browsing, history enabled normally. My other privacy settings are:

    • Content Blocking: Standard
    • Do Not Track: Only when Firefox is set to block known trackers
    • Ask to save logins and passwords: on
    • Use a master password: off
    • Autofill addresses: on
    • Autofill credit cards: on
    • Remember History
    • Block pop-up windows: on
    • Warn you when web sites try to install add-ons: on
    • Prevent accessibility services from accessing your browser: off
    • Block dangerous and deceptive content: on
    • Block dangerous downloads: on
    • Warn you about unwanted and uncommon software: on

    Let me know if there are other settings to grab!

  • Hi @kaitlyn My privacy settings are the same as @EricS.

    The log does not contain any private info as far as I can see, so here it is:

    Webconsole context has changed
    Initializing 1Password X... background.js:31:592778
    1Password X has been updated to 1.16.2! 🤟 background.js:31:594065
    (destructured parameter) is undefined background.js:31
        QU moz-extension://f54df525-332a-4b34-a748-bd5e3b88d89e/background/background.js:31
        apply self-hosted:4485
        applySafeWithoutClone resource://gre/modules/ExtensionCommon.jsm:588
        wrapPromise resource://gre/modules/ExtensionCommon.jsm:817
        withLastError resource://gre/modules/ExtensionCommon.jsm:736
        wrapPromise resource://gre/modules/ExtensionCommon.jsm:805
    Unchecked lastError value: Error: Could not establish connection. Receiving end does not exist. background.js:31
        QU moz-extension://f54df525-332a-4b34-a748-bd5e3b88d89e/background/background.js:31
    UnknownError: The operation failed for reasons unrelated to the database itself and not covered by any other error code.
    Loaded active tab (includeDesignations=false) 59 ms. popup-v2.js:7:108483
    TypeError: uY is null background.js:31:554568
  • kaitlynkaitlyn

    Team Member

    Thank you for the additional information, @EricS and @ddewit! I'll pass this along to my team and update you once I hear back from them.

  • kaitlynkaitlyn

    Team Member

    @EricS – I do have one question for you. Are you using Ubuntu 18.04 as well? If not, what operating system are you on?

  • EricSEricS Junior Member

    @kaitlyn Almost - I'm on Linux Mint 19.1, which is based on Ubuntu 18.04.

  • kaitlynkaitlyn

    Team Member

    Perfect – thanks @EricS.

    The TypeError: uY is null errors that we've seen in the past have indicated that the database isn't available, like when in private browsing mode. We're extra curious about this one since that doesn't seem to be the case. I'm wondering if either you or @ddewit have made any chances to the Firefox config at about:config. If there have been, we'll want to know which settings have been modified and see if that points us in the right direction.

  • @kaitlyn I sent the changes in about:config through e-mail. Afaik this are only housekeeping things that are changed by Firefox itself, no settings that I changed.

  • kaitlynkaitlyn

    Team Member
    edited September 2019

    @ddewit – Thanks so much! I'll update my team with that info and let you know what we come up with.

    In the meantime, if you're comfortable with performing a refresh in Firefox, we've had luck with that fixing similar issues in the past. Be sure to take a look at which data will be removed just to make sure it's something you want to do. You can find that info here:

    Let me know if you end up doing the refresh. If not, we'll continue to look into it!

    ref: xplatform/xplatform#98

  • @kaitlyn - Thanks, the addon works just fine in a new profile. However, I'll keep the old profile in case you need any more information or logs from it.

  • kaitlynkaitlyn

    Team Member
    edited September 2019

    @ddewit – That's great to hear. Do you have any other extensions aside from 1Password X installed in the profile that's causing trouble?

  • @kaitlyn - There is only one other addon in that profile:, I disabled it (and restarted FF), but that didn't help.

  • brentybrenty

    Team Member

    Thanks for checking. It is not uncommon for Firefox profiles to become damaged, and exhibit some strange issues as a result. I'm glad that creating a new one helped! :)

  • ddewitddewit
    edited October 2019

    @brenty I just rebooted my machine, and now the problem is back on the new profile. If you have some debug version of the addon that I can run to help you get to the bottom of this issue, then I'm willing to run that.

    -- edit:
    Apparently my shortcut was wrong, I started the wrong profile. The new profile is still working just fine.

  • kaitlynkaitlyn

    Team Member

    @ddewit – Thanks for editing your comment to update us. That's great the new profile is working well for you. We'll be here if anything else comes up!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file