Disable 1Password in Asana's fields

Hello,
I use frequently Asana as a project manager, and when I create a task the field Asignee is getting username of 1Password and it makes a window when it souldn't be.

How can i solve it? or do you make something in 1Password to solve it?


1Password Version: 7
Extension Version: Not Provided
OS Version: Mac
Sync Type: 1Password

«1

Comments

  • ag_sebastianag_sebastian 1Password Alumni
    edited March 2019

    @davidperezgar: Thanks for your report, and sorry for the hassle. This is a known issue that'll be fixed in the next 1Password X update. Unfortunately there's no easy workaround for this issue except for disabling the extension when using Asana. If you're on Chrome and in a hurry, you can install the 1Password X beta which should already have the fix in place.

    ref: xplatform/brain#68

  • @ag_sebastian Is there a beta for Firefox? I'm having this issue and use Asana a lot.

  • Hello @wjdp,

    Sorry, we don't have a beta available for Firefox. Hopefully it won't be too long before 1.15 is ready for stable release and you can take advantage of the fix.

  • What is the status of this issue? I'm having the same problem. It is super annoying. I cannot assign tasks to team members because 1 password blocks half of my team's names.

  • BenBen AWS Team

    Team Member
  • carstenlangecarstenlange Junior Member

    Hey 1password,

    any update on this? It's June and even with the latest 1Password X update, this issue isn't fixed. And it's really annoying one :(

    Best, Carsten

  • kaitlynkaitlyn

    Team Member

    Hey there @carstenlange! The issue should be completely resolved at this point. I just tested it out with my own Asana account in the stable build of 1Password X (1.15.2), and I'm not seeing the 1Password icon in the assignee field any longer.

    Are you seeing something different?

  • carstenlangecarstenlange Junior Member

    Hey Kaytlin,

    Thanks for getting back to me, and indeed everything looks great again.

    Best, Carsten

  • kaitlynkaitlyn

    Team Member

    That's great to hear, @carstenlange! Thanks for sharing the good news with me. :)

  • I have the same issue at some other sites. Could you add a button to exclude some fields specifically?

  • kaitlynkaitlyn

    Team Member

    @dospolov – It's something we're interested in, and we'd love to offer in the future. Stay tuned for future updates. :)

    ref: dev/core/core#227

  • kaitlynkaitlyn

    Team Member
    edited October 2019

    @dospolov – I've actually got some really good news for you. We recently added the ability to disable the 1Password X inline menu on specific websites in the current 1Password X beta. If you're willing to test it, let me know what browser you use and I'll give you the link. ❤️

  • Yes! Chrome

  • kaitlynkaitlyn

    Team Member

    @dospolov – Sweet! You can download the 1Password X beta in Chrome here.

    Here's the button you'll click to disable the inline menu on the current page:

    Keep in mind, that will reset if you quit your browser. We're still working on a way to save sites you've previously disabled safely and efficiently, but we were excited to get this feature out the door. :)

  • @kaitlyn if it doesn't store this field - that doesn't work for me.
    I've solved it with a custom js snippet that I wrote. So will wait for a version with storage

  • kaitlynkaitlyn

    Team Member

    Sounds good, @dospolov! Thanks for the feedback.

  • Hello @kaitlyn ! I'm afraid tha the 1password button is merged with clear button, and I cannot use it...

  • kaitlynkaitlyn

    Team Member
    edited November 2019

    Hi @davidperezgar! I just responded to you in this thread, but you're absolutely right. I just tested it out on Asana's site, and the issue we previously fixed has made its way back. This time, we don't have the ability to close 1Password X's inline menu since that also closes the Asana dropdown menu. I did notice that they made some changes to their site, so we may just need to re-fix things on our end. Our developers will need to investigate before jumping to any conclusions. In the meantime, the Hide on this page option I mentioned earlier in this thread should help you out. It's only available in the 1Password X beta, though, so let me know (on either thread) which browser you use and I'll send you the link to download it.

  • It seems that it solved in beta version! Thanks!

  • kaitlynkaitlyn

    Team Member
    edited November 2019

    Glad to hear that, @davidperezgar! I'll be here if anything else comes up.

  • I installed the latest Chrome extension beta as recommended by this thread, and can now click the 1P icon to make the dropdown go away. However, I'm not seeing the "Hide on this page" prompt as in the screenshot above. macOS 10.14.6 with Version 79.0.309.71.

    Disabling for a field should definitely be included as it's annoying when 1P gets in the way. In my case it's for people name field in Atlassian Confluence, which is not a login field, but a field of who's basically watching the wiki page for updates.

  • ag_anaag_ana

    Team Member

    @apasternak:

    What exact version of 1Password X are you currently running in Chrome?

  • edited January 31

    @ag_ana, I just installed it, so it's the version in the store now: 1.17.0.
    https://chrome.google.com/webstore/detail/1password-x-–-password-ma/aeblfdkhhhdcdjpifhhbdiojplfjncoa

    Since I have the "integrate with desktop" option on, the version of that may be relevant as well? It's Version 7.4.2.BETA-3 (70402003).

    Update: here's the relevant screen, btw. For me, the icon now toggles either showing the list of 1P suggestions or not (no menu). Right-clicking on the 1P icon just displays the standard browser right-click page menu.

  • kaitlynkaitlyn

    Team Member

    @apasternak – While hiding the inline menu temporarily will likely work for you (until the next time you quit your browser), I'd like to make sure this issue gets reported to our developers so we can do our best to tackle the root cause. You mentioned Atlassian previously. Could you let me know which specific page you're on where the 1Password icon appears in unnecessary fields?

    For the hide on this page feature, try clicking the 1Password icon in your screenshot to invoke the inline menu, then click Suggestions. Do you see the Hide on this page option there?

  • edited February 1

    @kaitlyn, you're right that clicking on Suggestions made the entire menu appear. This was not clear to me, that the menu in the screenshot above wasn't the one the user got immediately when clicking on the icon.

    Hide on this page did turn off the 1P icon, which is great, but it's also not clear whether it's an exact match for a URL or not. However, the 1P prompt did appear again if I tried to log off and back on. So for now the beta solved my issue.

    You asked about the specific page. Confluence is Atlassian's wiki-type product, so this Watch dialog can be invoked on literally any page, with the format of:
    https://<my work wiki>/pages/viewpage.action?pageId=<12345>

  • kaitlynkaitlyn

    Team Member

    @apasternak – Thanks for the additional info. I appreciate it!

    The "Hide on this page" feature should stick for the length of your browser session, but ever-changing URLs are when things get tricky. There are a few sites where I've found the URL change so frequently that the feature becomes pointless.

    I want to make sure I'm understanding everything correctly since you came into this thread a few months after my last comment (and I'm very glad you did!). You mentioned you installed the 1Password X beta and that solved your issue. Back when I posted this comment indicating that you'd need to install the beta to get the "Hide on this page" feature. However, that feature has since made it to the stable version of 1Password X, so you shouldn't need to install the beta. Did the beta solve your issue in another way?

  • @kaitlyn, my previous version was 1.17.0. I disabled that when I installed the beta, currently at 1.18.6. The solution (or at least workaround) in my case wasn't the "Hide on this page", but just being able to click the 1P icon to get its suggestions to go away, which didn't work for me before.

    You're right that in my case the URL is a changing one with IDs, so if the "hide" is only per-session and per-exact URL, that is somewhat limiting. However in my case I don't access this field all that often (it's a list of people who get notifications for the wiki page changes, just for context), so it's OK. Long-term as I suggested, a more permanent fix would be to add ignored fields by ID. So in this Confluence case, 1P could be smart enough to never show suggestions again on this domain for "add-page-watcher-user" fields like this one:

    <input id="add-page-watcher-user" name="userFullName" class="text autocomplete-user" type="text" value="" placeholder="Full name or username" data-max="10" data-target="#add-page-watcher-username" data-dropdown-target="#add-page-watcher-dropdown" data-template="{title}" data-none-message="No matching users found." data-autocomplete-user-or-group-bound="true" autocomplete="off" tabindex="1" data-last-search="blah">

  • kaitlynkaitlyn

    Team Member

    @apasternak – Right. I was just mentioning that the "Hide on this page" feature is available in version 1.17.0 as well, so I wanted to clarify what the beta fixed.

    We're always looking for ways to improve that feature, so I really appreciate your suggestion. Making it stick over time rather than just for one browser session, for example, is something we're currently exploring. We can get much more granular than we already are, but I tend to focus on how we can fix the issue of 1Password appearing in the field in the first place rather than focusing on ways we can cover it up. I asked about the specific page where you run into the issue so I could test it out on my end and get it reported to our developers. I was able to create an Atlassian trial account, but I haven't found the field you're referring to quite yet. I'll still attempt to mess around with it, but the steps that you take to access that page and/or field would be extremely helpful. If I'm still not able to access it, I'm happy to pass the still report along since you provided the HTML for us.

  • @kaitlyn, I'm really glad you're taking the extra steps to try to recreate the issue, that's amazing! If you have a Confluence trial, be sure to you're an admin for whatever space you want to add pages to. Bottom left to get to Content Tools / Space options.
    https://confluence.atlassian.com/conf59/administer-a-space-792498663.html

    Then create a page. Big Create button at the top, then save it.
    https://www.atlassian.com/collaboration/confluence-create-content-with-pages

    Then manage watchers for the page, in the top right.
    https://confluence.atlassian.com/doc/manage-watchers-218271870.html

    Let me know if there's a support email you'd like me to reach out to help further.

  • kaitlynkaitlyn

    Team Member

    Thank you so much, @apasternak! That's exactly what I needed. I honestly wasn't sure where to start, but you helped a ton.

    I've got a test page set up, and I believe I found the Manage Watchers option you mentioned. Does this look right?

    I don't see the 1Password icon, but perhaps it's because I don't have anyone else on my Confluence account. I figured I'd check with you to make sure I'm in the right place before digging too much deeper.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file