Extension won't start in Edge

Running the latest version of all software:
Windows 10 - Version 10.0.17134 Build 17134
Microsoft Edge - 42.17134.1.0
Microsoft EdgeHTML 17.17134
1Password: 7.2.581

When in the browser and I click the icon, nothing happens. Sometimes, if I click it several times, it will come up. Sometimes it comes up on the first click. The behaviour is not consistent, but often I have to launch 1Password it self and manually copy/paste what I need.


1Password Version: 7.2.581
Extension Version: Not Provided
OS Version: Windows 10 - Version 10.0.17134 Build 17134
Sync Type: Cloud
Referrer: forum-search:won't start in edge

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @cmoczarski,

    Thanks for reporting this. I'm sorry you're having an issue trying to get 1Password to work in Edge.

    Let's try this first:

    1. Reboot your computer and then open 1Password first, unlock and wait about 30 seconds.
    2. Open Edge, click on 1Password, any response?

    Do you have a 32-bit Windows 10 build or 64-bit? If you're not sure, go to Start menu > Settings > System > About, it should be next to the Device spec.

  • edited October 2018

    Hi Mike - thank you for the response. I am running 64-bit OS with x64-based processor

    I have tried the reboot process and the impact isn't consistent … sometimes it works without issue, other times it won't come up at all. In those cases, I typically start the 1Password app (which by the way doesn't always come up the first click either) and manually copy/paste my credentials.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @cmoczarski,

    There are a few known issues with Edge extension:

    1. You cannot close and open Edge right away, if you do, it'll break the extension. You must wait 30 seconds between closing/opening Edge. If you did do this, you have to use Task Manager to terminate all 1Password.Edge.* processes and then restart Edge for it to work again.
    2. Sleeping the device while Edge with 1Password is running will break the extension. Windows at this point does not allow resuming suspended extension processes for some odd reasons. We also cannot opt out of the suspension either, we want the processes to be terminated but Windows switched to suspension after the Creators update, which is when we started to see a lot of problems. We've tried a few times to force the termination but it didn't work.

    In those cases, I typically start the 1Password app (which by the way doesn't always come up the first click either)

    Was 1Password running unlocked when you open 1Password in this case or did it appear locked like it started for the first time?

  • Mike - thank you. I think the majority of my issues are stemming from what you describe in #2. Regarding your last question - no. Typically I don't run the 1Password app on the desktop unless I need something in my secure notes.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @cmoczarski,

    1Password extension in Edge requires the 1Password app to be running. If it is not running, it won't work. However, by default, 1Password minimize to your notification tray area, so it may be running already when you try to start 1Password.

    Next time you see this issue, please check the notification tray area (usually bottom right of your screen, you may need to reveal all icons to see 1Password) to see if it is already running. If not, it could mean 1Password crashed and that's why the extension can't run.

  • Hi there - resurfacing this question as it seems like the problem is getting worse in Edge than better. MikeT - I did double check and the 1Password icon is running in the notification tray, yet it refuses to work in the browser. i'm thinking a better question than getting this app to work consistently in Edge is … are there any plans to bring the extension to the new Chromium browser? I know it's still in Dev from Microsoft, so I don't expect it any time soon, but hoping there's a plan in place? :) Thanks

  • GregGreg

    Team Member

    @cmoczarski: Indeed, we are working with Microsoft to make our companion extension available for the new version of Microsoft Edge, but I do not have anything else to share at this point.

    Right now, if you have a 1Password account, you can try to install 1Password X in the new Edge beta.

    As a possible workaround for the current version of Edge, you can close Edge, open Task manager and end the Edge background process. Then restart Edge and check if 1Password extension works.

    Let us know what you find. Thank you! :+1:

    ++
    Greg

  • I installed immediately and have been using since without issues! I love the new interface as well. Thanks Greg for the update.

  • brentybrenty

    Team Member

    Glad Greg was able to help! And thanks for the kind words. We're here if you need us. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file