1Password X window content too large for extension popup when page zoom not set at 100%

Hi!

First of all thanks for 1Password X, now I can finally use my favorite password manager also under Linux :)

Now to my problem at hand: Since I like most pages to be displayed bigger by default, I have set the page zoom level to 150% in the Chrome settings, but this seems to also translate to the content of the 1Password X extensions popup, which is not appropriately (re)sized for the now bigger content.

The implications can be seen in this screenshot: https://i.imgur.com/vNxI28j.png

While the extension is still usable, it can be quite annoying that buttons are not always completely visible and the scroll bars have to be used.

The problem exists in both Windows and Linux (Arch) under Chrome 62.0.3202.94 with 1Password X 1.1.0. No other 1Password application or extension installed. When I reset the page zoom level in the Chrome settings to its default value (100%), everything is displayed normally, but this is something I explicitly do not want.

Thanks for any clarification on how to mitigate this or possible fixes for this annoyance.
Best regards.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided

Comments

  • MitchMitch

    Team Member

    Hi @SecretSalmon,

    Thanks very much for your report. I was able to reproduce this issue on Ubuntu (but interestingly, not on macOS, where Chrome appears to ignore the zoom setting for the pop-up).

    I'm looking into ways we can address this since accessibility is an important concern for us. I'm also interested in knowing your opinion: would you prefer for the pop-up to scale with your zoom preference (but of course remain usable) or stay at a fixed size?

  • Your response prompted me to open up my old MacBook again and yes, Chrome under macOS seems to ignore the zoom setting.

    As to whether the extension pop-up should be scaled with the page zoom setting or left fixed at 100%, I'm a bit torn to be honest, but I would be happy with either solution. (Whatever is easier for you, I guess ;) )

    But in the meantime I have found a workaround that I can use (for now):

    • Open the extension pop-up page manually in chrome (chrome-extension://aeblfdkhhhdcdjpifhhbdiojplfjncoa/popup/popup.html).
    • Reset the page zoom to 100% for this page.
    • Chrome will save the zoom level for the pop-up and the extension in shown normally (at 100% scale).
  • brentybrenty

    Team Member

    @SecretSalmon: Ah! Good find! I was just thinking that since Chrome is pretty cool about remembering scaling preferences. Thank you for sharing that — even if you beat me to it! And thank you for the feedback. Maybe there's a trick we could use to take advantage of Chrome's built-in "zoom memory". Cheers! :)

  • This solution no longer works.

    CHROME VERSION: 78.0.3904.108
    OS VERSION: Linux: 4.15.0-65-generic

  • brentybrenty

    Team Member
    edited November 2019

    @trivigy: Can you elaborate? I'll close this since it's an incredibly outdated discussion, and you've also posted here. In the future, please refrain from sending multiple messages in different places, as that causes confusion and slows down response times for everyone -- including you.

This discussion has been closed.