Auto-fill Popup disappears when keyboard appears (most of the time)

I've been using 1Password on Android for quite a while now and it has worked well so far. Since a few weeks however (I'm not sure when exactly it started), I cannot use the auto-fill popup anymore, which is sort of annoying.

What happens is that the popup usually shows up when a login field is present. Most of the time this login field will also activate the on-screen keyboard. Once the on-screen keyboard appears, the auto-fill popup disappears. Sometimes the on-screen-keyboard is quicker to appear in which case I will not see the auto-fill popup at all. I'm not sure if the popup actually disappears or if it is just hidden under the on-screen keyboard. Only in some rare cases (like 5% of the time) the auto-fill popup stays when the keyboard activates and I can properly log in using it. Most of the time now, I have to open up the 1Password app and manually copy&paste login information into the login fields.

The behaviour doesn't seem to be limited to a specific app, I've seen it across the board - browsers, my banking app, brain.fm, etc.

I'm using a Samsung Galaxy S7 edge (SM-G935F), on Android 8, Samsung Experience Version 9.0 and the SwiftKey on-screen keyboard version 7.4.5.5.

Is there a way I can fix this so the popup stays open? Maybe a setting I have accidentally messed up?


1Password Version: 7.3.4
Extension Version: N/A
OS Version: 8.0.0
Sync Type: Families

Comments

  • andiAGandiAG

    Team Member

    Hi @derkork, that's frustrating.

    The keyboard shouldn't be dismissing the Autofill prompt, and even if it does, tapping in a login field again should bring the prompt back up.

    Could you check whether Autofill and Accessibility are turned on in the 1Password settings? To check, open and unlock 1Password, and tap Settings > Autofill. Both the switches should be blue to indicate they're turned on.

    I'm not seeing the same behaviour with SwiftKey, are you also able to try with another keyboard and see if that makes any difference?

  • derkorkderkork
    edited January 15

    Hi Andy,

    Thank you very much for getting back to me :). It would seem like the keyboard is not making any difference. I tried SwiftKey, Samsung's keyboard and even the 1 Password keyboard, happens with all the 3. So maybe it isn't caused by the keyboard. It seems to work better in Firefox where the pop-up is working most of the time, but not always. In Brain.fm it doesn't show but intermittently appears and then immediately disappears when I quickly tap the login field a few times.

    The two settings you mentioned are enabled, I also tried disabling and re-enabling them.

    I have created a screen recording of the Brain.fm thing, maybe this helps to understand what I'm seeing. Since I cannot attach it here (MP4s are not allowed), I have uploaded it to Firefox Send: https://send.firefox.com/download/94cecceb90c7a056/#6R7q6S5HKjFQKaK4SnLgXg

  • periperi

    Team Member

    Hi @derkork. I've just tested filling in this site in Firefox and I'm not seeing the same behavior as you. You mentioned that the prompt "intermittently appears and then immediately disappears when I quickly tap the login field a few times." Does the prompt appear if you just tap the username or password field once?

  • derkorkderkork
    edited January 16

    Hi Peri, thank you for checking this :) . The filling in Firefox works most of the time. The video shows the Brain.fm app. There the pop-up appears and then quickly disappears. Sometimes it does not even appear at all. I just tapped the field multiple times quickly to better show this in the video.

    The behavior seems to be that when an input field for a password is focused, the pop-up quickly appears and then immediately disappears. When you do this the first time, the keyboard will also open - which led me to believe that the issue might be caused by the on-screen keyboard.

    I therefore tapped the input field multiple times to see if I could make the pop-up appear again once the keyboard is opened. The video shows that indeed I can, but the pop-up almost immediately disappears again. It also partially renders over the keyboard (which I am not sure if this is supposed to be).

    In Firefox this seems to occur less often, but I get this behavior in all the other apps I have tried (e.g. Brain.fm or my banking app).

  • andiAGandiAG

    Team Member

    Thanks for the update @derkork, let's get a diagnostics report and take a closer look. To do this, follow the instructions linked below:

    Sending Diagnostics Reports (Android)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    • A link to this thread: https://discussions.agilebits.com/discussion/110543/auto-fill-popup-disappears-when-keyboard-appears-most-of-the-time#latest
    • Your forum username: @derkork

    That way I can "connect the dots" when I see your diagnostics in our inbox.

    Let me know when you've emailed in and I'll keep an eye out for you. :)

    Cheers!

  • @andiAG thanks for having a look, I just sent the report. I had to do a bit of manual copy & pasting as the "email now"-functionality wouldn't automatically attach the report to the mail, but I hope you got some useful information anyways. If I messed up, please let me know :)

  • MicaMica

    Team Member

    @derkork No worries, you're golden! Thanks for sending that over, and being sure to copy and paste the content from your diagnostics -- it's very much appreciated. We'll get back to you shortly! :chuffed:

This discussion has been closed.