Support for configuring SCIM w/ Okta

I've been going back and forth on an email with 1Password Support for a couple of weeks and it's gone nowhere, and slowly. I'm hoping that someone can work with me to get the last mile configured. We already have the bridge up and running in Kubernetes and the SCIM integration configured with the app in Okta. We're running into an importing/provisioning issue that doesn't really make any sense.

Ideally, I'd like to hold a screen share with someone so they can see what I'm seeing. Thanks!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Sync Type: Not Provided
Referrer: forum-search:okta scim

Comments

  • graham_1Pgraham_1P

    Team Member

    Hi @ross_namely

    That is very doable. I see Richard already has taken care of you, but to others in the future, please request a call if you need one, and we can coordinate.

    Generally as our development team is relatively small, we prefer to attempt to resolve problems via email first, but screenshares are a core piece of our support if that isn't working.

    Graham

  • Hey @graham_1P,

    Is it possible to get another set of eyes on an email thread I have open with [email protected]? I have had zero traction over the last few months and 1Password keeps pushing me over to Okta and Okta keeps pushing me over to 1Password. I have an Engineer from Okta who has been wiling to get on a call with someone from 1Password, but when I email back to 1Password, I either get no response or a response at least a day later, if not two or three.

    The issue is this...

    When I make a call to the 1Password API, the users returned are correct, both in quantity and the fact that each user shows up once.
    When I make a call to the 1Password SCIM Bridge, the users returned are correct, both in quantity and the fact that each user shows up once.
    However, when Okta runs an import from the 1Password SCIM Bridge, the users that are returned are A) incomplete, B) duplicated, triplicated, or worse, and C) inconsistent from one import to the next.

    I'm trying to find out if the issue is with the call that the Okta Integration is making (which was designed in a joint effort by Okta and 1Password) or if the issue is somewhere else. It doesn't make sense to me that hitting the SCIM Bridge directly but manually would yield one set of results but hitting it via the Okta integration would yield a totally different set of results.

    Unlike most in the forums, we had no issues getting the bridge configured, no issues with Okta reaching the bridge. But the data that's being returned is inconsistent at best.

    Any thoughts, help, insight, or assistance you can provide would be greatly appreciated. Thanks!

  • graham_1Pgraham_1P

    Team Member

    Hey @ross_namely

    I just took a look at your ticket and chatted with NK. You are in good hands; she knows her stuff. As our development team has responsibilities beyond high tier support its hard to have a quick turn-around for same day meeting requests. I'm confident she will be able to work with you to find a time that works for you, the Okta engineer, and her.

    As she has more context than I do, I'll leave it in her capable hands for now.

    My two cents on imports from Okta is that it is a really powerful feature that can sometimes be a bit finicky. Generally you'll need to ensure you are using the right matching term (email), and work on from there.

    Let me know how it goes.

    Graham

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file