Autofill enters incorrect password on USAA and university login

For some time now, when using autofill on my USAA login page or my university's login page, the password is entered incorrectly — the page doesn't recognize it, plus it's visibly the wrong length. If instead I click "copy" in 1Password mini and paste it, it works fine.

This happens on both my Mac and my iPhone.

Any idea why this could be occurring? Is this a problem on my end, or with 1Password's integration to those particular websites?

1Password Version: 7.4 for Mac, 7.4.3 for iOS
Extension Version: Not Provided
OS Version: macOS 10.14.6, iOS 13.1.3
Sync Type:


  • brentybrenty

    Team Member

    @timothymh: Can you elaborate on "visibly the wrong length"? Do you maybe have something of "the wrong length" saved in the password field or web form details of that Login item?

  • timothymhtimothymh
    edited November 2019

    Ah, that solved the university login problem, whoops! Should have thought to check that. 😅

    USAA is still having trouble, though: when I simply hit ⌘\, it fills in something three characters longer than my actual password, though the 1Password entry doesn't have anything extraneous or incorrect.

  • ag_anaag_ana

    Team Member


    If you open this item in 1Password and click on the View Saved Form Details button, do you see a longer password there?

  • @ag_ana Nope, that’s what worked for the Brown password, but the USAA login has nothing extra or incorrect.

  • ag_anaag_ana

    Team Member


    Thank you for the confirmation. Do you mind trying to create a new item manually and see if that one works fine?

  • timothymhtimothymh
    edited December 2019

    I've found the issue — the password field is apparently limited to 12 characters, but my full password was longer than that. (Apparently when you set up a password at USAA, they don't tell you it's too long, they just cut it down.) When I paste my password, it gets automatically truncated by the webpage, but when 1Password fills it, it manages to put all 14 characters into the text field, which then gets rejected as an incorrect password.

    Obviously the fault lies with USAA on this one, but possibly there's something that would make sense to change in 1Password's behavior which would solve the problem as well? Regardless, my issue is solved. Thanks for the help!

  • Hey @timothymh, I'm glad to hear everything's working now. Those pesky websites with their lax password requirements! :smile:

  • I am experiencing a similar problem with the LabCorp Patient Portal iOS app. There are no extra fields in the form details, and the password is correct and of the proper length. 1P auto-fill for the username and password works fine with the LabCorp desktop web site and with the LabCorp web site through the iOS Safari browser. But it fails when trying it with the LabCorp's iOS app. If I manually copy and paste the username and password from 1P into the app, it works. Any thoughts?

  • YaronYaron

    Team Member

    Hey @BLD ,
    It would have been better to open a new discussion about your issue in the iOS forum and not reply here as this is a different platform, but since you're already here, I would suggest you save a new login from within the iOS app after you manually enter the username and password, then try to fill with that new login and see if it does work correctly in the iOS app. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file