Cannot Connect to Desktop App

While I was using MS Edge browser the 1PW X beta extension installed an update. After the install it said it does not support my browser. I closed and reopened Edge and now I seem to have lost touchID for login. When I open 1PW preferences, it says "Unable to establish a connection with a 1Password Desktop App"


1Password Version: 7.4.2
Extension Version: 1.18.6
OS Version: OSX 10.15.3
Sync Type: Cloud

Comments

  • Also seeing this. I assume 7.4.2 being pushed overrode the betas and removed the desktop app integration.

  • Same here.

  • kaitlynkaitlyn

    Team Member

    Hey @edbro @plttn @BrianInMD!

    @plttn was spot on. 1Password for Mac 7.4.3.BETA-0 was released shortly after. Go ahead and try checking for updates if you haven't already, and let me know how you get on once you've got 7.4.3.BETA-0 installed.

  • Yes, it works again. However, I gotta say the roll-out of these updates could have been handled better.

  • kaitlynkaitlyn

    Team Member

    Thank you for the feedback, @edbro. I agree that the update process in regards to Desktop App Integration has some room for improvement. The good news is that once the feature gets pushed to the stable versions, we won't run into the same issue.

    I hope you have a great rest of your week. I'll be here if you have any other questions!

  • edbroedbro
    edited February 6

    It's back! Once again, 1PW X is not communicating with the desktop app. When I open the desktop app, it encourages me to install the 1PW extension, which is already installed.

    1PW-X 1.18.6
    1PW 7.4.3 BETA-0
    MS Edge: 79.0.309.71

  • kaitlynkaitlyn

    Team Member

    @edbro – Do you see the same error on the 1Password X settings page?

    I wonder if Edge is pending any updates. Could you click Microsoft Edge in the macOS menu bar with Edge option, then select About Microsoft Edge. Do you see any pending updates that are requiring you to restart Edge?

    If that's not the case, it'd be helpful to take a look at your 1Password X log to see if it tells us what's going on with the connection. We've got a guide that explains how to grab your 1Password X log here. If you'd rather not post it on a public forum, feel free to shoot us an email at [email protected]

  • There are no Edge updates pending.

    I tried to follow the guide on grabbing the log but it told me to enable "Enable extension developer features". There is no such flag in my install. I verified by pasting that in the search box.

  • ag_anaag_ana

    Team Member

    @edbro:

    It looks like the Enable extension developer features is only available in the Windows version of Edge, according to Microsoft's own documentation page.

  • @kaitlyn For me it does not work anymore since a couple of days Chrome on Mac. When I check settings it tells me: "Unable to establish connection with a 1password desktop app [...]".

    • I do have the latest versions for both 1pX and the desktop app.
    • I switched the connection off and on again (same result)
    • I have unlocked both the extension and the desktop app multiple times

    What am I missing? :)

    Thanks

  • kaitlynkaitlyn

    Team Member

    @ttomr – Sorry to hear about the trouble! I'd be happy to help, but it'd be nice to see a 1Password X log first. That should help me diagnose the issue or at least point us in the right direction. Would you mind grabbing the log for me? You can find our guide that explains exactly how right here.

    In addition to that, can you list out the version numbers you have for both 1Password for Mac and 1Password X?

    Thanks, and I look forward to hearing back from you!

  • Hi, I just installed the Mac beta, v7.4.3.BETA-0 and the 1Password X Chrome extension, v1.18.6 beta. The desktop integration doesn't work for me, however.

    Here are my logs:
    02:44:16.793 background.js:27 Initializing 1Password X...
    02:44:16.943 background.js:27 Initializing Desktop App Integration. Attempting to connect to native app. 💌
    02:44:16.971 background.js:27 Finished initializing beta 1Password X 1.18.6 in chrome (20099)
    02:44:16.975 background.js:27 🖥 Looking for native app 2bua8c4s2c.com.agilebits.1password
    02:44:17.107 background.js:27 Preparing hello payload for device lrn4aqoyojhbjikr6cdtpi5yt4:
    02:44:17.107 background.js:27 (accountUUID, userUUID, server) => (DQX3QH4KJBFUPCQHEGHRCTHXKY, NCYDIAFNXBGXRGU6SIKBEBLPAM, 1password.com)
    02:44:17.110 background.js:27 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.
    02:44:17.133 background.js:27 crypto tests: 190.048828125ms
    02:44:17.135 background.js:27 Signing payload for account DQX3QH4KJBFUPCQHEGHRCTHXKY with kid na3dtetv76r6ubjpbziw6ydsu4
    02:44:17.137 background.js:27 🌈 Sending message to native app
    02:44:17.137 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?
    02:44:19.612 background.js:27 🖥 Looking for native app 2bua8c4s2c.com.agilebits.1password
    02:44:19.713 background.js:27 Preparing hello payload for device lrn4aqoyojhbjikr6cdtpi5yt4:
    02:44:19.713 background.js:27 (accountUUID, userUUID, server) => (DQX3QH4KJBFUPCQHEGHRCTHXKY, NCYDIAFNXBGXRGU6SIKBEBLPAM, 1password.com)
    02:44:19.713 background.js:27 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.
    02:44:19.715 background.js:27 Signing payload for account DQX3QH4KJBFUPCQHEGHRCTHXKY with kid na3dtetv76r6ubjpbziw6ydsu4
    02:44:19.715 background.js:27 🌈 Sending message to native app
    02:44:19.716 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?
    02:44:24.716 background.js:27 🖥 Looking for native app 2bua8c4s2c.com.agilebits.1password
    02:44:24.823 background.js:27 Preparing hello payload for device lrn4aqoyojhbjikr6cdtpi5yt4:
    02:44:24.823 background.js:27 (accountUUID, userUUID, server) => (DQX3QH4KJBFUPCQHEGHRCTHXKY, NCYDIAFNXBGXRGU6SIKBEBLPAM, 1password.com)
    02:44:24.823 background.js:27 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.
    02:44:24.829 background.js:27 Signing payload for account DQX3QH4KJBFUPCQHEGHRCTHXKY with kid na3dtetv76r6ubjpbziw6ydsu4
    02:44:24.854 background.js:27 🌈 Sending message to native app
    02:44:24.854 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?
    02:44:34.825 background.js:27 🖥 Looking for native app 2bua8c4s2c.com.agilebits.1password
    02:44:34.922 background.js:27 Preparing hello payload for device lrn4aqoyojhbjikr6cdtpi5yt4:
    02:44:34.922 background.js:27 (accountUUID, userUUID, server) => (DQX3QH4KJBFUPCQHEGHRCTHXKY, NCYDIAFNXBGXRGU6SIKBEBLPAM, 1password.com)
    02:44:34.923 background.js:27 Native app port disconnected. Error: Access to the specified native messaging host is forbidden.
    02:44:34.928 background.js:27 Signing payload for account DQX3QH4KJBFUPCQHEGHRCTHXKY with kid na3dtetv76r6ubjpbziw6ydsu4
    02:44:34.950 background.js:27 🌈 Sending message to native app
    02:44:34.950 background.js:27 💥 Failed to send because our port was disconnected. Browser code signature became invalid?

  • kaitlynkaitlyn

    Team Member

    Hi @swali! Thanks for jumping in. It looks like the browser's code signature is invalid. What browser are you using?

    If Chrome, you may have a pending update in which case restarting Chrome will cause the update to complete. If you're using a different Chromium-based browser, let me know and there may be some additional steps you'll need to follow.

  • swaliswali
    edited February 19

    I didn't have any updates pending, but I went to the settings page and updated and restarted anyway. Now I'm on Chrome Version 80.0.3987.116 (Official Build) (64-bit) and up to date. The desktop integration still doesn't work.

    In addition, I'm seeing a new problem today, both before and after the Chrome update: the 1Password Chrome popup that comes up when I try to unlock is very slow, borderline frozen. I type my password, and it there is no visual feedback at first, looks like the textbox doesn't have focus. After like 5 seconds a bunch of dots appear at once. I'm able to successfully login and use it after that. If I lock and try again, same thing.

  • kaitlynkaitlyn

    Team Member

    @swali – Thanks for giving that a try. I'd like to investigate the Error: Access to the specified native messaging host is forbidden. error message a bit more. If you wouldn't mind, could you send in a diagnostics report to [email protected]? You can find the instructions for how to create a diagnostics report here. Please include both a link to this forum post as well as your forum username in the email so I can match things up properly.

    For the second issue you noticed, do you happen to have the Chrome window on an external display? There's currently a bug in Chromium that causes some delay in extensions with pop-ups that sounds an awful lot like what you described. I haven't seen much recent action on the issue that's been filed with the Chromium team, but here it is if you'd like to check it out. If that's indeed what you're experiencing, it should be resolved by moving the Chrome window to your primary display. The good news is that your Master Password is still being typed – the lag is strictly a display issue.

  • @kaitlyn Just FYI I sent the diagnostics report a couple of days ago.

    Also, I think you were right about the external monitor. I haven't been able to try that, but I can confirm that the password box lag is non-existent when just using the mac display. Thanks!

  • kaitlynkaitlyn

    Team Member

    @swali – Thanks for the heads up! I just got back to you via email.

    ref: MSF-79319-941

  • @kaitlyn did you find a solution to this issue? I'm experiencing the same issues on OSX 10.15.3. 1Password X 1.18.6 on chrome 80.0.3987.122 with the desktop app being

    1Password 7
    Version 7.4.4.BETA-0 (70404000)
    1Password Beta.
    
  • kaitlynkaitlyn

    Team Member

    Hi @delps1001! I believe everyone in this thread has had different solutions, but I'm happy to look into this with you. The first thing I'd check is if Chrome has a pending update. To look at that, click Chrome in your macOS menu bar, then select About Google Chrome. You'll notice from there if you need to restart Chrome. If that's not the case, it'd be helpful to see your 1Password X logs. You can grab them by following this guide. You're welcome to either post them here or send them in via email to [email protected] If you go that route, be sure to include a link to this forum post and your 1Password forum username in the body of the email. Let me know if you have any trouble.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file