Autofill on Chrome and Safari missing. How to?

Hy guys! Maybe i'm missing something but what i would like when 1P is active is that he automatically fill my user and password fields on sites that i visit. what happen now is (for example on your forum) is this:

https://prnt.sc/r8n7l0

How can i let 1P fill this fields so that i have just to press enter or login?

One other thing is that when i click on user i can't see 1P suggestion because is under the Chrome suggestion and it's annoying :(

https://prnt.sc/r8ncr7

Thanks so so much!


1Password Version: 7.4.4 beta 0
Extension Version: 1.18.0
OS Version: macOS 10.15.3
Sync Type: iCloud

Comments

  • ceceliacecelia

    Team Member

    Thanks for reaching out, @Jedi82!

    There are a couple types of autofill: Automatic autofill and manual autofill. Autofilling using 1Password does require your interaction each time so we can help ensure your data is kept safe. Automatic autofill would definitely be a convenient feature, but we've learned that filling your details on a webpage without your knowledge or consent is not at all secure. This (automatic autofill) opens the door for folks out there with malicious intent. That’s the main reason it’s so important that we’ve made it so it's necessary to always call upon 1Password to fill your information for you, using manual autofill. Once an item has been saved in 1Password, you can select the item from the inline menu to fill your details in an instant by hitting the down arrow key to highlight the correct login and pressing enter. This guide shows what saving and filling using 1Password X should look like: — 1Password Support Guide : Filling using 1Password X

    Chrome's inline autofill menu does seem to be getting in the way in that second screenshot. To remedy that, let's make 1Password X the default password manager in Chrome, which will allow 1Password X to operate at its full potential as well as disable Chrome's built in password manager. To do so:

    • "Right click" the 1Password icon in Chrome's toolbar.
    • Choose Settings.
    • Bump the slider to the right next to "Make 1Password the default password manager."

    That should automatically disable the built in password manager in Google Chrome. :)

  • Thank you for such an explanation :) Will it be in the near future a possibility to let us choose between automatic or manual autofill? :( Would be a nice thing at least for me. Maybe a checkbox to let the user choose and risk of course.
    I know how to disable Google autofill but i discover that make 1P the default password manager inhibits Google to autofill (sooooo well) forms during a payment. And i'm sad to tell you that i'm not so satisfied about 1P autofill identities and address and due to this i have to leave Google autofill on and have this annoying overlap :( But all of you are an amazing team and i know you can make very soon an amazing identity autofill (please please please please)

  • kaitlynkaitlyn

    Team Member

    On behalf of my friend Cecelia, you're very welcome!

    I don't see us going in the direction of automatic autofill, even if it was only an optional setting, if I'm being completely honest. At our roots, we're a security company. Your security really is our first priority. Our very own Chief Defender Against the Dark Arts wrote a compelling blog post on the dangers of automatic autofill that I'd highly recommend checking out. You can give it a read here.

    I'm wondering what it is that you don't like about filling Identities/Credit Cards using 1Password. I'm hoping I'll be able to better understand your use case and pass it along to our developers as a feature request. If you wouldn't mind sharing your biggest pain points when filling Identities/Credit Cards, that would help me out tremendously. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file