will not accept 3 field logins in version7

Hi All
I am updating from ver. 3.9.20 to ver. 7.4.4 Beta-0. on Mac Catalina ver. 10.15.3.
Firstly I am unable to migrate login data from old version as I think I missed the opportunity on Welcome Screen.
I am currently reentering the data manually.
Problem is v7 will not recognise 3 field logins. No trouble with the old v3 but have tried all the options found in various searches but no joy.
Site is https://ibanking.stgeorge.com.au/ibank/loginPage.action.
When I fill in the three fields it compresses to 2 fields when saved in 1password.
Apparently this was an issue in v6 but is claimed to have been fixed in v7.
Any help?
Aside from above. Old version would take me straight to the opened webpage. New version takes me to the completed login page and then I still have to click LOGIN (this is on 2 field logins that otherwise work). Generally a lot more key strokes to achieve same outcome on v7 than was the case on v3.
I am currently on 1 mth free trial on my subscription plan but doubt if that will affect anything above.
Thanks

Comments

  • ag_anaag_ana

    Team Member

    Hi @RoyG!

    I have just tested that website and I was able to get 1Password to fill all three fields for me. Can you please try saving this login item manually in the browser and see if that works for you too?

    Also, you don't have to enter all your data manually: you can still import data from the 1Password File menu > Import... even if you skipped the prompt in the welcome screen ;)

  • Thanks ag_ana
    Good to know that I might to be able to import that data. Not the end of the world really as I do not have that many and I need to go through them all and delete the ones I do not use any more.
    As for the 3 field login. I had to create a new password now as I had too many attempts and got shut out. New user name and pass word works fine manually from the browser however as you know this login site requires Access Number, Security Number and Password. No matter how I try to set it up in 1password it will only create 2 fields - User Name and Password. I guess the name is unimportant however it needs 3 fields.
    As I said the old Version 3 did that no problems.
    Thanks for your help,
    Roy

  • ag_anaag_ana

    Team Member

    @RoyG:

    Have you tried following the instructions I shared with you in my previous post? I used those myself to create a login on that website, and 1Password is now filling all three fields for me.

  • RoyGRoyG
    edited March 1

    My apologies.
    That was assumed, I should have been more specific. Yes I had actually followed that procedure several times before I contacted you. After your reply I again followed those specific instructions several times but still no good.
    In 1Password the entry only shows two fields of saved data no matter how I enter it.
    When in the Login page the three fields appear to fill with dots when I click Go, however the site displays a message something like Incomplete Data and shows the login screen with two of the three fields blank waiting for me to enter data in those fields.
    I have spent a half day today manually entering login data for other sites and testing them. They all seem to work fine eventually after some needing a little tweaking however they are all two field entries. Even one that had each field on a seperate page seems to open fine with 1Password so I have a general understanding of how data entry works by now.
    Just having issues with this one site. I need it as it is probably one of my most used sites at the moment. Guess I have the details memorised by now but still would be nice to have it in the vault with all the rest. I could just save the login page in 1Password then manually enter the login details from memory but really, should I have to do that?

  • ag_anaag_ana

    Team Member

    @RoyG:

    Would you be able to send us a short video of the procedure you are following for that specific website?

  • Thanks for following through with this.
    This is the first time I have ever joined and posted a question on a forum anywhere. I am feeling a bit exposed and vulnerable at present and starting to look rather dumb. As this is becoming an issue isolated to me/my computer and not general interest I would like to close this discussion and email the video direct to support. Happy for you to take it up there if you work in that department as well. Certainly no issues with you personally.
    Thanks Anna

  • YaronYaron

    Team Member

    Hey @RoyG ,
    Thanks for the update. We do understand your concern and wish to continue the conversation privately, so feel free to send us an email to [email protected] with all the details and make sure to add the link of this discussion to the email so we can connect the dots.

    Regardless, I went ahead and tried this on my Safari, it worked pretty well and I made a video recording of my steps for you: https://recordit.co/GUwBnpRJm8
    If this is not what you are experiencing, feel free to email us further or reply here. Either way is great :)

  • Thanks Yaron for the video. Yes that is exactly correct. Probably worth noting here that at the :28 point on your video it only shows as two fields and I feel this is where the problem might be. Same on my computer. However when I go to the next step beyond your video and actually try to log in from 1Password I get the screen below. I appreciate you can not test that step with dummy inputs.

  • YaronYaron

    Team Member

    Thanks for the additional info @RyG.

    I have taken a deeper look at this website and found that it does some crazy stuff to the text you input in the security number field and the password field. It fills in completely random stuff (even if you fill it in manually) instead of the actual characters you type, so then 1Password records some gibberish instead of the actual stuff you type in.

    Can you please try to open that login in your 1Password and click on "Edit", then edit the password field to your actual password, and under it find the security number field and edit it to your actual security number, save the login and try to autofill then?

    If that doesn't work then I'm afraid this website's security mechanisms were designed to prevent autofilling on purpose, in which case I would suggest you contact their support and send them this: https://blog.1password.com/an-open-letter-to-banks/

  • Thanks Yaron
    The gibberish you refer to appears to me to only occur when I click EDIT in a 1Password entry. It looks like it just decides to change the password to a random one it has created. This happens as soon as I click edit and down the track would be a real problem because the official password would then be erased.
    The problem here too is that there is no security number field to edit. It just is not there. Just username and password fields are stored there.
    I am reluctant to blame it on to the bank website because as I have pointed out, logging into this site has always worked fine
    in my old 1Password version 3. I just tried again now and it logs in just fine. Of course the 10 year old lap top is all but dead and the V3 will not run on my new laptop.
    I can send the screen video later but will have to work out how to do that first. I did a search and found a link to instructions. Most probably will not get back to this till after next weekend though and probably should send it to support and not here.
    Thanks.

  • YaronYaron

    Team Member

    Hey @RoyG ,
    Thanks for the update.

    It is not 1Password that changes the entry to gibberish, but the actual website does. Then, when you try to record it as a new login in 1Password, it records that same gibberish from the website. That is why when you try to autofill, 1Password puts in gibberish in the password field and an incorrect security number as that too is being modified by the website as soon as you enter it.

    My solution suggest you try to manually edit the entry in your 1Password, but perhaps recreating it completely manually would work even better. Please try this when you get a chance:
    1. Open and unlock your 1Password desktop app.
    2. Create a new login by clicking the "PLUS" icon and selecting "Login".
    3. Give the new login a name, then fill in your access number in the username field.
    4. Fill in your password in the password field.
    5. In the website field, paste this URL: https://ibanking.stgeorge.com.au/ibank/loginPage.action
    6. Under the website field, select one of the empty fields and put this in its title: "securityNumber" (this is case sensitive).
    7. Put in your security number under the title, then change that field's type from "Text" to "Password" by clicking the little three dots icon on the right side of the fields.
    8. Click on "Save and close 1Password, then go to the website and try to autofill using this new login, see if you are able to log into the website properly.

    Take your time and let me know how it goes when you get around to it.

  • I hate to be a pain. I've looked through numerous posts on this subject and still not able to get success. I think i have the old version of 1password (not x) on my chrome browser so I was able to attempt the solution that is usually described by clicking the gear. That process doesn't seem to be the same in X. When doing it through the old version it will save the username and SSN but not PW. With X in firefox with will do username and PW but not SSN

    Website I'm trying: https://www.paycomonline.net/v4/ee/web.php/app/login
    I've tried making manual entries but not really figuring it out. I guess im curious if someone more familiar is able to look at the site and see if there's anything special about it. Or what I'm doing wrong.

  • ag_anaag_ana

    Team Member

    @dwang:

    I see that you used "Last 4 digits of SSN" as the title of this additional field. Can you try using securityNumber instead, as per my colleague Yaron's instructions earlier in this discussion?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file