auto-lock time setting on iPad iOS 13.4 not working

alm1alm1

No matter what time I set for auto-lock, I am still asked to unlock each and every time.


1Password Version: 7.4.7
Extension Version: n/a
OS Version: iOS 13.4
Sync Type: ?
Referrer: forum-search:auto-lock time setting on iPad iOS 13.4 not working

Comments

  • ag_anaag_ana

    Team Member

    Hi @alm1!

    Is this happening with the full 1Password app, or does it happen in the AutoFill extension?

  • Both the full 1Password app work and the extension work correctly on my Mac.
    The problem is only on my iPad.
    -Al

  • BenBen AWS Team

    Team Member

    @alm1

    Thanks for that information, but to clarify: Ana is asking about the 1Password app vs the autofill extension on your iPad. E.g. if you launch the 1Password app from the home screen of your iPad, unlock it, put it into the background by returning to the home screen, and then re-launch it, are you still asked to unlock?

    The reason we're asking is because with the autofill extension the main app always has to be unlocked once first before autofill can remain unlocked. If you haven't launched and unlocked the 1Password app at least once this session then the autofill extension will be locked every time you open it.

    Ben

  • OK. I understand.
    I've opened 1Password on my iPad and it's open in the background now.
    I will test and let you know in a bit.
    -Al

  • ag_anaag_ana

    Team Member

    Thank you @alm1! Sounds good :+1:

  • OK. I have 1Password open in the background. Auto-Lock is set to 1 Hour.
    I open a site that needs a password.
    1Password is locked and asks me to unlock. I do.
    I login to the site successfully with 1Password.
    I logout of the site.
    A minute later, I try to login to the same site, and 1Password is locked, asking me to login again.

    This should not be happening, correct?

  • BenBen AWS Team

    Team Member

    @alm1

    To confirm: "Lock on Exit" in 1Password > Settings > Security is not turned on?
    Do you have Touch ID / Face ID enabled?
    What do you have set for 1Password > Settings > Advanced > Security > Always show lock screen for Password AutoFill set to? If you toggle that setting, does it make a difference?

    If Lock on Exit is enabled or Touch ID / Face ID is not enabled then I would expect what you're seeing. Otherwise I would not, but toggling the 1Password lock screen setting may help if the other two settings are as expected.

    Ben

  • No. I did not have Lock on Exit turned on. Intuitively, I did not think I wanted that turned on.
    Auto-Lock is set to 1 Hour.
    I have turned it on and will re-test and will let you know results a little later.

    -Al

  • BenBen AWS Team

    Team Member
    edited March 30

    @alm1

    No; sorry, Lock on Exit should be off ("not turned on"). What about the other settings mentioned?

    Ben

  • I turned Lock on Screen back to off.
    I don't have Touch ID turned on.
    I don't know if I have Face ID turned on. I'm running on an iPad Pro 7.
    When I go to 1Password > Settings > Advanced > Security > I get a blank screen. That may be a clue to the problem?
    -Al

  • BenBen AWS Team

    Team Member

    I don't have Touch ID turned on.

    This is the problem. It needs to be on. :)

    Ben

  • YES!! That was it. Thank you Ben! You rock.
    -Al

    P.S. IMHO, this is not the easiest setup for an iPad app, but I'm happy anyway.

  • BenBen AWS Team

    Team Member

    Thanks for the update @alm1. Glad to hear that sorted it. :) If there is anything else we can do, please don't hesitate to contact us.

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file