1Password couldn't finish updating (Update to Malwarebytes 4.1.0 first)

2

Comments

  • I am having trouble with the newest update. My computer has an enterprise version of Malewarebytes (1.80.2.1012), which does not give me the option to whitelist anything. I tried updating with the beta version of 1Password, but it still get the same error message. Any suggestions?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @rdharvey,

    I'm not familiar with that specific version, can you reach out to your IT department to see if they can whitelist 1Password and/or reach out to Malwarebytes for better help.

    You may want to try rebooting and see if it helps.

  • Hi,

    Glad to have stumbled onto this thread as I have been experiencing similar issues.

    I've updated Malwarebytes to 4.1, turned off AV, etc., but getting the same message above when trying to update to latest version of 1Password. Note that I am not even able to start 1Password desktop app (thankfully can get what I need thru the web interface).

    I also tried uninstalling 1Password before attempting to update to 7.4.750 ... no joy - wouldn't let me do that. I get the following error message:

    "Error parsing arguments: ParseError"

    Any guidance would be greatly appreciated.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @jbwjohn,

    That's an odd uninstall error, please use this guide to generate the 1Password diagnostic report and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

  • jbwjohnjbwjohn
    edited March 9

    Thanks @MikeT for the quick response.

    Unfortunately when I (try to) start the desktop app I see it show up in the task manager, but the app doesn't become visible. (And each time I try to start it I see another instance in the process list.) Any suggestions?

  • MikeTMikeT Agile Samurai

    Team Member

    @jbwjohn, just an idea, try this:

    1. Click start menu and search for cmd to open Command Prompt
    2. Enter start 1Password.exe --uninstall

    That may bring up UAC prompt, say yes to allow 1Password to uninstall. Now, see if you can install 1Password.

  • Hi @MikeT,

    Same issue... I get a 1Password warning modal saying "Error parsing arguments: ParseError"

  • MikeTMikeT Agile Samurai

    Team Member

    @jbwjohn, we need to move this to email, so we can help you directly. Please email us at [email protected], in the email itself, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let me know when you did that here. Thanks!

  • Hi @MikeT - email sent.
    Thanks.

  • ag_anaag_ana

    Team Member

    @jbwjohn:

    I confirm that we received your message and that I was able to locate it in our system. I also see that Kate has already replied to you via email :)

    ref: BUI-43783-114

  • I also fixed the problem by updating my MalwareBytes Pro to 4.1.0. Note that the MWB update didn't fix the problem UNTIL I did a RESTART. Then the 1P update completed successfully. Thanks MikeT and all other posters for your help!!

  • MikeTMikeT Agile Samurai

    Team Member

    Thanks for letting us know, @PeteD.

  • I'm having the same issue. Can't update my 1password.

  • GregGreg

    Team Member

    Hi @Jramsey, sorry for the troubles!

    Are you also running Malwarebytes? Have you updated it to the latest version and still have the issues with 1Password update? Please confirm. Thanks! :+1:

  • Hi Greg, I'm not using Malwarebytes. I'm on a company (corporate) laptop, but I had no issues installing and using 1password. So I don't think my company is blocking anything. I've only had an issue with this update...and, the error messaging is constantly popping up throughout the day. I can cancel the update and "roll back", but about 10 minutes later, 1password attempts to kick off the update again and I'm back in a loop of pop-ups and error messages from 1password. Recommendations?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Jramsey,

    We need your help with tracking down that loop, we can't reproduce it. Can you email us your 1Password diagnostics report with this guide and email it to us at [email protected]. Also, in the email, include the link to this thread along with your forum username, so that we can connect the email to this thread.

    Let us know here when you've sent it, so we can confirm we got the email.

    If you're struggling to generate the report, please do the following:

    1. Open Windows Explorer and go to %LOCALAPPDATA%\1Password
    2. Compress the Logs folder and email that instead to us.

    Thanks!

  • Sent. Thanks!

  • MikeTMikeT Agile Samurai

    Team Member

    Just got the report, thanks! I will reply ASAP.

    ref: IDW-78493-323

  • Just to confirm: Updating Malwarebyte cured the problem with 1Password update. This is my actual Malwarebyte version: 4.1.0.56/1.0.20600

  • MikeTMikeT Agile Samurai

    Team Member

    That's awesome, thank you for letting us know.

  • I can confirm I have the latest Malwarebytes version installed and that seems to have finally resolved this nightmarish problem of 1Password repeatedly (I lost count after about 20 times) prompting to install the latest version, failing, and then immediately reprompting. I had to boot into Safe Mode to try to uninstall 1Password to resolve this and then ran into the ParseError. I hope 1P devs will learn from this that while retries are a good thing, unlimited retries are very frustrating - if you try to reinstall the new version 4-5 times and keep failing, guess what - the sixth time isn't going to work! Please stop this endless update loop with no way to exit it.

  • I can report the same issue. I have Malwarebytes 4.1.056 and 1password cannot update since a month. I can disable Malwarebytes real-time check and install updates, but the more serious issue is the installer "loop" of 1password if it fails. I think this is something you would have to resolve, as it keeps beeping and one cannot resolve it without killing all the processes.

  • bundtkatebundtkate

    Team Member

    I mentioned this in another thread, @MichaelJKelly and @Gorkyman, but if y'all are seeing this message repeat obsessively like that, chances are there's something more to this than the Malwarebytes update that was needed. The reason I say this is because the retry is triggered in two different ways:

    1. When you click Retry in the dialogues (I think I'm safe assuming y'all didn't do that) or
    2. When 1Password can't write to its folder to essentially make a note that an update failed and not to retry for 24 hours.

    We do, of course, want it to retry eventually as a little nudge that you still do have to install an update but spamming it is both ineffective and annoying and we're well aware of that. There's a chance of a 3 here – something we haven't tracked down just yet – but before I go digging for something new, I'd want to make sure the case wasn't that your folder wasn't writable as that's the more likely cause.

    So, why might your folder not be writable? It could be genuinely set to read-only, though that's extremely uncommon. I've also see AVs effectively make the folder read-only when something has triggered active scanning. As y'all might be aware, there are two types of scans AVs do. There are your scheduled scans that scan everything ever and will generally happen while you're not using your PC because you set them to do so. Then there's active scanning that is triggered by activity the AV thinks might be fishy so it scans to double-check and prevents any changes from being made while they do so. If this happens during the update then 1Password can't update (because it can't modify its files) and isn't getting the message that it already tried (because it can't write to those files and leave itself that message). This would be my best guess as to why you're a) having trouble updating and b) seeing repeated retries.

    If your AVs (Malwarebytes included) have an active scanning module, then excluding %LOCALAPPDATA%\1Password from active scanning specifically could help. This is generally managed separately from normal scanning exclusions. If active scanning is locking down that folder, this would prevent both the retries and the initial error.

    With that said, these issues are surprisingly unique to the user. The thing with Malwarebytes was a special case where they had a known issue that they sorted out which lead to the same thing impacting a larger number of people, but everything from your AV settings to something like pending Windows updates can cause this sort of interference. We have control over this stuff to a degree, but no matter how hard we try, we're probably going to miss a few possibilities. Read-only was one that was particularly unexpected. It seems like it may have fundamentally broke something we'd implemented precisely to avoid those repeated retries. If we do confirm that AVs are effectively making these folders read-only by locking them down during an active scan, we absolutely are going to have to consider a different strategy for that throttling.

    I hope y'all understand this isn't done out of malice or bare negligence. Windows is a diverse and complicated ecosystem and our PCs are almost like fingerprints these days – they're really unique to us. This is one thing I honestly love about Windows, but it comes with its challenges as well. We're hoping by gathering a larger group of beta testers, we can better avoid more of these in future updates as we'll have more of that diversity covered in the testing phase. And, of course, we always appreciate y'all's feedback. It does allow us to do better every since update, even if we still end up shy of perfect. Thank you for taking the time and, of course, let me know if the any of the suggestions here help. :chuffed:

  • edited April 3

    First, thanks for the super thorough and thoughtful answer. Sorry for my tone that implied negligence.

    All I can tell you is the problem went away when I fixed the Malwarebytes problem, and I am now running 7.4.763 of 1P.

    The symptoms I saw were the UAC dialog would come up presumably asking to run the setup. I think I said YES the first time, but it failed. So after that I would say "NO" and then I would get an error dialog I believe from the installer that the update couldn't happen. I don't remember exactly what that dialog said but I seem to recall it had only an OK button, so I think it was just a failure notice. I would OK that and literally within 1-2 seconds - faster than I could do just about anything else -- I would get the UAC prompt - so I'm guessing it was starting setup again. Again I'd say NO, get the error dialog again... and then it would repeat. When I booted to Safe Mode, I removed 1P from the autostartup group so I could deal with this - and then the problem fixed itself.

    Happy to send a diagnostics report if it helps - I see a lot of setup logs in the logs directory:

    Directory of C:\Users\mikek\AppData\Local\1Password\logs\setup

    04/02/2020  08:27 AM    <DIR>          .
    04/02/2020  08:27 AM    <DIR>          ..
    03/21/2020  03:38 PM               999 1PasswordSecureSetup-7.3.705_install_7.3.705_2020-03-21_15-38-54.log
    03/21/2020  03:38 PM             1,114 1PasswordSetup-7.3.705_install_7.3.705_2020-03-21_15-38-50.log
    03/21/2020  04:23 PM             2,249 1PasswordSetup-7.4.758_2020-03-21_16-23-44.log
    03/24/2020  11:12 AM             7,036 1PasswordSetup-7.4.759_2020-03-24_11-11-38.log
    03/24/2020  11:13 AM             7,036 1PasswordSetup-7.4.759_2020-03-24_11-13-30.log
    03/27/2020  08:19 AM             4,331 1PasswordSetup-7.4.759_2020-03-27_08-19-28.log
    03/27/2020  08:22 AM             4,331 1PasswordSetup-7.4.759_2020-03-27_08-22-35.log
    04/01/2020  06:53 PM             1,007 1PasswordSetup-7.4.759_2020-03-29_23-24-08.log
    04/01/2020  06:53 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-53-26.log
    04/01/2020  06:53 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-53-31.log
    04/01/2020  06:53 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-53-37.log
    04/01/2020  06:53 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-53-42.log
    04/01/2020  06:53 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-53-46.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-53-57.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-02.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-08.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-13.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-18.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-24.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-29.log
    04/01/2020  06:54 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-33.log
    04/01/2020  06:55 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-54-38.log
    04/01/2020  06:55 PM             4,331 1PasswordSetup-7.4.759_2020-04-01_18-55-18.log
    04/01/2020  06:55 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-55-30.log
    04/01/2020  06:55 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-55-38.log
    04/01/2020  06:55 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-55-43.log
    04/01/2020  06:55 PM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-55-48.log
    04/01/2020  06:55 PM               733 1PasswordSetup-7.4.759_2020-04-01_18-55-52.log
    04/02/2020  08:15 AM             1,007 1PasswordSetup-7.4.759_2020-04-01_18-57-29.log
    04/02/2020  08:16 AM             4,331 1PasswordSetup-7.4.759_2020-04-02_08-16-09.log
    04/02/2020  08:16 AM             1,007 1PasswordSetup-7.4.759_2020-04-02_08-16-32.log
    04/02/2020  08:16 AM               733 1PasswordSetup-7.4.759_2020-04-02_08-16-38.log
    04/02/2020  08:19 AM             1,007 1PasswordSetup-7.4.759_2020-04-02_08-18-56.log
    04/02/2020  08:19 AM               733 1PasswordSetup-7.4.759_2020-04-02_08-19-54.log
    04/02/2020  08:26 AM             2,014 1PasswordSetup-7.4.759_2020-04-02_08-26-29.log
    04/02/2020  08:27 AM             2,014 1PasswordSetup-7.4.763_2020-04-02_08-27-33.log
              36 File(s)         64,139 bytes
               2 Dir(s)  429,909,241,856 bytes free
    

    Let me know if seeing these would be helpful.

  • GregGreg

    Team Member

    Hi @MichaelJKelly,

    Thank you for your understanding! Could you please specify how did you "fix Malwarebytes problem"?

    If you want to avoid such errors in the future, please try whitelisting 1Password and its app directory %LOCALAPPDATA%\1Password\ in Malwarebytes on your PC. This way it won't interfere next time.

    Thank you! :+1:

    ++
    Greg

  • This is what is happening for me:

    Dialog comes up and says: "1Password couldn't complete its install. Your 1Password folder is in use or is read-only.". When I click "Cancel", it says that installer will "roll-back" any changes. But after ~20 seconds, same pop-up is shown. So I would guess @bundtkate what you were saying is exactly what happens. I will work it out, but just wanted to let you know what exactly happened (is happening) to me.

    Best,
    Jernej

  • bundtkatebundtkate

    Team Member

    @MichaelJKelly, that UAC thing is actually enlightening. There is only one ill-fated build that would give you a UAC prompt and that thing is definitely a complicating factor. If you were on that version when you updated, I can't even claim professional curiosity in figuring it out as that is an experiment I'm simply happy to see the back of. If sorting out Malwarebytes fixed it and you've had some successful updates since, I'd write it off as a combination of that old UAC build and the known issue with Malwarebytes and call it good.

    As for your trouble, @Gorkyman, it would be helpful to know what resolves things for you. We've got a little guide that covers the common culprits (including a read-only folder) here:

    https://support.1password.com/cs/cannot-complete-install/

    If whitelisting in your AV or removing the read-only flag fixes it, that probably means I'm right. If it is something else that sorts it, though, that might mean we've got a separate issue in need of some attention when it comes to ensuring that update prompt doesn't spam.

  • Well, I had this a while back and it went away next day, No idea why.
    It's now back.
    I've whitelisted with mwb 4.1.0.56 and no change, just a continual loop of update fail.

  • ag_anaag_ana

    Team Member

    @TheGadge:

    Have you perhaps tried rebooting after whitelisting 1Password?

  • @ag_ana Yep, that worked many thanks. Didn't know whitelist needed reboot. Thanks again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file