1Password always starts with "Accounts" highlighted

Not a big deal, but for quite some time, when I start 1Password, instead of "Logins" being highlighted, the program starts with "Accounts" highlighted. (in left column, under "Vault.")

Since I seldom use "Accounts" I always have to click on "Logins" as a first step.

Is there some way I can rectify this? I always use "Logins" and would prefer if this were the default start folder. Thanks.

Comments

  • khadkhad Social Choreographer

    Team Member
    1Password should remember your "position" when you quit and relaunch it. What version of 1Password are you using? I'll try to test this, but I want to be sure we are on the same page. :)

    Thanks!
  • poppiepoppie Junior Member
    edited December 2011
    I'm on v3.8.11 right now, but this behavior has persisted for a good six months, if not longer.

    To recreate:
    - click the 1pw "lock"
    - "Quit" 1pw
    - Restart 1pw
    - Enter password
    ... back at "Accounts" :)
  • khadkhad Social Choreographer

    Team Member
    Very strange indeed. I am not able to reproduce this. Can you test something for me?

    1. Open 1Password (and unlock it if prompted).
    2. Select a Login item from the Logins vault.
    3. Be sure you are not selecting an item in a folder, smart folder, or tag. Select an item in the Logins vault.
    4. Quit 1Password
    5. Open 1Password

    Is that what you were testing before, or were you quitting with an item in a folder or tag selected? Does it make a difference for you?

    If you are still having trouble, please try setting aside your 1Password preference file. Please move these files to your Desktop temporarily and then try the above steps again:

    ~/Library/Preferences/ws.agile.1Password.plist
    ~/Library/Preferences/ws.agile.1Password.plist.lockfile
    
  • poppiepoppie Junior Member
    edited December 2011
    Sorry for the delay, I didn't get an email notification for your reply.

    When I follow the steps 1-5 above, 1PW opens in the login vault, but when I LOCK 1PW (or wait long enough for it to auto-LOCK prior to re-opening) then the Accounts vault is selected.

    The problem only occurs when the program is in a locked state and asks for the password when opening.

    Regarding folders, no... I'm not using folders and am clicking on the vaults.

    OK... I now have deleted the plist files you listed.

    Now, when I recreate the steps (lock 1PW, quit, then reopen) the program always opens with the "General" folder highlighted... This is a different, but very similar problem. I previously had the "folders" collapsed, as I don't use them...

    How can I convince 1Password to open with the Login vault selected?
  • khadkhad Social Choreographer

    Team Member
    The problem only occurs when the program is in a locked state and asks for the password when opening.

    Very strange. We are still not able to reproduce this in the labs. What options do you have selected to "Display in Sidebar"?

    20111213-dwy7tiqbf9g4k3xbba6pu8ebx2.png
This discussion has been closed.