1PasswordX problem with GMAIL Password Fields

I need some help with a problem I'm having. The system is Windows 10, Google Chrome, 1PasswordX version 1.18.1. Desktop version: 7.4.763

Problem Description:

When I try to log on to Gmail, the correct password value is not put into the password field by 1PasswordX. I can see the correct password in both 1PasswordX and in the Desktop application, but those values are not being put into the Gmail password field of the web page. When I reveal the password field, it's like the correct value goes in for a split second, then it gets overlaid with what looks like an old password.

Here's what preceded this episode and what I've done to try and fix the problem:

What Took Place Before the Problem:

I have been going through the process of changing 70 or so web sites on a family member's computer that contained the same passwords on multiple sites, along with weak passwords. To eliminate the inconvenience of keeping their computer for extended periods of time while I changed passwords, I created a vault on my own computer where I have been changing their passwords. After I got them all changed and tested, I shared all of the entries from the vault on my computer to the family shared vault. Then I moved all the entries from the shared vault into the family member's private vault. The entries have been tested and work properly on my system in both Chrome and Firefox. They do not work correctly after importing on the family member's computer using Chrome. There must be something different between the two systems, but I don't know where to start to identify what those differences are. I believe my browser extension updated to 1.18.1 sometime today when I was in the process of importing.

What I've tried:

  • Uninstalled and re-installed all 1Password components.
  • Did "optimize database" from the desktop app.
  • Lots of different trial and error with Chrome settings.

I'm at a loss as to what to do next.

Thanks for any help.


1Password Version: 7.4.763
Extension Version: 1.18.1
OS Version: Windows 10
Sync Type: Not Provided

Comments

  • RTV0070RTV0070
    edited April 15

    I have continued trying to troubleshoot this issue. Are the following log entries from this system meaningful ?

    6208 2020-04-15 16:37:43 1589.475s WRN opw_app::api:736 > failed get_filling_plan: opw-app\src\api.rs:748 JSON
    6208 2020-04-15 16:37:43 1603.820s ERR opw_app::api:701 > chrome: Brain has no plan.
    6208 2020-04-15 16:38:01 1618.821s WRN opw_app::api:736 > failed get_filling_plan: opw-app\src\api.rs:748 JSON
    6208 2020-04-15 16:38:01 1622.146s ERR opw_app::api:701 > chrome: Brain has no plan.
    6208 2020-04-15 16:40:08 1742.191s WRN opw_app::api:736 > failed get_filling_plan: opw-app\src\api.rs:748 JSON
    6208 2020-04-15 16:40:08 1749.366s ERR opw_app::api:701 > chrome: Brain has no plan.
    6208 2020-04-15 16:49:42 2319.511s WRN opw_app::api:736 > failed get_filling_plan: opw-app\src\api.rs:748 JSON
    6208 2020-04-15 16:49:42 2322.700s ERR opw_app::api:701 > chrome: Brain has no plan.

    Edit --
    Need to add that I am seeing the same behavior with the regular 1password browser extension.

  • kaitlynkaitlyn

    Team Member

    Hello again @RTV0070!

    First of all, I sincerely appreciate the detailed report. It makes things much easier to understand, especially with a one-off issue like this one.

    Just so I'm clear on everything, you signed into accounts with your family member's username and password, then updated the password to something more secure, which you then stored in 1Password. Does that sound right? Did the items exist in 1Password prior to you updating the passwords, or did you make brand new items?

    This is definitely odd, and I'm still trying to make sense of it all. The first thing I can think of is to recreate one of the items on their computer. You can use Gmail as a test, if you'd like. Here's the instructions for 1Password X:

    1. Copy and paste (instead of autofilling) the username and password from 1Password X.
    2. Click Save in 1Password underneath the password field.
    3. Save as a new item – you may need to click Update Saved Login and select Save New Login instead.
    4. Add the word "new" to the item's title so you can distinguish it from existing items.
    5. Click Save.

    Now, try filling the Gmail item with the word "new" in the title. Do you see the same results as before?

    This is merely a test, and I don't expect you to recreate each item. I'm trying to get a better understanding of what's going wrong for now.

    Let me know how it goes, and we'll move forward from there!

  • I don't know how to quote on this system:

    "Just so I'm clear on everything, you signed into accounts with your family member's username and password, then updated the password to something more secure, which you then stored in 1Password. Does that sound right? Did the items exist in 1Password prior to you updating the passwords, or did you make brand new items?"

    Not quite right. Initial changes to the passwords were done using my own user i.d. on my system and then I shared them. The items did exist before I updated them.

    I tried to do the test that you suggested and I'm seeing similar results. In looking more closely at the two systems, Chrome is definitely behaving differently on the problem system than it is on my own. It looks like the password information from 1PasswordX is not making it into the password field of the GMAIL login. User I.D. fills properly, but password doesn't.

    I think that something is broken with Chrome. I am going to re-install it and see if I get the same results. If that doesn't fix it, then I would guess the problem is at the 1Password side of things, or some other software component on the system. I'll look at that after I clean up Chrome and will post with updated info. after I re-install.

    Are those error messages I posted related in any way to this problem ?

  • So here's the last information dump for today.

    I uninstalled and re-installed Chrome and tried to log into Gmail. The same problem symptoms persist. Even though I told Chrome to delete everything, extensions and home page persisted after I re-installed. That means that something did get left over from the previous install. I don't know if that's significant.

    I then did a fresh install of Firefox and it is exhibiting the same behavior. The problem system has Kaspersky Internet security installed and mine doesn't. Disabling Kasperskey Internet security did not produce any different results. I have no idea what to try next. During the time that I was doing this, I noticed the following message pop up from 1Password. No idea what that's all about.

    Because of that message, I ran a complete system scan using Kaspersky and it indicated that no threats were detected.

    I got nothing left to add. Much as I'd like to find the root cause of this, I really just want it to work. Any suggestions (up to and including nuking everything and starting over) are appreciated. Let me know if there's anything else I can provide. I will, of course, provide additional diagnostic info. before that if needed.

  • kaitlynkaitlyn

    Team Member

    @RTV0070 – Thanks again for all the details. The screenshot makes me think that Chrome could be going through an update. That'll temporarily change the code signature and cause the 1Password companion extension to become disconnected. If that were the case, though, 1Password wouldn't be filling the username. It's be filling nothing at all.

    The errors in the log you mentioned are somewhat familiar. They reminded me of an issue that was resolved a year or two ago. So, relevant? I guess I'm not sure how to answer that just yet.

    Are you seeing the same results on all of the websites you changed the password for or just Gmail?

  • @kaitlyn - I've done some additional testing and the problem is related specifically to login for Gmail. I've been systematically testing each of the other login entries that I created for my family member, and they've pretty much all worked out fine so far. I've successfully logged into 40 of the 70 web sites, and the only one that gives problems is the Gmail login. I plan on testing the rest of the logins tomorrow, but given results from today, I'm pretty sure that they will work out fine. I'll update this thread when I'm done. The work around for Gmail will be to stay logged in. That way we won't have to manually copy and paste to get logged in to Gmail.

    It's possible the "unknown browser connection" is related to a component of Kaspersky called "Smart Money." While working on the system today I noticed behavior whereby Kaspersky would start some kind of "secure browser" when accessing sites that involve financial transactions. That might have been what popped up that message in the screen shot. I disabled Smart Money. I don't know if you have any information about Kaspersky components interfering with 1Password. I know that there was an unused Kaspersky Password Vault program on this system which I also disabled before starting on this implementation. Possibly something left over and not disabled interfering ??? (just spitballing). Kaspersky is overly intrusive and it's the biggest difference between the problem system and mine. I'll probably remove it in the future because of what' I've seen recently. In the meantime we'll keep using the workaround to stay connected to Gmail.

  • kaitlynkaitlyn

    Team Member

    @RTV0070 – When you look at the problem Login item in the 1Password web app and click Show Web Form Details, do you see the old password listed at all? I'm wondering if an extra field got picked up somehow. Let me know what you find.

    As far as Kaspersky goes, since there are other Logins filling just fine, I doubt it would be interfering. I've heard of it interfering with the connection between the 1Password desktop app and the companion extension, but if that were the case, then all of your items would refuse to fill.

  • @kaitlyn I think I may have found something. I was able to create a login entry that works. When I compare it to the one that doesn't work in the 1Password web app I see some differences. I took screen shot, but I'm not confident that I can obfuscate user information correctly enough to post it on a public forum. Here's a description of what I see on the login that does not work:

    username [email protected]
    website https://accounts.google.com/signin/v2/challen.. [Rest of string is very long]

               Saved on accounts.google.com
               Enter your password       NNNNNNNNNNNN   [_NNNNNNNNNNN is the actual password_]
    

    The last two lines "Saved on accounts.google.com" and "Enter your password" above are not present on the login entry that works. I don't know if that's helpful or not.

  • kaitlynkaitlyn

    Team Member

    @RTV0070 – Ah, super interesting. I'll keep my eye out for an issue like this in the future. It's still really strange to me that it would have filled an old password. Was the old password stored in the Web Form Details of the old item, or did you get a chance to check that yet?

  • @kaitlyn - Nothing happens when I click on Web Form Details. There's no difference between clicking hide or show details. Looks to me like something's scrambled with this entry. Whatever is wrong with it persists when I duplicate the entry or share it from one vault to another.

    I don't know if I mentioned previously that the two problematic entries were in the target vault before I shared the rest of the items into the target. If I was working on this (instead of being retired) I'd be suspicious of the import process, or the update process of 1Passwordx. That update item process just seems flaky sometimes.

    I've got things working right now, so I'd like to clean up the various defective entries. I'll hold off for a day or so before I do that in case there's any further info. that I can provide.

    Thanks for your help on this.

  • kaitlynkaitlyn

    Team Member

    I'm glad you've got it working now. You mentioned the import process – was the item originally imported or was it created in 1Password? I'm more suspicious of the update process, simply because I didn't know that the item was imported (if it was). In an attempt to reproduce the issue, I tried changing my own Google account password. I didn't see the same behavior, though, nor did I get the same "Saved on accounts.google.com" section. I know what you're referring to since I've seen it before, but I haven't had any luck in getting this issue to occur for me.

    Please feel free to clean up the older entries – I'd document the old password in a note of the new item, just in case Google ever asks for it. I recall a website asking for a previous password if you're ever unable to enter 2FA, but I can't remember if it was Google or not.

  • I recall a website asking for a previous password if you're ever unable to enter 2FA, but I can't remember if it was Google or not.

    Yes Google may well ask for previous password(s) as part of AR (Account Recovery).

  • ag_anaag_ana

    Team Member

    Thank you for the confirmation @jmjm :+1:

  • @kaitlyn - I don't remember for sure, but I think that the original problematic entries were created manually. I should have said "shared" instead of "import". I was thinking along the lines of something happening when share (copying) multiple entries into a vault with already existing login items. Good luck with the bug hunt. Thanks again. 8-)

  • kaitlynkaitlyn

    Team Member

    @RTV0070 – I see what you're saying. Thanks for investigating this with me! :glasses:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file