Safari extension having frequent trouble

It seems about half the time I try to use the 1P extension in Safari in the last few months, it hasn't worked. Sometimes if I do a bunch of the troubleshooting stuff it comes back, sometimes not. The most frequent problem is the Command+\ shortcut does nothing. This time when that happened, I did all the troubleshooting steps in the extension Troubleshooting menu, still didn't work. Turned extensions off and back on, option-quit safari, still nothing. Opened 1P app and updated it, said yes to the dialog to update extensions, but it didn't. I deleted the extension in Safari and manually installed it from the 1P app. I love this system, but it's getting to be somewhat unstable and high-maintenance.

Currently I have 3.8.8 extension, 3.8.12 app. Any suggestions to make it work?
Thanks,
Jim

Comments

  • thightowerthightower T-Dog Agile's Mascot
    Hey Jim

    Open System Pref > Keyboard > Keyboard Shortcuts > Universal Access > look for the entry for image smoothing and see if it is using the Command+\ shortcut. In the past this was always the issue for me.

    You can either disable it or change it to something else, I always disabled it myself.

    If this is the issue I would recommend keeping this discussion safe as some updates security and other wise from Apple have re activated it.

    You did not mention on what OSX version you are using, this was always helpful under SL. However it looks like Apple changed this short cut in Lion (or maybe I did it) either way see if my suggestion helps you any.
  • Thank you. I found that shortcut, it was Option+Command+\, but I edited it to something else and then changed it back. I'm not sure if that's why, maybe it started working earlier for some other reason and I hadn't used it, but anyway now it works. I'm using Lion, 10.7.2.
    Thanks again, Jim
  • thightowerthightower T-Dog Agile's Mascot
    edited December 2011
    Hey Jim,

    Nice to hear it. I just noticed you live in Gunnison CO, I use to live in Parachute (between Rifle and Grand Junction) about 28 years ago. GOD saying that makes me feel old. Time flies

    Glad I maybe helped you a little. If you still have issues please post back here or our other support channel http://support.agilebits.com/
    In all honesty if you use the other one you may get a quicker reply. Just my opinion.
  • The Command-\ shortcut is broken yet again. I don't think it is related to the image smoothing shortcut since that is still Option-Command-\.

    I'm running the 3.8.8 extension and the 3.8.13.BETA-1 (build 31231) application on Mac 10.7.2, Safari 5.1.2.

    I've turned Safari extensions off and back on, disabled and re-enabled the 1P extension, and under the main 1P Help>Troubleshooting menu, cleared the cache, restarted the helper, and rebuilt the data file.

    What next?
  • I figured out this was due to the bug involving another user with Safari on with the extension. I quit her Safari and tried to stop the Helper process but it popped right back on again. In any case it gave me the shortcut back.
    Jim
  • khadkhad Social Choreographer

    Team Member
    I figured out this was due to the bug involving another user with Safari on with the extension. I quit her Safari and tried to stop the Helper process but it popped right back on again. In any case it gave me the shortcut back.

    I was just about to mention that. I'm glad you were able to get it sorted out. At the time, running the extension in two different users accounts simultaneously will break the keyboard shortcuts. This is a known issue we are working on. Thanks for your patience on this!
This discussion has been closed.