Logins Window Stays Open

In both Google Chrome (16.0.912.63) and Firefox (10.0) when I use my keyboard shortcut to login to a website the 1Password Login window pops up. It doesn't do it with Safari (5.1.2 (6534.52.7) only the other 2. Sometimes it prohibits the login but most times I have to click the correct login in the open window.

My system is:
MacBook Pro 15" 2007
OSX 10.6.8

Comments

  • khadkhad Social Choreographer

    Team Member
    Hey Phil,

    Are you referring to the "FIll Login" shortcut (Command-\ by default)? Or the "Show Extension Popup" shortcut (Option-Command-\ by default)? I'm assuming the former rather than the latter, but I just want to make sure we are on the same page. :)

    Have you changed the default shortcuts? Could you post a screenshot of 1Password's preferences showing what yours are set to? I'll post mine as an example, but yours may be slightly different if you are using 1Password 3.8.
    20120204-8yca16fdgp4hs93xw128iqwjqc.png
    Does the issue occur on every page or only certain ones?

    If certain ones, does it always occur on those pages or only sometimes?

    I've not heard of this happening before, so any additional details you can provide could help shed some light on the matter. Thanks so much for your help!
  • khadkhad Social Choreographer

    Team Member
    I also want to add that if the extension is set to "Open Login in New Tab" (or "…New Window") and you select a Login from that section, the overlay will still be present on the original tab on which you invoked the extension if you switch back to it.

    This is a known issue. I don't have a time frame for a specific release, but it is on our radar.

    If that is not the issue you are describing, please go on. Pardon the distraction. :D
  • Yes, it happens on every Login on Firefox (my browser of choice these days) and Chrome. I use the top choice shortcut.
  • Sorry, here is the image.
    2012-02-04%252006.34.37.jpg
  • khadkhad Social Choreographer

    Team Member
    Thanks for the additional information (and screenshot), Phil!

    If you press ⌘\ while viewing a login page for a site where you only have one Login saved, 1Password should simply fill it in (and optionally submit it if you have autosubmit enabled).

    The extension will open if you have more than one Login saved for a site. This will give you a chance to select the one you want to use. Can you confirm that you are seeing the popup even when you have only one Login saved for a site? It sounds like that is what is happening, but I'm not sure how that is possible. I've never heard of that issue before.

    Could you try removing and then reinstalling the extension to see if that changes anything?
  • I have confirmed there is only one Login for the sites.

    I have deleted then reinstalled the browser extension then restared Firefox.

    I have confirmed for you that I am using the same Login stroke that comes as default since I've owned 1Password.

    Hope this all helps, it's been annoying.

    2012-02-05%252009.30.00%2520am.jpg
  • khadkhad Social Choreographer

    Team Member
    I have tried all manner of methods to reproduce the issue, but I have yet been unable to do so.

    Does it make a difference if 1Password is locked or unlocked when you use the ⌘\ keyboard shortcut?

    Do you find the same results using the beta version of the Firefox extension? If you're not already using is, you can remove the current extension you have installed, and then check the box to "Allow beta extensions" on the Browser Extensions page:

    https://agilebits.com/extensions/mac/index.html

    You've got me scratching my head on this one. Hopefully we can find that crucial piece of information that allows us to reproduce it in order to fix it. It is nearly impossible to resolve issues we are not able to reproduce. :(

    Thanks for your help with this.
This discussion has been closed.