Internet Explorer freezes

Hi,
I use Internet Explorer 8 and have installed 1Password 1.0.2.155. I only use the tool for a couple of days, but I've experienced the following issue multiple times: When I use the shortcut to fill user name and password on a login page the internet explorer windows (and all of its tabs) freeze. Other IE windows that are opened at the same time are not affected, but I cannot even close the affected window, but must force a shutdown using the task manager.

I have not yet found out if the same issue occurs when I use 1Password with the menu (instead of the shortcut).
Can anybody help me with that issue?
Thanks!

Comments

  • DBrownDBrown 1Password Alumni
    Christine, welcome to the forum!

    I haven't heard of that problem, so I hope you won't mind my asking a few questions:

    If you leave IE open long enough, does 1Password ever fill in the form?

    Does this problem happen with all login forms or only with specific URLs?

    Does it happen every time you press Ctrl+\, most of the times, or some of the times?

    Is there anything else you can tell us that might help us narrow down the possible cause?

    Thanks for your help!
  • Hi David,

    thanks for your help. Please find my answers below.

    If you leave IE open long enough, does 1Password ever fill in the form?
    --> I've kept it open for about 10min, but it did not fill the form.

    Does this problem happen with all login forms or only with specific URLs?
    --> I think it happens will all URLs. I've imported my existing key chain from 1Password for Mac that I use on another laptop and it happens with passwords that I've never used on the Windows-laptop before as well as with those that I did use before.

    Does it happen every time you press Ctrl+\, most of the times, or some of the times?
    --> It only happens some of the times. Maybe one time of ten.

    Is there anything else you can tell us that might help us narrow down the possible cause?
    --> As I described before it may be of interest that I've copied the key chain from 1Password for Mac.
    And sometimes it happens that 1Password doesn't recognize the page and does not offer a password (although it did do it before on the same page). But I do not know if that correlates with the above issue.

    Thanks a lot for your help!
  • DBrownDBrown 1Password Alumni
    At this point, I think we'd have to ask for a few example URLs where the "freeze" behavior happens regularly, so we can reproduce it here and look into possible causes.

    If they're sites you don't want to post in the forum, please send us a message ([email protected]) that includes the URL of this thread (http://forum.agile.ws/index.php?/topic/3394-internet-explorer-freezes/).

    Thanks, Christine!
  • I'm experiencing a similar problem with IE 9.0.8112.16421 and 1Password 1.0.9.272.

    It seems that after I've filled in a password on a site with 1Password (which I can do successfully), at some point later IE will freeze. I generally don't experience this freezing until after I've invoked 1Password to fill in a login for a site. I know, I know, fairly flimsy evidence and, unfortunately, I don't have a specific repro for this. However, I'm wondering if its a regression of the multiple-tab issue (http://forum.agilebits.com/index.php?/topic/9205-ie-9-freezes-when-using-1password-with-more-than-one-tab-open/page__hl__%2Bie9+%2Bfreezes__fromsearch__1)

    If I can track down a repro I'll repost here, or let me know if you have any other recomendations.

    Thanks,

    -b
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, bobbrum. Thanks for posting.

    Please do let me know if you have specific steps to reproduce. If so, try removing the 1Password extension and see if it still happens. I'm sure that seems obvious, but I just thought it would be prudent to mention it. :)
  • AStaleyAStaley
    edited February 2012
    I'm not sure if this is relevant, but I started to have this problem this week. I would open IE9 and bring up 1Password (Ctrl+\) to log me in to a site and the first couple go through without issue and then for no apparent reason IE9 locks. Looking at Task Manager I see multiple copies of Agile1PBroker.exe running, if I clear these down then IE9 responds. Firefox 10 seems to be unaffected. I've since cleared my problem by uninstalling 1Password, rebooting and then installing again.

    I'm running Windows 7 x64, fully patched and 1Password 1.0.9.272.

    AStaley.

    *edit* I did check in the Event Log, no errors around the time of the problem with 1Password.
  • khadkhad Social Choreographer

    Team Member
    Thanks for this additional information, AStaley. It sounds like there might be an issue with the broker process (which is only used with IE and not any other browsers due to IE's protected mode). So if there is an issue with the broker process, it will only affect IE.

    We're still unable to reproduce the problem here, but we'll continue to monitor this situation.

    Just to be clear, does the problem still exist if you simply remove the 1Password extension from IE?

    Do you have any specific, reproducible steps I can take to see the issue on my own machine? If we're not able to reproduce the problem it can be very hard (or impossible) to resolve it. I'd love to get this sorted out for you, so please let me know.
  • AStaleyAStaley
    edited February 2012
    Since I reinstalled 1Password I've not had the problem reoccur, so my problem does seem to have resolved it self. I wasn't doing anything out of the ordinary and my Windows is a standard setup with the minimum loaded. I.E. Flash Player/Adobe Reader and Java. The only other thing i can add is that the problem would never occur straight away, and I would have closed/opened IE9 a few times, looking at current behaviour it would seem that the broker process wasn't unloading when I exited IE9 and then a 2nd/3rd copy etc was started? At the point IE9 would lock I had maybe 10 copies running.

    My 1Password is also a straight forward setup, the keychain is stored in a Dropbox folder. The keychain was originally created on my Mac and then added to my Windows install later. I've not changed anything in my Mac/Windows setup other than the recent update for Mac and the usual Windows security updates etc.

    It may not be the same issue as the original OP but at least sounds similar. Hopefully it provides some useful information.

    AStaley.

    *edit* Around the time this issue started happening I had just updated Flash Player with the latest release. But can't recall if this was before or after.
  • khadkhad Social Choreographer

    Team Member
    edited February 2012
    Actually, I think I just reproduced the issue. If not, I found a different issue. :)

    I'm working with the dev to resolve. Can you try these steps and let me know if that seems like the issue you saw?

    1. Open IE 9

    2. Make sure that the 1P extension is locked

    3. Open more than one tab. (The issue does not occur if there is only one tab open.)

    4. Visit the login page for a site where you have a saved Login item.

    5. Press Ctrl+\ or select the Login from the extension.

    6. Enter an incorrect master password. (The issue does not occur if you skip right to step 7.)

    7. Then enter your correct master password


    Unlock sound triggers and windows focus shifts to the previously used app. Clicking IE results in nothing but Windows 7 "dinging" at me.
  • This isn't the issue I originally had. But does look to be a bug, if I do as you instructed then I get a crash with IE9 which then recovers itself.

    Looking through my Event Log I have an entry for Application Error, Event ID 1000. Content is below;

    Faulting application name: iexplore.exe, version: 9.0.8112.16421, time stamp: 0x4d76255d
    Faulting module name: Flash11f.ocx_unloaded, version: 0.0.0.0, time stamp: 0x4f39bda1
    Exception code: 0xc0000005
    Fault offset: 0x588682b8
    Faulting process id: 0x11f8
    Faulting application start time: 0x01ccf223e2a893ad
    Faulting application path: C:\Program Files (x86)\Internet Explorer\iexplore.exe
    Faulting module path: Flash11f.ocx
    Report Id: 31e03aab-5e17-11e1-a9f9-005056c00008
  • khadkhad Social Choreographer

    Team Member
    It looks like Adobe Flash crashed.
  • Indeed, repeated your steps 4 times and same result everytime. Running the latest release of Flash Player 11,1,102,62, with the latest Nvidia GFX drivers 293.73. Not the same issue as originally posted I'm sure, but still a nice bug for the dev's to play with.
  • khadkhad Social Choreographer

    Team Member
    Thanks for the additional information! We'll keep an eye on this.
This discussion has been closed.