Cannot install Firefox extension in Windows

Hi,

I can't get the 1Password extension to install on my Windows PC in Firefox. It appears to drop '[email protected]' into the extension directory, but not enable in extensions.ini. Not sure why this is happening:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
1Password 1.0.9 BETA-275

Cheers,

Comments

  • khadkhad Social Choreographer

    Team Member
    Sorry you're having some trouble. I'm not able to reproduce the problem here unless I don't check the box to "Allow this installation" when prompted by Firefox. Can you confirm that you are checking that box when installing the extension?

    Just quit Firefox and then uncheck/recheck "Firefox" in 1Password's preferences.

    Next time you launch Firefox you should see this:

    20120217-qwk2f36d4kw4ke9bjgkmmybe2f.png

    Are you using multiple profiles in Firefox?
  • kop48kop48 Junior Member
    Weird. I was trying to do that yesterday (multiple times), and that dialog never came up. Updated 1Password to the latest Beta, and Firefox picked up the extension (with the dialog you showed above.)

    Not sure what went wrong...
  • khadkhad Social Choreographer

    Team Member
    I'm glad it is working well now. If you have any further trouble, please let me know.
  • I went to Win 7 FF 9.0.1 from 3.6.27 and accepted update to 1P 1.0.9.279.
    I cannot get the 1P icon back on my main FF toolbar.
    It seems to be in an endless loop taking me back to the agilebits page and showing only Safari and Chrome add-ons.
    I blew away FF 9.0.1 went back to 3.6.27 but
    1. need to know which version of 1P compatible with FF3.6.27 to re-install (this combo was very stable)
    2. Any suggestions as what viable alternatives there are.
    As much as I would like spend all night to get this sorted ... I just need to quickly restore back to stable state.
    As much as I am frustrated by it ---> Win 7 is my work machine.
    Many thanks
  • How and where are you installing our Firefox extension? You should install it here:

    File > Preferences (Ctrl+P) > Browsers

    ...and then check the box that reads "Mozilla Firefox".
  • kop48kop48 Junior Member
    I kept having this problem again on my Windows Server 2008R2 machine. I'm running Windows 8 now, and the problem does not seem to be happening, but I never ended up resolving it on my Server machine.

  • How and where are you installing our Firefox extension? You should install it here:

    File > Preferences (Ctrl+P) > Browsers

    ...and then check the box that reads "Mozilla Firefox".


    Extension install -> going to 1P ->Preference and ticking Firefox (checkbox)
    Did this for IE and the 1P icon appears in customise toolbar so IE works.
    I have gone back to FF 3.6.27
    Created a fresh profile and tried the 1P install again --> 1P->Preferences->FF checkbox-->tick
    1P is at Version --> 1.0.9.279
    the 1P icon *does not* appear in the "customise toolbar" icon, so no 1P in FF.
    ??
  • khadkhad Social Choreographer

    Team Member
    edited March 2012
    Can you confirm that the box for your profile in checked in 1Password's preferences? Click the "Profiles…" button to the right of the Firefox checkbox.

    20120302-erd9gsqcipm7sq98bp3saykmmk.png

    Try quitting Firefox, unchecking the main box for Firefox, restarting your computer, and then checking the box for Firefox once more.

    Can you also confirm that the path listed in 1Password's preferences for your profile matches the one Firefox is using?

    Enter [font=courier new,courier,monospace]about:support[/font] in Firefox's address bar, then click the "Open Containing Folder" button.

    20120302-c9bu2k7qews1udq755u5u9pw9y.png
    It sounds like it is not showing up in Firefox's list of extensions but can you double-check there as well?

    20120302-bwx1njuex2xa8ic8pin2xbipn3.png
  • Hi Khad,

    Checked that 1P and FF (containing folder) use the same path for the extension and it is the same. Both point at :-

    C:\Users\'my_username'\AppData\Roaming\Mozilla\Firefox\Profiles\bemxgrm8.default

    1P is now showing up in the FF Add-On page.
    [attachment=1555:1P_xtn.jpg]

    It it still not showing up in the "Customise" --> Icons page
    [attachment=1556:no_icon.jpg]

    So I am (still) stumped.
  • Hi Khad,

    Solved.
    In the "customised toolbar" page, you need to click on the "Default Set" of Icons --> thats where the 1P icon hides.

    Ah well.
  • khadkhad Social Choreographer

    Team Member
    edited March 2012
    Thanks for updating the thread to let me know that all is well. :)

    From the screenshot it appears that the 1Password button was already in the toolbar. Perhaps it was just hidden from view, so restoring the default set brought it back into view.
This discussion has been closed.