IE9 Hangs after new login created

I'm running 32-bit IE9 on 2K8R2x64. Whenever I create a new login, IE9 becomes unresponsive and I have to end process. IS this a known issue, are there any steps to resolve this?

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, guruchill. I'm sorry that you are having this problem.

    Please be sure you are running the the latest version of 1Password.

    Could you be more precise as to when IE becomes unresponsive? Are you manually saving a Login using the "Save Login" button? Or is it an autosave prompt? Does the problem occur before, during, or after the "Save this … Login in 1Password?" dialog box?

    20120229-faexxy7a3dhxx19pai85sum53h.png
  • The Save this login dialog appears, and I can hit save. After this IE becomes unresponsive (it feels like there's a modal dialog popped up somewhere that I can't find)

    I've updated a few times, have been experiencing this for a while.
  • khadkhad Social Choreographer

    Team Member
    Does it make a difference if you only have a single tab open versus multiple tabs?

    Does it make a difference if you have a failed master password entry, or does it always occur even if you unlock 1Password on the first try?

    This sounds similar to another issue I have documented, but I don't have Windows Server 2008 to test with at the moment. Do you see the same behavior in Windows 7, Vista, or XP (assuming you have access to any/all of them)?
  • Hi,

    This only seams to happen if I have more than one tab open. I don't see any correlation between a failed master password. Only other OS I run is OSX.
  • Hi,

    I have exactly the same issue when using IE9 on Windows 7 64 bit. I happens on two computers.
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Mark. I'm sorry to hear that you are also experiencing some trouble.

    We have thus far been unable to reproduce this in our labs. It can be very difficult to come up with a solution for a problem we cannot see ourselves. Could you give me a list of the steps you are taking to reproduce the problem? Perhaps we have been missing a step in our testing.

    Is it 100% consistent or does it only happen occasionally?
  • I have the same problem with IE9 on Windows 64bit. It seems to have problems primarily on sites that have javascript for their logins (i.e. pop ups or other things for logins). If it's a static site it seems a little bit more stable. For example the American Express site. But I would say about half the time recently, 1password crashes IE9. Any suggestions? Reinstalling? I like IE9 because it has better OneNote and Evernote addons. Would like to keep using it if possible.

    It tends to crash for me either after the password is loaded in. Sometimes even before.
  • khadkhad Social Choreographer

    Team Member
    Sorry if I sound like I am repeating myself, but could you give me a list of the steps you are taking to reproduce the problem? I'd love to be able to reproduce it in order to resolve it.

    Thanks in advance for you help!
  • edited March 2012
    Sure. It's a little unpredictable what sites work. One that is failing right now is Smorgie. Basically I try to login and press the 1Password button on my browser. I then fill in the 1Password password and it returns to the site and then hangs. (it does fill on the password and then it hangs). IE9 will then over crash and recover that page. Sometimes it cannot recover that page and I get a error that says Website Restore Error. ieframe.dll

    It seems to be intermittent and particularly a problem when the sign in box is a window rather than a space on the static webpage.

    Another thing that seems to break it is if I try to generate a new password from the site. That seems to almost always crash IE and one password.

    It's also happening on Fool.com right now. Sometimes it happens on American Express.
  • khadkhad Social Choreographer

    Team Member
    edited March 2012
    Hm. I am really trying to get IE9 to hang, but I just can't.

    You mention "Smorgie" but you didn't provide a URL. Is this the Login page to which you are referring?

    http://smorgie.com/user/signin

    Do you have the problem immediately after a fresh launch of IE9 or has it been running for a while?

    Are there other tabs open or just a single window?

    I tried generating a password, saving a Login, and filling the saved Login at all of the following URLs:

    http://smorgie.com/user/signin

    https://www.fool.com/secure/login.aspx

    https://www.americanexpress.com/

    I was able to get IE9 to freeze sometimes, but I was unable to come up with a set of reproducible steps myself. It isn't clear to me if this is a 1Password problem or a problem with IE9. IE9 is not my regular browser, so I don't have much of a frame of reference in IE9.

    We'll continue to see what we can uncover. Thanks!
  • Hi there,

    same problem for me on ie9 and W7 64 bit.

    It prompts to save login, prompts for master password... and then nothing more possible. Completely kills IE9 and I have to do an end task from task manager.

    Doesn't make a difference if 1 or more tabs.

    I did originally get the message telling me that 1password would run outside of protected mode and I okayed this. Didn't really have a choice!

    Going to disable add-on for now and do everything manually.

    Please fix - very annoying.

    Mike
  • Yup. you got the right login for smorgie. It tends to happen a bit after IE9 has been running for a while. I actually find IE9 to in general be a little less stable than chrome particularly when the pages are heavily running javascript so these may be related. Adding 1password to the mix seems to really crash it.
  • khadkhad Social Choreographer

    Team Member
    mikecurl, if you are going to disable the 1Password extension in IE9, rather than doing anything manually, I would at least suggest switching browsers where you may find greater stability all around. Obviously we want to resolve the problem if it lies within the 1Password extension for IE9, but so far we are not able to consistently reproduce anything. That makes it nearly impossible to come up with any kind of fix.

    felixtsai, thank you for the additional data. I'll continue working with the developer, but please don't hesitate to add more information to this thread if you come across any.
  • Is there any resolution to this? I'm also seeing the issue on a fresh install of IE9 on Win7 now.
  • khadkhad Social Choreographer

    Team Member
    Thanks for the additional data point, guruchill. Unfortunately, we have still been unable to narrow it down. If you can provide any additional information (especially steps to consistently reproduce) that would be extremely helpful.
This discussion has been closed.