1Password Mobile quits when viewing security cameras

diittodiitto Junior Member
Hi... I have three Panasonic security cameras that monitor my home. Those camera are username/password protected so on my iPhone 4, I purchased a copy of the 1Password mobile app, built logins for these three cameras and placed the access to those three cameras behind 1Password Mobile.. See attached a jpg of one of many screens available on these cameras... Note that there are buttons on the left side of the screen and clickable tabs across the top of the screen.

When this screen comes up on the iPhone, all the buttons are very small so I first have to two finger drag to zoom the screen somewhat... Then I have to move around until I can see the button I want to push. Then I push it... Pushing any of the buttons along the left side works fine... But if I click any of the tab buttons across the top of the screen, 1Password immediately quits. I have to launch it again, put in my 1Password password again, reopen the login for the camera I'm interested in and do this all again... 1Password used to do this once in a while so I just tolerated it... But now it's quitting 100% of the time... That makes it almost not useable for me...

Last night I tried several of the buttons (tabs) across the top of the screen and each one I tried caused the app to quit while none of the buttons I tried along the left side did so...

So see the attached jpg called "page.jpg"... Again, it's the black tab buttons such as Setup, Top, Single, Multi (any of them) across the top of the page that cause 1Password to quit 100% of the time. While none of the buttons on the left side cause any problems...

Your thoughts??? thanks... bob...

Comments

  • thightowerthightower T-Dog Agile's Mascot Community Moderator
    edited October 2012
    Hey bob

    Been a while since I seen you around.

    I use an app called Remote Patrol for my camera viewing. But in re to your question I would assume it has something to do with the built in browser, and possibly updates to it made by Apple or possibly something by the guys here.

    I cant confirm for sure one of the staff will need to answer that question.

    I mainly wanted to drop in and say thanks I never really thought of putting my login inside 1P and going that route. (truth be told I seldom use the built in browser) I just wanted to say you gave me a new idea and thanks for doing that.
  • diittodiitto Junior Member
    Hey thightower... good to see you too... Yeah, I have some rather long usernames and passwords for logging in to these cameras (no good reason why, tis just how I set them up once upon a time... So, by making a login via 1Password, it stores the login info for me (just like 1Password is supposed to do) so all I have to do to get into any of the cameras is log in to the 1Password mobile app...

    Like I said, it would always quit on me once in a while but now it's constant... I can still see the cameras as they default to the single camera view screen. But if I want to change a setting, especially shut one off so it doesn't trigger when I walk in the room, for now I can't do that with the 1Password mobile app... I will look at the app you use, Remote Patrol, to see what it does...

    Hope all is well on your end... thanks... bob...
  • khadkhad Social Choreographer

    Team Member
    edited October 2012
    It sounds like a possible low memory condition. If so, restarting your device may help. Please try restarting your device by holding down both the Home and Sleep buttons simultaneously for at least 10 seconds until the Apple logo appears.

    Which specific iOS device are you using? Is it the 4 or the 4S? Do you have access to any other iOS device to test it there as well?
  • diittodiitto Junior Member
    Hi khad... I did what you suggested by restarting the iPhone... Did no good... Still fails every time I click any of the tabs at the top of my camera pages. Does it on any of the camera pages... The phone is an iPhone 4 (not 4S). I also have a first generation iPad on which I also have the 1Password mobile app... The iOS on the iPhone is version 6.0. On the first gen iPad it has stopped at version version 5.1.1

    Now someone smarter than me will have to tell me how to check the version number of the 1Password app itself... I've been hunting for how to do that and I would think it would be obvious but so far, I haven't found it... I hadn't used 1Password on the iPad to connect to these cameras but I did go ahead and build a login for one of my cameras and that works fine...

    So it does NOT work on the iPhone 4 running iOS 6 and whatever version of 1Password is on there (recently updated all apps)... And it DOES work on the first gen iPad running iOS 5.1.1 and whatever version of 1Password is on the iPad (have not updated that in quite a while and the iPad is showing 12 apps needed to be updated but there is some other bug (reading all about that on Apple support) that is preventing me and lots of other folks from being able to update apps on some (??) iPads...

    Can someone tell me how to check the version number of 1Password on either the iPhone or the iPad???

    So that's what I know... Your thoughts??? thanks... bob...
  • diittodiitto Junior Member
    OK, I was able to update the apps on my iPad 1. I intentionally did NOT update the 1Password app (yet) but it did let me see what version of 1Password it was wanting to update to and that would be version 3.7... So the iPad 1 has something older than 3.7 on it currently and it works... The iPhone has whatever is the most recent app and that one does NOT work... Just an update to what I said above... thanks... bob...
  • thightowerthightower T-Dog Agile's Mascot Community Moderator
    Bob,

    On the Phone

    Launch 1Password > (enter pin etc as needed to open the app) > more > settings > about - version number should be shown.

    Should be similar in nature on the iPad I don't have one in front of me at the moment.
  • diittodiitto Junior Member
    Yep, thanks... I should have been able to figure that out... But I didn't... So thanks... Anyway, the version on the iPad (that works ok) is 3.6.5... The version on the iPhone (that has the problem, see earlier post above) is version 3.7... thanks... bob...
  • diittodiitto Junior Member
    Hi... Today I upgraded the 1Password app on my iPhone to the new version I just saw, 3.7.1... Unfortunately, the problem I've been having as described above is still there... When I click any tab at the top of custom screens on my Panasonic web camera pages, 1Password instantly quits... Other controls on the webpage work but not the tabs at the top... Unfortunately, one of those tabs must be clicked when i want to change modes from secure to insecure or vice versa, something that I do often...

    Just a heads up that the problem I have still exists... Might be a tough one to fix since it does appear to be specific to the Panasonic webpage format...

    thanks... bob...
  • khadkhad Social Choreographer

    Team Member
    Thanks for the update, Bob. If there is any way we could actually access the site to see what it happening, that may be the only way we can resolve the issue. I understand that it may be a very sensitive thing, but we can discuss the details if you are interested via email: [email protected] agilebits .com

    Can you confirm for me that the site works as expected in Mobile Safari? Have you tried in Mobile Chrome? That is to say, the problem is only in the 1Password app?
  • diittodiitto Junior Member
    Hi Khad... I just now tried Mobile Safari... I logged on and was able to click two tabs successfully but when I clicked a third, Safari quit... I then logged on a second time (takes time to log on, especially typing on an iPhone, thus my reason for wanting to use 1Password). This time I was able to click a tab only once successfully... On the second attempt, Safari quit...

    That's sort of how 1Password worked in recent times but on some more recent upgrade, now 1Password fails on every tab click...

    But Safari quitting so regularly wouldn't be much better so the bottom line is the problem exists on more than just 1Password... Something about these Panasonic webpages, only the tabs at the top and not at all the many buttons on the left of the screen (see attached pic at the beginning of this thread), cause these apps to be unstable and quit...

    It all worked fine when I first put 1Password on my iPhone... Then it began to fail now and then... And now, all the time... Safari is only barely better... Hmmm... I will give Chrome Mobile a try but right now, it's off to the rack for me... I will post more after I try Chrome... But the bottom line is it does not appear to be a 1Password problem, at least not exclusively... More a Panasonic problem and getting those guys to change anything would be next to impossible... I get work around it and likely will just need to do so... But I will post what Chrome does later... thanks... bob...
  • khadkhad Social Choreographer

    Team Member
    That is definitely bittersweet. It would seem to be a bug in Safari and thus the WebView that we use in 1Password since it uses the same code from Apple. If it were only a problem in 1Password we may be able to resolve it on our end, but if the problem is in Safari/WebView that code is beyond our control. I'm sorry I don't have a better answer, but I am curious if it somehow works in Chrome. If so, that would be very interesting indeed.

    Cheers,
  • diittodiitto Junior Member
    I tried Google Chrome Mobile tonight... At first, it appeared to work as I was able to click three or four tabs and it worked... But then, just clicking yet another tab, the code seem to pause as the gear just sat spinning... Then the code quit just like Safari or the browser in 1Password... I then relogged in to the Google Chrome version of one of my cameras and from that point forth, every time I would click a tab, the code would just quit...

    So, it must be an issue between how these Panasonic webpages are built and ALL these mobile browsers... Oh, and I did just update the iOS version tonight to 6.0.1... That I did before trying Google Chrome... I also tried the 1Password browser again just to see if the updated OS helped but no... It still fails...

    They all fail... All browsers... Too bad... thanks for the help... bob...
  • khadkhad Social Choreographer

    Team Member
    I'm sorry to say that it does sound like a bug in Safari/WebView. We'll keep an eye on it, but I think this may be out of our control.
  • diittodiitto Junior Member
    edited November 2012
    yeah, I think you're right... Like I said, it used to fail now and then but now it's every time... But I've figured out a reasonable workaround... I use two of the tabs on each of 3 cameras... I used to have 3 logins for the three cameras and then I would use the two needed tabs to move between two different screens... But today, I went ahead, inside 1Password, and made six logins (took maybe 10 minutes total to make them, long URL's).. Three of the logins are the three cameras accessing one of the tabs... The other three logins are the same three cameras accessing the second of the two tabs that I use... So by accessing the screens at the URL level (the different tabs have different suffixes on the URL's) I can still access all the screens I need without having to touch the tab keys anymore... Just gave the six logins reasonable names and I'm good to go... Not very eloquent but perfectly functional...

    thanks for all the help... bob...
  • khadkhad Social Choreographer

    Team Member
    Necessity is the mother of invention. You've come up with a very creative workaround. I'm glad that works for now. :)

    Cheers,
  • diittodiitto Junior Member
    Thanks Khad... Retyping these long URL's, my usernames and passwords multiple times made me remember why I so appreciate 1Password... Keep up the good work... thanks... bob...
This discussion has been closed.