Web Mode Freezes Briefly After Entering Quick Unlock Code

Penelope PitstopPenelope Pitstop Junior Member
Is this bug reproducible?

Mostly but precise trigger not clear. 4.1b3.

Which devices did this bug appear on and is it reproducible on any devices?

iPad. Haven't tried phone.

A quick summary of the bug:

App becomes briefly unresponsive after entering quick unlock code.

Detailed Step-by-step instruction on how to reproduce it:

1. Open 1PW in landscape orientation. Make sure lock on exit is switched on. Go to web mode. Browse say this forum.

2. Quick switch to Safari and browse a few sites for 15-30 secs.

3. Quick switch back to 1PW and enter QUC. You will see page you were last browsing but be unable to scroll it. App is completely unresponsive for a few seconds. Long enough to make you think it has hung.


  • roustemroustem AgileBits Founder

    Team Member
    I just fixed a somewhat similar issue in 4.1b4. Please if it works for you.

    Thank you!
  • Penelope PitstopPenelope Pitstop Junior Member
    Yes that seems to have fixed it :). I had a sneaky suspicion it was something to do with syncing because the delay seemed about the same as when I watched the iCloud sync status. I didn't mention it because I had no real evidence to link the two things.
  • MikeTMikeT Agile Samurai

    Team Member
    That's great news, thanks for confirming it!
This discussion has been closed.