1 Password in Firefox shows "connecting...(ascending number)" when entering master password

I use 1 Password with Firefox and Drop Box with my MacBook Pro. I installed Drop Box and 1 Password on my desktop Windows 7 PC. The 1 Password installation seemed to work and Drop Box syncs but I cannot get 1 Password to work in my Firefox browser.

In the Firefox toolbar, the 1 Password icon has a red questionmark over the key. When selecting the key to open the app and enter the master password the button shows "Connecting...(ascending number)". I had also installed the Firefox extension under 1 Password>Preferences>Browsers.

Drop Box is synching with a green checkmark. If I open the 1 Password application from Start>Program files>1 Password, the program opens, I enter the master password and the program displays all my data (passwords, identities, wallet, etc.) So it appears Firefox is not talking to or knows where to point to to get a file it needs, but the file structure on my HDD for 1 Password all seems to be accurate.

What else do you need to know to help me get it working?

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, JediHoth! The "syncing" message you are seeing is not related to Dropbox at all. The extensions themselves have a sandboxed database that syncs back to the main app.


    Please review our troubleshooting guide for this, and review each step carefully:

    http://help.agilebits.com/1Password_Windows/helper-not-connected.html

    A common cause is a proxy server or other "Internet security" programs blocking the secure connection between the sandboxed browser extension and the main 1Password program. Workarounds for both of these are outlined in the guide, and the latter has its own page linked in step seven:

    http://help.agilebits.com/1Password_Windows/antivirus-configuration.html

    Please let me know how it goes and if the above applies to your situation.


    Also, you can try completely removing and reinstalling the Firefox extension. Other browsers handle the removal of the SQLite file automatically, but you will need to do this manually for Firefox:

    1. Open Firefox.
    2. Remove the 1Password extension.
    3. Enter `about:support` in the address bar and press Return.
    4. Click the "Show Folder" button.
    5. Quit Firefox.
    6. In the Explorer window that opened, go up one level in the file hierarchy.
    7. Move the `OnePassword.sqlite` to your desktop.

    ​Then reinstall the Firefox extension from 1Password for Windows' preferences on the Browsers tab.

    _Once everything is working well, you can safely move the `OnePassword.sqlite` file on the desktop to the trash._

    If you're still having trouble, could you please send us your Diagnostics Report? Select **Help > Diagnostics Report > Export to File** from the menu bar in 1Password. Then attach the report to an email to us:

    support @ agilebits.com

    Once we see your report we should be able to help more. Thanks in advance!
  • Khad,

    1 Password seems to work now and I did very little (changes) to make it work. I'm not sure what caused things to work but I still want to provide you feedback so you might know better what happened and help someone else should they have a similar problem. I opened the 1 Pasword program and checked for updates but as I suspected I was already runnig the latest version. I had opened Firefox and saw the familiar black key on the toolbar but it did not have the red question mark over its icon. I tried opeing the app by entering the master password and it gave me the familiar synching message and counting upward. Even when I moved to another program and came back for instance the number was much higher, meaning it was still counting upward (trying to sync) in the background.

    I didn't tell you before but I run Norton 360 for firewall and internet security. Although I did not make any adjustments to it. I didn't have to get that far in the help process.

    What apparently made 1 Password work was step 2: Launch the 1Password program, choose Help > Restart 1Password Helper, wait 10 seconds or more, and then relaunch the browser. I launched firefox again and selected the black key on the toolbar, entered the masterpassword and all my passwords, wallet, identities, etc. were there. I am so pleased it was such an easy fix. I love your program particularly because it syncs in the Drop Box cloud. That's realling the selling item for me. The 1 Password program is fantastic but unless it could automatically sync with all my other devices it would have limited use.

    If you have the time for a follow-up, and for gee whiz purposes, what is the Password helper file and what does it do? What action did I cause with the restart that wasn't happening when I installed the program? Thanks for the help! (rock) (hi)
  • khadkhad Social Choreographer

    Team Member
    edited September 2012
    Great news! Thanks for letting me know that everything is working well. :)

    The Helper is what we call the background process which is responsible for keyboard shortcuts, backups, and — most relevant to your situation — communicating between the main application and the sandboxed browser extension. If the Helper is unable to connect for some reason the data will not be "in sync" between the main application and the extension.

    From the aforelinked troubleshooting section of the User Guide:

    1Password manages the exchange of data between itself and the browser extensions through WebSocket connections. This allows the 1Password background process to communicate with the browser extensions while still respecting the “sandboxing” rules enforced by modern web browsers. Although they appear as network connections, they are limited to your local machine. These connections are also encrypted and authenticated, so they cannot be used to deliver information to any processes besides 1Password and its browser extensions.


    If the connections are blocked for any reason, the extension will not be able to connect to 1Password, and no data transfer can occur. The most common symptom of this problem is a “helper not connected” message from the browser extension. The simplest solution is to ensure that local connections are not blocked on 127.0.0.1 by a proxy server or software firewall.


    The specific ports that 1Password uses through its WebSocket connections are 6258, 10191, 14821, 24861, 25007, 38151, 46360, 49801, 55730, and 59483; but it’s much easier simply to allow all connections to 127.0.0.1 (localhost).


    If we can be of further assistance, please let us know. We are always here to help!
  • I had the same issue as decribed. In looking through the suggested resolution steps above the only one I had to do to fix the problem was turn off my Internet LAN Settings for Auto Detect. Steps to do this:

    Start> Control Panel> Internet Options
    Select the Connections Tab
    Click the LAN Settings Button
    Untick the "Automatically detect settings" option.

    Thanks for the tips! Problem solved :)
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Stephen! Sorry you had a bit of trouble, but I'm glad things are working well now.

    If we can be of further assistance, please let us know. We are always here to help!
This discussion has been closed.