Enabling both iCloud and Dropbox sync freezes/crashes app

Hey guys,

I purchased the new version of 1Password earlier today and installed it on both my iPad and iPhone, setting up the sync via both iCloud and Dropbox as I hadn't yet decided which to use. Upon doing so, the app would consistently freeze after the unlock screen with the settings icon animated in the bottom right corner. I assumed this was due to some kind of sync error, and confirmed that upon disabling "Documents & Data" for iCloud, the app would resume full functionality.

Not only that, but if at any time, the "Documents & Data" option in iCloud was turned back on, it would once again freeze -even if iCloud sync is disabled within the app-. The only way to turn it back on without causing a crash is to go into Settings > iCloud > Storage & Backup > Manage Storage and then hit Edit and delete the "onepassword" entry.

I'm currently sticking with just Dropbox sync as it covers more platforms anyway, but it took me a little while to figure out the problem and was on the verge of leaving bad feedback on the App Store before I solved it. I thought I'd do the right thing and let you know before those 1-star ratings start appearing!


  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, KitchenKnives! Thanks for taking the time to contact us. We really appreciate it. I'm sorry that you are having some trouble.

    1Password was designed to allow for simultaneous syncing via both iCloud and Dropbox, and I think pretty much everyone on the team here (as well as many other customers) have them both enabled. So there must be something more specific going on on your device (or with your iCloud account.) Let's see if we can get this resolved for you.

    Please remove the data from iCloud and then try restarting your device by holding down both the Home and Sleep buttons simultaneously for at least 10 seconds until the Apple logo appears. Does the issue persist after restarting your device?
  • Hey khad, I initially tried restarting my device with no luck, but after trying a second time the problem seems to have fixed itself. I guess it was a rarer bug than it originally seemed. Glad it's all working now though :)
  • khadkhad Social Choreographer

    Team Member
    Thanks for updating the thread with the good news. I'm glad everything is working well. :)
This discussion has been closed.