Internet Explorer locks up when adding a new password [FIXED in 1.0.9.BETA-314]

macrosmacros
edited January 2013 in 1Password 4 for Windows
Looking for a little bit of help. When I use 1Password with Windows 8, everything seems to work until I try to add a new password. When the system autodetects a login and prompts to store it, if I say yes.....the entire instance of IE locks completely. I can't switch tabs, I can't click the close button. I get a "Ding" sound anywhere I click. The password seems to store, but then I need to kill IE using task manager and reopen it to get it working again.

Any ideas?

Thanks in advance for any help you can provide!

Comments

  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, Macros! Thanks for taking the time to contact us. While we don't actually support pre-release versions of software (including and especially operating systems), I'm not able to reproduce the problem. Hopefully we can find the cause of it on your machine and get it resolved for you.

    Just our of curiosity, do you see the same issue using the current shipping releases of Windows 7 and Internet Explorer 9?
  • I'm actually running the release version of Windows 8 (Technet). But I do not have the same issue on Windows 7, nor on Firefox on the Windows 8 machine. It just seems to be relegated to IE 10 (in Desktop mode, as I have yet to use it in Metro mode).

    I doubt it will help much, but IE constantly complains about slow add-ons. And the issue only occurrs when I try to store a new password. All other functions seem to work fine.

    Thanks for your help Khad!
  • MikeTMikeT Agile Samurai

    Team Member
    Hi Macros,

    At the moment, 1Password doesn't support Internet Explorer 10. We haven't finish testing 1Password on Windows 8. Unfortunately, I don't have a timeframe on when we might have an update to fix the issue with Internet Explorer 10 but I can confirm the lock-up with the auto-save.

    For now, if you turn it off, it'll be more stable and you can always ask 1Password to save manually by pressing the 1Password button to save the Login but unfortunately, that'll also lock it up for 2-5 seconds.

    I recommend an alternative browser if you want a smoother experience such as Chrome.

    We'll try to get this fixed as fast as we can. I apologize for the inconvenience.
  • Mike -

    Thanks for the confirmation of the issue. I was worried it was just my machine as I thought I recall reading that others had used it successfully.

    I'll keep watching for the update.
  • macros wrote:

    When I use 1Password with Windows 8, everything seems to work until I try to add a new password. When the system autodetects a login and prompts to store it, if I say yes.....the entire instance of IE locks completely. I can't switch tabs, I can't click the close button. I get a "Ding" sound anywhere I click. The password seems to store, but then I need to kill IE using task manager and reopen it to get it working again.


    Can you please download 1.0.9.BETA-302 and try again? Thanks!
  • I'm using windows 7 and ie 9, and I have the same issue.
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, ediehl! If you are using completely different OS and browser versions it may very well not be the same issue. :)

    What version of 1Password are you using?
  • Hello,

    Sorry for the delay. I am still having this issue. It is happening on two different machines with two different OS's and IE Versions.

    Machine 1: Windows 8 Professional with IE 10. All patches applied. 1Password 1.0.9.305
    When trying to save any new site directly from IE, IE locks up. Cannot click the X button to close, cannot use the task bar to right-click and close. System continues to make a small "bing" noise when trying to click anywere on the IE window. Reminds me of when there is a modal window hidden on other applications. This has happened with any version of 1Password since September on Windows 8.

    Machine 2: Windows 7 Professional SP1 with IE 9.0. All patches applied. 1Password 1.0.9.305
    Exact same issue. Seemed to happen after latest install, previous to that it worked fine.

    Would love to be able to use the software to it's full potential, but up to now...it just doesn't seem to like me.

    Thanks for the help!
  • khadkhad Social Choreographer

    Team Member
    [font=helvetica, arial, sans-serif]Sorry to hear you're still having some trouble in Internet Explorer, macros. Please try resetting Internet Explorer which Microsoft describes as being a cure for this sort of behavior:[/font]

    [font=helvetica, arial, sans-serif]"Is browsing always slow in Internet Explorer? Does it frequently [/font]freeze[font=helvetica, arial, sans-serif] or crash?"[/font]

    http://support.micro...b/923737#showme

    [font=helvetica, arial, sans-serif]"When you reset Internet Explorer settings, all add-ins and customizations are deleted. You basically start with a fresh version of Internet Explorer. This article helps you reset Internet Explorer."[/font]

    [font=helvetica, arial, sans-serif]Just follow the instructions for Windows 8 and Windows 7 on the respective machines and let me know if you're still having trouble.[/font]
  • Hi all -

    I'm having IE trouble as well. My browser doesn't lock up at any specific time, but ever since installing 1Password extension about a week ago, IE uses a lot more memory according to Task Manager (several times seen it growing past 1G) , and it freezes/locks up a couple times a day. Can't click anywhere in it, or close normally, have to kill all iexplore.exe processes from TM and restart. IE9/WIN7-64, latest patches. Corporate laptop, forced to use IE. Haven't installed any other programs in last month.

    Second issue, when using extension to login to YahooMail, I sometimes get 403 Forbidden. It looks like it works when logging in, but then I always get that page. If I copy the p/w to the clipboard and manually login to Yahoo, it works.

    Any ideas on either?
  • khadkhad Social Choreographer

    Team Member
    Welcome to the forums, 76cardinal! I'm sorry that you are having some trouble. From your post it doesn't sound like you followed the steps mentioned in my reply directly above yours to reset Internet Explorer as a solution to the first issue you mentioned. Please be sure to follow those steps.



    Second issue, when using extension to login to YahooMail, I sometimes get 403 Forbidden. It looks like it works when logging in, but then I always get that page. If I copy the p/w to the clipboard and manually login to Yahoo, it works.

    It sounds like the wrong URL is saved in your Yahoo Login item. Please edit your Login item for Yahoo! Mail and make sure it is set to this:

    https://login.yahoo.com/config/login_verify2?&.src=ym

    If you're still having trouble with Yahoo! Mail, try saving a new Login item via the browser extension. If that doesn't work, please let me know in a new thread since it is a separate issue than the one this thread is for. We'll figure out what's happening. :)

    Cheers,
  • khad wrote:

    [font=helvetica, arial, sans-serif]Sorry to hear you're still having some trouble in Internet Explorer, macros. Please try resetting Internet Explorer which Microsoft describes as being a cure for this sort of behavior:[/font]

    [font=helvetica, arial, sans-serif]"Is browsing always slow in Internet Explorer? Does it frequently [/font]freeze[font=helvetica, arial, sans-serif] or crash?"[/font]

    http://support.micro...b/923737#showme

    [font=helvetica, arial, sans-serif]"When you reset Internet Explorer settings, all add-ins and customizations are deleted. You basically start with a fresh version of Internet Explorer. This article helps you reset Internet Explorer."[/font]

    [font=helvetica, arial, sans-serif]Just follow the instructions for Windows 8 and Windows 7 on the respective machines and let me know if you're still having trouble.[/font]
    I have good news and bad news, the instructions did resolve the issue with the Windows 7 box. But the issue remains with Windows 8 and IE 10. In response to your questions, IE continually notifies me that disabling add-ons could improve its speed (the only add-on it recommends disabling is 1Password, go figure). What happens is anytime I go to a site and enter in a username and password, 1Password will prompt me to save. If I do save, it will then prompt me for my Unlock code. At which point, all 1Password prompts go away and IE completely locks up. Click anywhere on IE will produce a "Ding!" sound. I cannot click X to close IE, I cannot switch tabs, it is completely frozen. As I mentioned before, it reminds me of times when a modal dialog box somehow appears in the background of a program and you cannot dismiss it. My only recourse at that point is to go into task manager and end the IE task. This happens EVERY time I try to save a password.
  • khadkhad Social Choreographer

    Team Member

    Version 1.0.9.BETA-313 might fix this.

    https://agilebits.com/onepassword/win/release_notes (click on "Show Betas")

    Can you please download 1.0.9.BETA-313 and confirm the fix?

    If the problem is still there, can you tell us what web site you're experiencing this problem with? (I have tried gmail.com for example and could not reproduce the problem)

    Thanks!

  • Thanks guys! The old forums had a reply by Stefan von Dutch to try 1.0.9.BETA-314 and that worked! 1Password is finally working in Windows 8 Desktop mode as it should. No more lockups!

    Khad, I didn't try 1.0.9.BETA-313 so I'm not sure if that would have worked or the additional changes in 314 finally fixed whatever it was that I was running into. Either way, thanks for the continued effort!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi Macros,

    That's great news, I'm glad it's working better now.

This discussion has been closed.