Problem with custom folder and USB syncing with 1P4

edited August 2013 in 1Password 6 Beta

I use 1Password 4 Beta on Mac and iOS.

If I use 1Passwords default suggested folder for Mac (the container one) everything syncs fine.

But if I set a custom folder for my agile keychain (i.e. username/my things/1password.agliekeychain) the USB sync tool claims 'cannot find local data file on the Mac' even though 1Password 4 Beta mac works just fine with it.

Can you please help me get USB syncing back? Perhaps there is a way to specify the location in the USB tool, as apposed to having it set automatically?


  • sandjsandj
    edited August 2013

    Hi there,

    I like the USB syncing tool. If I use a default folder set by 1Password Mac, it works great.

    But in 1Password 4 for Mac (beta) if I set a custom folder for my agilekeychain file (lets say - username/documents/1Password) when I attempt a sync it reports 'Cannot find local data file on this Mac'.

    I have ensured 1Password 3 (MAS edition) is uninstalled and even did a thorough cleansing to remove all traces of it.

    Could you please help me get USB syncing back? Or perhaps add an option to the USB tool to either 'detect agilekeychain automatically' or 'specify a location'?

  • MrCMrC Community Moderator

    I just did this. On the iDevice, in 1Password, I deleted the data file (under Settings > Advanced). In iTunes, I went to the devices App section, and found 1Password under File Sharing, and Add the new keychain file location, and then synced. USB syncing should work after this.

  • sandjsandj
    edited August 2013

    Thanks for reply and I tried your instructions... still no luck...

    • 1Password 4 BETA on Mac Mountain Lion
    • 1 Password 4 on iOS 6
    • Mac setup to 'sync to folder'

    When I run USB Sync tool it claims 'Cannot find local data file on this Mac'

    If I stop folder syncing - it works

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    USB sync does not yet support the flexible locations offered by Folder Sync. The problem is that right now, the beta version of the USB Sync tool only works in pre-defined locations such as the Home > Library > Application Support > 1Password folder and Dropbox or Dropbox > 1Password folders.

    We do plan to update our USB sync tool to work with 1Password 4's folder sync but I don't have a timeframe right now on when it'll be updated.

    What you can do is tell Folder Sync to sync to Home > Library > Application Support > 1Password, and that'll let it pick it up.

  • MrCMrC Community Moderator

    Sorry, I must have misunderstood sandj's goals. I have the old keychain (from 1P3) in a custom location, and 1P4 keeps it up to date. I had assumed that USB sync is using that data.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @MrC,

    It's a good assumption and it is what we want to do but USB Sync was released early this year in Jan, so it doesn't have all the data it needs to work with 1Password 4 just yet. We'll get it in sync.

  • Hello again
    Any more news on this? Currently I have to sync via iTunes. Not fun.

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @sandj,

    No news on this. We're working on bringing back the Wi-Fi sync, which is just released in beta 60. We're working on an iOS update to implement the Wi-Fi sync there. Once that update is released, the Wi-Fi sync will then be used for direct syncing between 1Password 4 for OS X and 1Password 4 for iOS.

    There's a good chance that we might replace the USB sync with the Wi-Fi sync if it works out well.

  • Is there an ETA on that then? This is truly terrible. I was thinking that I could use folder sync to keep my 3 Macs in line and then USB to my iPhone and iPad for the time being. Problem is, the Mac that I USB to isn't the "host" of the data file, so USB sync doesn't see it.

    Ugh. You guys have literally ZERO WORKING SOLUTIONS for people with multiple devices who don't want their data on a third-party server. What's up with that?

  • @molvetica, I think your last comment is a little unfair. I have 1P4 on my MacBook and 1P4 for iOS on my iPad. I sync perfectly satisfactorily to the iPad by transferring the keychain via iTunes. Is there some reason you aren't able to do that? (I know it's not hugely elegant, but it does work!)


  • molveticamolvetica
    edited September 2013

    @Stephen_C, That would work if I wanted to go into the guest room closet, plug my phone into my "headless" (no monitor) Mac Mini home server, then go back downstairs to my iMac, remote in to the server and transfer from iTunes. Then repeat the process with my iPad as well -- every time I have an update to my keychain. That's hardly a solution.

    I understand that there are workarounds in place for people with one Mac, but it gets hairy if you throw more computers into the mix. Especially if you use a home server. The iOS devices in my home don't sync with the iTunes libraries on the Macs that are personally used. They sync with the server. The USB sync utility should work with my personal Mac since I've given the machine read/write privileges to the network-mapped server directory containing my agilekeychain, but alas, it only looks for the keychain in the default directory on the machine I'm physically using. It's not there, obviously.

    Basically, I'm boned unless I want to use iCloud or Dropbox. It's pretty shocking that those are the choices I'm left with, especially in the post-PRISM world we currently inhabit. Pretty shortsighted of AgileBits to think that cloud syncing would be the way to go moving forward.

  • @molvetica, I can see there may be usability problems for you with what I suggested. Nevertheless, it's not exactly "zero working solutions" for the average mortal...and wifi sync is on the way (indeed, you can test the beta if you want.


  • So I exported my old 1PW3 data to .1pif file, deleted all 1PW4 data on my Mac and re-installed as a "new" user. I then imported the .1pif file and set 1PW4 to sync to the folder "Home > Library > Application Support > 1Password" as directed by @MikeT. I then deleted/re-downloaded the USB sync tool and tried to sync. Same error as before. "Cannot find local data file on this Mac."

    Any ideas?

This discussion has been closed.